diff mbox series

mm/madvise: replace with page_size() in madvise_inject_error()

Message ID 29dce60c-38d6-0220-f292-e298f0c78c4d@huawei.com (mailing list archive)
State New, archived
Headers show
Series mm/madvise: replace with page_size() in madvise_inject_error() | expand

Commit Message

Yunfeng Ye Nov. 6, 2019, 7:06 a.m. UTC
The function page_size() is supported after the commit a50b854e073c
("mm: introduce page_size()").

Replace with page_size() in madvise_inject_error() for readability.

Signed-off-by: Yunfeng Ye <yeyunfeng@huawei.com>
---
 mm/madvise.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

David Rientjes Nov. 6, 2019, 9:28 p.m. UTC | #1
On Wed, 6 Nov 2019, Yunfeng Ye wrote:

> The function page_size() is supported after the commit a50b854e073c
> ("mm: introduce page_size()").
> 
> Replace with page_size() in madvise_inject_error() for readability.
> 
> Signed-off-by: Yunfeng Ye <yeyunfeng@huawei.com>
> ---
>  mm/madvise.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/mm/madvise.c b/mm/madvise.c
> index 2be9f3fdb05e..38c4e7fcf850 100644
> --- a/mm/madvise.c
> +++ b/mm/madvise.c
> @@ -856,13 +856,13 @@ static int madvise_inject_error(int behavior,
>  {
>  	struct page *page;
>  	struct zone *zone;
> -	unsigned int order;
> +	unsigned int size;

Should be unsinged long.

> 
>  	if (!capable(CAP_SYS_ADMIN))
>  		return -EPERM;
> 
> 
> -	for (; start < end; start += PAGE_SIZE << order) {
> +	for (; start < end; start += size) {
>  		unsigned long pfn;
>  		int ret;
> 
> @@ -874,9 +874,9 @@ static int madvise_inject_error(int behavior,
>  		/*
>  		 * When soft offlining hugepages, after migrating the page
>  		 * we dissolve it, therefore in the second loop "page" will
> -		 * no longer be a compound page, and order will be 0.
> +		 * no longer be a compound page.
>  		 */
> -		order = compound_order(compound_head(page));
> +		size = page_size(compound_head(page));
> 
>  		if (PageHWPoison(page)) {
>  			put_page(page);
Yunfeng Ye Nov. 7, 2019, 2:05 a.m. UTC | #2
On 2019/11/7 5:28, David Rientjes wrote:
> On Wed, 6 Nov 2019, Yunfeng Ye wrote:
> 
>> The function page_size() is supported after the commit a50b854e073c
>> ("mm: introduce page_size()").
>>
>> Replace with page_size() in madvise_inject_error() for readability.
>>
>> Signed-off-by: Yunfeng Ye <yeyunfeng@huawei.com>
>> ---
>>  mm/madvise.c | 8 ++++----
>>  1 file changed, 4 insertions(+), 4 deletions(-)
>>
>> diff --git a/mm/madvise.c b/mm/madvise.c
>> index 2be9f3fdb05e..38c4e7fcf850 100644
>> --- a/mm/madvise.c
>> +++ b/mm/madvise.c
>> @@ -856,13 +856,13 @@ static int madvise_inject_error(int behavior,
>>  {
>>  	struct page *page;
>>  	struct zone *zone;
>> -	unsigned int order;
>> +	unsigned int size;
> 
> Should be unsinged long.
> 
ok, thanks. Andrew has already help me modify the patch and add to -mm tree.

>>
>>  	if (!capable(CAP_SYS_ADMIN))
>>  		return -EPERM;
>>
>>
>> -	for (; start < end; start += PAGE_SIZE << order) {
>> +	for (; start < end; start += size) {
>>  		unsigned long pfn;
>>  		int ret;
>>
>> @@ -874,9 +874,9 @@ static int madvise_inject_error(int behavior,
>>  		/*
>>  		 * When soft offlining hugepages, after migrating the page
>>  		 * we dissolve it, therefore in the second loop "page" will
>> -		 * no longer be a compound page, and order will be 0.
>> +		 * no longer be a compound page.
>>  		 */
>> -		order = compound_order(compound_head(page));
>> +		size = page_size(compound_head(page));
>>
>>  		if (PageHWPoison(page)) {
>>  			put_page(page);
> 
> .
>
David Rientjes Nov. 7, 2019, 8:48 p.m. UTC | #3
On Thu, 7 Nov 2019, Yunfeng Ye wrote:

> >> The function page_size() is supported after the commit a50b854e073c
> >> ("mm: introduce page_size()").
> >>
> >> Replace with page_size() in madvise_inject_error() for readability.
> >>
> >> Signed-off-by: Yunfeng Ye <yeyunfeng@huawei.com>
> >> ---
> >>  mm/madvise.c | 8 ++++----
> >>  1 file changed, 4 insertions(+), 4 deletions(-)
> >>
> >> diff --git a/mm/madvise.c b/mm/madvise.c
> >> index 2be9f3fdb05e..38c4e7fcf850 100644
> >> --- a/mm/madvise.c
> >> +++ b/mm/madvise.c
> >> @@ -856,13 +856,13 @@ static int madvise_inject_error(int behavior,
> >>  {
> >>  	struct page *page;
> >>  	struct zone *zone;
> >> -	unsigned int order;
> >> +	unsigned int size;
> > 
> > Should be unsinged long.
> > 
> ok, thanks. Andrew has already help me modify the patch and add to -mm tree.
> 

Good deal, in that case:

Acked-by: David Rientjes <rientjes@google.com>
diff mbox series

Patch

diff --git a/mm/madvise.c b/mm/madvise.c
index 2be9f3fdb05e..38c4e7fcf850 100644
--- a/mm/madvise.c
+++ b/mm/madvise.c
@@ -856,13 +856,13 @@  static int madvise_inject_error(int behavior,
 {
 	struct page *page;
 	struct zone *zone;
-	unsigned int order;
+	unsigned int size;

 	if (!capable(CAP_SYS_ADMIN))
 		return -EPERM;


-	for (; start < end; start += PAGE_SIZE << order) {
+	for (; start < end; start += size) {
 		unsigned long pfn;
 		int ret;

@@ -874,9 +874,9 @@  static int madvise_inject_error(int behavior,
 		/*
 		 * When soft offlining hugepages, after migrating the page
 		 * we dissolve it, therefore in the second loop "page" will
-		 * no longer be a compound page, and order will be 0.
+		 * no longer be a compound page.
 		 */
-		order = compound_order(compound_head(page));
+		size = page_size(compound_head(page));

 		if (PageHWPoison(page)) {
 			put_page(page);