mbox series

[RFC,00/11] mmc: rename mmc_can_* functions

Message ID 20250401095847.29271-1-wsa+renesas@sang-engineering.com (mailing list archive)
Headers show
Series mmc: rename mmc_can_* functions | expand

Message

Wolfram Sang April 1, 2025, 9:58 a.m. UTC
As mentioned in [1], here is a series which rename mmc_can_* functions
to names which include 'card' or 'host' in the name. I am only an
occasional MMC core hacker, and these namings would have made my life
quite easier in past times. So, here is my proposed change. Have a look
and let me know if you like it. Plain RFC for now. Notes:

* This series is based on [1] which needs changes. My idea would be to
  respin the series on rc1 right after it is out.
* I intentionally left mmc_can_retune() out because it seems more
  consistent with all the other mmc_*_retune() functions
* Builds fine locally, tested on a Renesas Salvator-X with R-Car M3-W.
  buildbots still need to check it, branch is here:
  git://git.kernel.org/pub/scm/linux/kernel/git/wsa/linux.git renesas/mmc/unbind-power-off

What do you think?


[1] https://lore.kernel.org/r/20250320140040.162416-1-ulf.hansson@linaro.org

Wolfram Sang (11):
  mmc: rename mmc_can_discard() to mmc_card_can_discard()
  mmc: rename mmc_can_erase() to mmc_card_can_erase()
  mmc: rename mmc_can_ext_csd() to mmc_card_can_ext_csd()
  mmc: rename mmc_can_poweroff_notify() to
    mmc_card_can_poweroff_notify()
  mmc: rename mmc_can_reset() to mmc_card_can_reset()
  mmc: rename mmc_can_sanitize() to mmc_card_can_sanitize()
  mmc: rename mmc_can_secure_erase_trim() to
    mmc_card_can_secure_erase_trim()
  mmc: rename mmc_can_sleep() to mmc_card_can_sleep()
  mmc: rename mmc_can_trim() to mmc_card_can_trim()
  mmc: rename mmc_can_gpio_cd() to mmc_host_can_gpio_cd()
  mmc: rename mmc_can_gpio_ro() to mmc_host_can_gpio_ro()

 drivers/mmc/core/block.c             |  6 ++--
 drivers/mmc/core/core.c              | 48 ++++++++++++----------------
 drivers/mmc/core/core.h              | 10 +++---
 drivers/mmc/core/mmc.c               | 30 ++++++++---------
 drivers/mmc/core/mmc_ops.c           |  6 ++--
 drivers/mmc/core/mmc_ops.h           |  2 +-
 drivers/mmc/core/mmc_test.c          | 12 +++----
 drivers/mmc/core/queue.c             |  6 ++--
 drivers/mmc/core/slot-gpio.c         |  8 ++---
 drivers/mmc/host/dw_mmc.c            |  6 ++--
 drivers/mmc/host/mtk-sd.c            |  2 +-
 drivers/mmc/host/renesas_sdhi_core.c |  2 +-
 drivers/mmc/host/sdhci-omap.c        |  2 +-
 drivers/mmc/host/sdhci.c             |  6 ++--
 drivers/mmc/host/sunplus-mmc.c       |  2 +-
 drivers/mmc/host/tmio_mmc_core.c     |  6 ++--
 include/linux/mmc/slot-gpio.h        |  4 +--
 17 files changed, 74 insertions(+), 84 deletions(-)