diff mbox series

[RFC,08/11] mmc: rename mmc_can_sleep() to mmc_card_can_sleep()

Message ID 20250401095847.29271-9-wsa+renesas@sang-engineering.com (mailing list archive)
State New
Headers show
Series mmc: rename mmc_can_* functions | expand

Commit Message

Wolfram Sang April 1, 2025, 9:58 a.m. UTC
mmc_can_* functions sometimes relate to the card and sometimes to the host.
Make it obvious by renaming this function to include 'card'. Also, convert to
proper bool type while we are here.

Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
---
 drivers/mmc/core/mmc.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/drivers/mmc/core/mmc.c b/drivers/mmc/core/mmc.c
index 8fde20ba3d95..80bb0a68b037 100644
--- a/drivers/mmc/core/mmc.c
+++ b/drivers/mmc/core/mmc.c
@@ -1955,7 +1955,7 @@  static int mmc_init_card(struct mmc_host *host, u32 ocr,
 	return err;
 }
 
-static int mmc_can_sleep(struct mmc_card *card)
+static bool mmc_card_can_sleep(struct mmc_card *card)
 {
 	return card->ext_csd.rev >= 3;
 }
@@ -2140,7 +2140,7 @@  pr_info("%s: reason %d, may_notify %d\n", mmc_hostname(host), pm_type, mmc_may_p
 	if (mmc_card_can_poweroff_notify(host->card) &&
 	    mmc_may_poweroff_notify(host, pm_type))
 		err = mmc_poweroff_notify(host->card, notify_type);
-	else if (mmc_can_sleep(host->card))
+	else if (mmc_card_can_sleep(host->card))
 		err = mmc_sleep(host);
 	else if (!mmc_host_is_spi(host))
 		err = mmc_deselect_cards(host);