mbox series

[v8,0/9] kallsyms: Optimizes the performance of lookup symbols

Message ID 20221102084921.1615-1-thunder.leizhen@huawei.com (mailing list archive)
Headers show
Series kallsyms: Optimizes the performance of lookup symbols | expand

Message

Zhen Lei Nov. 2, 2022, 8:49 a.m. UTC
v7 --> v8:
Sort the symbols by name and implement kallsyms_lookup_name() using a binary
search. The performance is more than 20 times higher than that of v7. Of course,
the memory overhead is also extended to (3 * kallsyms_num_syms) bytes. Discard
all implementations of compression and then comparison in v7.

In addition, all sparse warnings about kallsyms_selftest.c are cleared.


v6 --> v7:
1. Improve the performance of kallsyms_lookup_name() when CONFIG_LTO_CLANG=y
   To achieve this, restrict '.' to be at the beginning of a substring, not in
   the middle or end.
2. kallsyms_selftest.c adds support for CONFIG_LTO_CLANG=y.
3. Patches 4-6 are rearranged, centralize implementations of the same
   functionality in one patch, rather than split it based on whether it
   belongs to the tool or kernel.
4. Due to the impact of the following patches, some adaptations are made.
   aa221f2ea58655f kallsyms: take the input file instead of reading stdin
   73bbb94466fd3f8 kallsyms: support "big" kernel symbols
   dfb352ab1162f73 kallsyms: Drop CONFIG_CFI_CLANG workarounds


v5 --> v6:
1. Add patch 6/11, kallsyms: Add helper kallsyms_lookup_clang_name()
2. Update commit message of patch 9/11.

v4 --> v5:
1. In scripts/kallsyms.c, we use an extra field to hold type and eventually
   put it together with name in write_src().
2. Generate a new table kallsyms_best_token_table[], so that we compress a
   symbol in the kernel using a process similar to compress_symbol().
3. Remove helper sym_name(), and rename field 'sym[]' to 'name[]' in
   scripts/kallsyms.c
4. Add helper __kallsyms_lookup_compressed_name() to avoid duplicate code in
   functions kallsyms_lookup_name() and kallsyms_on_each_match_symbol().
5. Add a new parameter "const char *modname" to module_kallsyms_on_each_symbol(),
   this makes the code logic clearer.
6. Delete the parameter 'struct module *' in the hook function associated with
   kallsyms_on_each_symbol(), it's unused now.

v3 --> v4:
1. Move the declaration of function kallsyms_sym_address() to linux/kallsyms.h,
   fix a build warning.

v2 --> v3:
1. Improve test cases, perform complete functional tests on functions
   kallsyms_lookup_name(), kallsyms_on_each_symbol() and
   kallsyms_on_each_match_symbol().
2. Add patch [PATCH v3 2/8] scripts/kallsyms: ensure that all possible
   combinations are compressed.
3. The symbol type is not compressed regardless of whether
   CONFIG_KALLSYMS_ALL is set or not. The memory overhead is increased
   by less than 20KiB if CONFIG_KALLSYMS_ALL=n.
4. Discard [PATCH v2 3/8] kallsyms: Adjust the types of some local variables

v1 --> v2:
Add self-test facility

v1:
Currently, to search for a symbol, we need to expand the symbols in
'kallsyms_names' one by one, and then use the expanded string for
comparison. This is very slow.

In fact, we can first compress the name being looked up and then use
it for comparison when traversing 'kallsyms_names'.

This patch series optimizes the performance of function kallsyms_lookup_name(),
and function klp_find_object_symbol() in the livepatch module. Based on the
test results, the performance overhead is reduced to 5%. That is, the
performance of these functions is improved by 20 times.

To avoid increasing the kernel size in non-debug mode, the optimization is only
for the case CONFIG_KALLSYMS_ALL=y.


Zhen Lei (9):
  scripts/kallsyms: rename build_initial_tok_table()
  kallsyms: Improve the performance of kallsyms_lookup_name()
  kallsyms: Correctly sequence symbols when CONFIG_LTO_CLANG=y
  kallsyms: Reduce the memory occupied by kallsyms_seqs_of_names[]
  kallsyms: Add helper kallsyms_on_each_match_symbol()
  livepatch: Use kallsyms_on_each_match_symbol() to improve performance
  livepatch: Improve the search performance of
    module_kallsyms_on_each_symbol()
  kallsyms: Delete an unused parameter related to
    kallsyms_on_each_symbol()
  kallsyms: Add self-test facility

 include/linux/kallsyms.h   |  12 +-
 include/linux/module.h     |   4 +-
 init/Kconfig               |  13 +
 kernel/Makefile            |   1 +
 kernel/kallsyms.c          | 121 +++++++--
 kernel/kallsyms_internal.h |   1 +
 kernel/kallsyms_selftest.c | 485 +++++++++++++++++++++++++++++++++++++
 kernel/kallsyms_selftest.h |  13 +
 kernel/livepatch/core.c    |  31 ++-
 kernel/module/kallsyms.c   |  15 +-
 kernel/trace/ftrace.c      |   3 +-
 scripts/kallsyms.c         |  78 +++++-
 scripts/link-vmlinux.sh    |   4 +
 13 files changed, 743 insertions(+), 38 deletions(-)
 create mode 100644 kernel/kallsyms_selftest.c
 create mode 100644 kernel/kallsyms_selftest.h

Comments

Luis Chamberlain Nov. 13, 2022, 2:44 a.m. UTC | #1
On Wed, Nov 02, 2022 at 04:49:12PM +0800, Zhen Lei wrote:
> v7 --> v8:
> Sort the symbols by name and implement kallsyms_lookup_name() using a binary
> search. The performance is more than 20 times higher than that of v7. Of course,
> the memory overhead is also extended to (3 * kallsyms_num_syms) bytes. Discard
> all implementations of compression and then comparison in v7.
> 
> In addition, all sparse warnings about kallsyms_selftest.c are cleared.

Awesome work, I can't find a single thing I hate about this, but my
biggest conern is the lack of testing so I'm going to merge this to
Luis Chamberlain Nov. 13, 2022, 2:55 a.m. UTC | #2
On Sat, Nov 12, 2022 at 06:44:26PM -0800, Luis Chamberlain wrote:
> On Wed, Nov 02, 2022 at 04:49:12PM +0800, Zhen Lei wrote:
> > v7 --> v8:
> > Sort the symbols by name and implement kallsyms_lookup_name() using a binary
> > search. The performance is more than 20 times higher than that of v7. Of course,
> > the memory overhead is also extended to (3 * kallsyms_num_syms) bytes. Discard
> > all implementations of compression and then comparison in v7.
> > 
> > In addition, all sparse warnings about kallsyms_selftest.c are cleared.
> 
> Awesome work, I can't find a single thing I hate about this, but my
> biggest conern is the lack of testing so I'm going to merge this to

Sorry finished the email too fast, I just wanted to add Nick to the
thread as his work does tons of changes on scripts/kallsyms.c.

I was saying -- I'm just concern with the lack of testing so I have merged
this to modules-next and see what explodes over the next few weeks.
I'm also happy to drop this from modules-next and have it go through
the livepatching tree instead, but given Nick's work is dedicated
towards modules and it also touches on scripts/kallsyms.c a lot, to
avoid conflicts it felt best to merge that to modules for now in case
his changes get merged during the next merge window.

Let me know what folks prefer.

Obviously, if testing blows up we can drop the series.

Zhen, wouldn't ftrace benefit from the same
s/kallsyms_on_each_symbol/kallsyms_on_each_match_symbol ?

  Luis
Zhen Lei Nov. 14, 2022, 1:25 a.m. UTC | #3
On 2022/11/13 10:55, Luis Chamberlain wrote:
> On Sat, Nov 12, 2022 at 06:44:26PM -0800, Luis Chamberlain wrote:
>> On Wed, Nov 02, 2022 at 04:49:12PM +0800, Zhen Lei wrote:
>>> v7 --> v8:
>>> Sort the symbols by name and implement kallsyms_lookup_name() using a binary
>>> search. The performance is more than 20 times higher than that of v7. Of course,
>>> the memory overhead is also extended to (3 * kallsyms_num_syms) bytes. Discard
>>> all implementations of compression and then comparison in v7.
>>>
>>> In addition, all sparse warnings about kallsyms_selftest.c are cleared.
>>
>> Awesome work, I can't find a single thing I hate about this, but my
>> biggest conern is the lack of testing so I'm going to merge this to
> 
> Sorry finished the email too fast, I just wanted to add Nick to the
> thread as his work does tons of changes on scripts/kallsyms.c.
> 
> I was saying -- I'm just concern with the lack of testing so I have merged
> this to modules-next and see what explodes over the next few weeks.
> I'm also happy to drop this from modules-next and have it go through
> the livepatching tree instead, but given Nick's work is dedicated
> towards modules and it also touches on scripts/kallsyms.c a lot, to
> avoid conflicts it felt best to merge that to modules for now in case
> his changes get merged during the next merge window.
> 
> Let me know what folks prefer.
> 
> Obviously, if testing blows up we can drop the series.
> 
> Zhen, wouldn't ftrace benefit from the same
> s/kallsyms_on_each_symbol/kallsyms_on_each_match_symbol ?

ftrace uses regular matching, so it cannot be replaced.

> 
>   Luis
> .
>