mbox series

[v2,0/4] Miscellaneous cleanups

Message ID cover.1645542447.git.christophe.leroy@csgroup.eu (mailing list archive)
Headers show
Series Miscellaneous cleanups | expand

Message

Christophe Leroy Feb. 22, 2022, 3:12 p.m. UTC
This series applies on top of my series "Allocate module text and data separately" v5.

It does some cleanup around the settling of modules's layout page flags:
- Make module_enable_x() independent of CONFIG_ARCH_HAS_STRICT_MODULE_RWX
- Reunify everything into strict_rwx.c
- Change big hammer BUG_ON()s into WARN_ON()s
- Change misleading debug_align() to strict_align()

Changes in v2:
- Rebased on top of my series "Allocate module text and data separately" v5
- Moved the Kconfig patch out of this series, it is an independent change

Christophe Leroy (4):
  module: Make module_enable_x() independent of
    CONFIG_ARCH_HAS_STRICT_MODULE_RWX
  module: Move module_enable_x() and frob_text() in strict_rwx.c
  module: Rework layout alignment to avoid BUG_ON()s
  module: Rename debug_align() as strict_align()

 kernel/module/Makefile     |  3 +-
 kernel/module/internal.h   | 26 +++----------
 kernel/module/kallsyms.c   |  4 +-
 kernel/module/main.c       | 58 ++++++-----------------------
 kernel/module/strict_rwx.c | 76 +++++++++++++++++++++++++++++++++-----
 5 files changed, 88 insertions(+), 79 deletions(-)

Comments

Christophe Leroy Feb. 22, 2022, 3:14 p.m. UTC | #1
Le 22/02/2022 à 16:12, Christophe Leroy a écrit :
> This series applies on top of my series "Allocate module text and data separately" v5.
> 
> It does some cleanup around the settling of modules's layout page flags:
> - Make module_enable_x() independent of CONFIG_ARCH_HAS_STRICT_MODULE_RWX
> - Reunify everything into strict_rwx.c
> - Change big hammer BUG_ON()s into WARN_ON()s
> - Change misleading debug_align() to strict_align()

Seems like I made a big mess with v2.

I will resend it as v3.

Sorry for that.

Christophe

> 
> Changes in v2:
> - Rebased on top of my series "Allocate module text and data separately" v5
> - Moved the Kconfig patch out of this series, it is an independent change
> 
> Christophe Leroy (4):
>    module: Make module_enable_x() independent of
>      CONFIG_ARCH_HAS_STRICT_MODULE_RWX
>    module: Move module_enable_x() and frob_text() in strict_rwx.c
>    module: Rework layout alignment to avoid BUG_ON()s
>    module: Rename debug_align() as strict_align()
> 
>   kernel/module/Makefile     |  3 +-
>   kernel/module/internal.h   | 26 +++----------
>   kernel/module/kallsyms.c   |  4 +-
>   kernel/module/main.c       | 58 ++++++-----------------------
>   kernel/module/strict_rwx.c | 76 +++++++++++++++++++++++++++++++++-----
>   5 files changed, 88 insertions(+), 79 deletions(-)
>