Message ID | 20230720133454.38695-1-jlayton@kernel.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | nfsd: add a MODULE_DESCRIPTION | expand |
> On Jul 20, 2023, at 9:34 AM, Jeff Layton <jlayton@kernel.org> wrote: > > I got this today from modpost: > > WARNING: modpost: missing MODULE_DESCRIPTION() in fs/nfsd/nfsd.o > > Add a module description. > > Signed-off-by: Jeff Layton <jlayton@kernel.org> > --- > fs/nfsd/nfsctl.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/fs/nfsd/nfsctl.c b/fs/nfsd/nfsctl.c > index 1b8b1aab9a15..7070969a38b5 100644 > --- a/fs/nfsd/nfsctl.c > +++ b/fs/nfsd/nfsctl.c > @@ -1626,6 +1626,7 @@ static void __exit exit_nfsd(void) > } > > MODULE_AUTHOR("Olaf Kirch <okir@monad.swb.de>"); > +MODULE_DESCRIPTION("The Linux kernel NFS server"); > MODULE_LICENSE("GPL"); > module_init(init_nfsd) > module_exit(exit_nfsd) > -- > 2.41.0 > Applied to nfsd-next. If you have a lore.kernel.org link, please pass it along and I will add it. -- Chuck Lever
On Thu, 20 Jul 2023, Jeff Layton wrote: > I got this today from modpost: > > WARNING: modpost: missing MODULE_DESCRIPTION() in fs/nfsd/nfsd.o > > Add a module description. > > Signed-off-by: Jeff Layton <jlayton@kernel.org> > --- > fs/nfsd/nfsctl.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/fs/nfsd/nfsctl.c b/fs/nfsd/nfsctl.c > index 1b8b1aab9a15..7070969a38b5 100644 > --- a/fs/nfsd/nfsctl.c > +++ b/fs/nfsd/nfsctl.c > @@ -1626,6 +1626,7 @@ static void __exit exit_nfsd(void) > } > > MODULE_AUTHOR("Olaf Kirch <okir@monad.swb.de>"); > +MODULE_DESCRIPTION("The Linux kernel NFS server"); Of 9176 MODULE_DESCRIPTIONs in Linux, 21 start with "The ". Does having that word add anything useful? Amusingly 129 end with a period. I wonder what Jon Corbet would prefer :-) A few tell us what the module does. "Measures" "Provides".... Do we want "Implements" ?? 232 start "Driver " and 214 are "Driver for".... Should we have "Server for" ?? 26 start "Linux" ... which seems a bit redundant 12 contain "for Linux". 67 mention linux in some way. 28 contain the word "kernel" - also redundant. Only three (others) mention "Linux kernel" drivers/pcmcia/cs.c:MODULE_DESCRIPTION("Linux Kernel Card Services"); fs/ksmbd/server.c:MODULE_DESCRIPTION("Linux kernel CIFS/SMB SERVER"); fs/orangefs/orangefs-mod.c:MODULE_DESCRIPTION("The Linux Kernel VFS interface to ORANGEFS"); hmmm.. 192 contain the word "module". Fortunately none say "Linux kernel module for ..." I would have found that to be a step too far. I'd like to suggest "Implements Server for NFS - v2, 3, v4.{0,1,2}" But that would require excessive #ifdef magic to get right. A small part of me wants to suggest: "nfsd" but maybe I'm just in a whimsical mood today. NeilBrown > MODULE_LICENSE("GPL"); > module_init(init_nfsd) > module_exit(exit_nfsd) > -- > 2.41.0 > >
On Fri, Jul 21, 2023 at 08:07:16AM +1000, NeilBrown wrote: > On Thu, 20 Jul 2023, Jeff Layton wrote: > > I got this today from modpost: > > > > WARNING: modpost: missing MODULE_DESCRIPTION() in fs/nfsd/nfsd.o > > > > Add a module description. > > > > Signed-off-by: Jeff Layton <jlayton@kernel.org> > > --- > > fs/nfsd/nfsctl.c | 1 + > > 1 file changed, 1 insertion(+) > > > > diff --git a/fs/nfsd/nfsctl.c b/fs/nfsd/nfsctl.c > > index 1b8b1aab9a15..7070969a38b5 100644 > > --- a/fs/nfsd/nfsctl.c > > +++ b/fs/nfsd/nfsctl.c > > @@ -1626,6 +1626,7 @@ static void __exit exit_nfsd(void) > > } > > > > MODULE_AUTHOR("Olaf Kirch <okir@monad.swb.de>"); > > +MODULE_DESCRIPTION("The Linux kernel NFS server"); > > Of 9176 MODULE_DESCRIPTIONs in Linux, 21 start with "The ". > Does having that word add anything useful? > Amusingly 129 end with a period. I wonder what Jon Corbet would prefer > :-) The Ohio State University has set a bad precedent. I think we can drop "The". > A few tell us what the module does. > "Measures" "Provides".... > Do we want "Implements" ?? I don't find "Implements" to be either conventional or illuminating. > 232 start "Driver " and 214 are "Driver for".... > Should we have "Server for" ?? > > 26 start "Linux" ... which seems a bit redundant > 12 contain "for Linux". 67 mention linux in some way. > 28 contain the word "kernel" - also redundant. > Only three (others) mention "Linux kernel" One of which is the new in-kernel SMB server, interestingly. I don't think "Linux kernel" or even "in-kernel" is needed here. Both should be obvious from the context. > drivers/pcmcia/cs.c:MODULE_DESCRIPTION("Linux Kernel Card Services"); > fs/ksmbd/server.c:MODULE_DESCRIPTION("Linux kernel CIFS/SMB SERVER"); > fs/orangefs/orangefs-mod.c:MODULE_DESCRIPTION("The Linux Kernel VFS interface to ORANGEFS"); > > hmmm.. 192 contain the word "module". Fortunately none say > "Linux kernel module for ..." > I would have found that to be a step too far. > > I'd like to suggest > > "Implements Server for NFS - v2, 3, v4.{0,1,2}" > > But that would require excessive #ifdef magic to get right. "Network File System server" works for me. > A small part of me wants to suggest: > > "nfsd" > > but maybe I'm just in a whimsical mood today. I'm resisting the urge to add "RFCs 1813, 7530, 8881, et al." Whimsy, indeed. ;-) > NeilBrown > > > > MODULE_LICENSE("GPL"); > > module_init(init_nfsd) > > module_exit(exit_nfsd) > > -- > > 2.41.0 > > > > >
Personally I like Jeff's text. There's zero need to overthink this. Jul 20, 2023 7:30:34 PM Chuck Lever <cel@kernel.org>: > On Fri, Jul 21, 2023 at 08:07:16AM +1000, NeilBrown wrote: >> On Thu, 20 Jul 2023, Jeff Layton wrote: >>> I got this today from modpost: >>> >>> WARNING: modpost: missing MODULE_DESCRIPTION() in fs/nfsd/nfsd.o >>> >>> Add a module description. >>> >>> Signed-off-by: Jeff Layton <jlayton@kernel.org> >>> --- >>> fs/nfsd/nfsctl.c | 1 + >>> 1 file changed, 1 insertion(+) >>> >>> diff --git a/fs/nfsd/nfsctl.c b/fs/nfsd/nfsctl.c >>> index 1b8b1aab9a15..7070969a38b5 100644 >>> --- a/fs/nfsd/nfsctl.c >>> +++ b/fs/nfsd/nfsctl.c >>> @@ -1626,6 +1626,7 @@ static void __exit exit_nfsd(void) >>> } >>> >>> MODULE_AUTHOR("Olaf Kirch <okir@monad.swb.de>"); >>> +MODULE_DESCRIPTION("The Linux kernel NFS server"); >> >> Of 9176 MODULE_DESCRIPTIONs in Linux, 21 start with "The ". >> Does having that word add anything useful? >> Amusingly 129 end with a period. I wonder what Jon Corbet would prefer >> :-) > > The Ohio State University has set a bad precedent. > > I think we can drop "The". > > >> A few tell us what the module does. >> "Measures" "Provides".... >> Do we want "Implements" ?? > > I don't find "Implements" to be either conventional or illuminating. > > >> 232 start "Driver " and 214 are "Driver for".... >> Should we have "Server for" ?? >> >> 26 start "Linux" ... which seems a bit redundant >> 12 contain "for Linux". 67 mention linux in some way. >> 28 contain the word "kernel" - also redundant. >> Only three (others) mention "Linux kernel" > > One of which is the new in-kernel SMB server, interestingly. > > I don't think "Linux kernel" or even "in-kernel" is needed here. > Both should be obvious from the context. > > >> drivers/pcmcia/cs.c:MODULE_DESCRIPTION("Linux Kernel Card Services"); >> fs/ksmbd/server.c:MODULE_DESCRIPTION("Linux kernel CIFS/SMB SERVER"); >> fs/orangefs/orangefs-mod.c:MODULE_DESCRIPTION("The Linux Kernel VFS interface to ORANGEFS"); >> >> hmmm.. 192 contain the word "module". Fortunately none say >> "Linux kernel module for ..." >> I would have found that to be a step too far. >> >> I'd like to suggest >> >> "Implements Server for NFS - v2, 3, v4.{0,1,2}" >> >> But that would require excessive #ifdef magic to get right. > > "Network File System server" works for me. > > >> A small part of me wants to suggest: >> >> "nfsd" >> >> but maybe I'm just in a whimsical mood today. > > I'm resisting the urge to add "RFCs 1813, 7530, 8881, et al." > Whimsy, indeed. ;-) > > >> NeilBrown >> >> >>> MODULE_LICENSE("GPL"); >>> module_init(init_nfsd) >>> module_exit(exit_nfsd) >>> -- >>> 2.41.0 >>> >>> >>
On Thu, 2023-07-20 at 20:00 -0400, Tom Talpey wrote: > Personally I like Jeff's text. There's zero need to overthink this. > It's like this patch was tailor-made for bikeshedding. ;) Personally, I'm fine with any reasonable string here. My main concern was just to silence the warning. > Jul 20, 2023 7:30:34 PM Chuck Lever <cel@kernel.org>: > > > On Fri, Jul 21, 2023 at 08:07:16AM +1000, NeilBrown wrote: > > > On Thu, 20 Jul 2023, Jeff Layton wrote: > > > > I got this today from modpost: > > > > > > > > WARNING: modpost: missing MODULE_DESCRIPTION() in fs/nfsd/nfsd.o > > > > > > > > Add a module description. > > > > > > > > Signed-off-by: Jeff Layton <jlayton@kernel.org> > > > > --- > > > > fs/nfsd/nfsctl.c | 1 + > > > > 1 file changed, 1 insertion(+) > > > > > > > > diff --git a/fs/nfsd/nfsctl.c b/fs/nfsd/nfsctl.c > > > > index 1b8b1aab9a15..7070969a38b5 100644 > > > > --- a/fs/nfsd/nfsctl.c > > > > +++ b/fs/nfsd/nfsctl.c > > > > @@ -1626,6 +1626,7 @@ static void __exit exit_nfsd(void) > > > > } > > > > > > > > MODULE_AUTHOR("Olaf Kirch <okir@monad.swb.de>"); > > > > +MODULE_DESCRIPTION("The Linux kernel NFS server"); > > > > > > Of 9176 MODULE_DESCRIPTIONs in Linux, 21 start with "The ". > > > Does having that word add anything useful? > > > Amusingly 129 end with a period. I wonder what Jon Corbet would prefer > > > :-) > > > > The Ohio State University has set a bad precedent. > > > > I think we can drop "The". > > > > > > > A few tell us what the module does. > > > "Measures" "Provides".... > > > Do we want "Implements" ?? > > > > I don't find "Implements" to be either conventional or illuminating. > > > > > > > 232 start "Driver " and 214 are "Driver for".... > > > Should we have "Server for" ?? > > > > > > 26 start "Linux" ... which seems a bit redundant > > > 12 contain "for Linux". 67 mention linux in some way. > > > 28 contain the word "kernel" - also redundant. > > > Only three (others) mention "Linux kernel" > > > > One of which is the new in-kernel SMB server, interestingly. > > > > I don't think "Linux kernel" or even "in-kernel" is needed here. > > Both should be obvious from the context. > > > > > > > drivers/pcmcia/cs.c:MODULE_DESCRIPTION("Linux Kernel Card Services"); > > > fs/ksmbd/server.c:MODULE_DESCRIPTION("Linux kernel CIFS/SMB SERVER"); > > > fs/orangefs/orangefs-mod.c:MODULE_DESCRIPTION("The Linux Kernel VFS interface to ORANGEFS"); > > > > > > hmmm.. 192 contain the word "module". Fortunately none say > > > "Linux kernel module for ..." > > > I would have found that to be a step too far. > > > > > > I'd like to suggest > > > > > > "Implements Server for NFS - v2, 3, v4.{0,1,2}" > > > > > > But that would require excessive #ifdef magic to get right. > > > > "Network File System server" works for me. > > > > > > > A small part of me wants to suggest: > > > > > > "nfsd" > > > > > > but maybe I'm just in a whimsical mood today. > > > > I'm resisting the urge to add "RFCs 1813, 7530, 8881, et al." > > Whimsy, indeed. ;-) > > > > > > > NeilBrown > > > > > > > > > > MODULE_LICENSE("GPL"); > > > > module_init(init_nfsd) > > > > module_exit(exit_nfsd) > > > > -- > > > > 2.41.0 > > > > > > > > > > >
diff --git a/fs/nfsd/nfsctl.c b/fs/nfsd/nfsctl.c index 1b8b1aab9a15..7070969a38b5 100644 --- a/fs/nfsd/nfsctl.c +++ b/fs/nfsd/nfsctl.c @@ -1626,6 +1626,7 @@ static void __exit exit_nfsd(void) } MODULE_AUTHOR("Olaf Kirch <okir@monad.swb.de>"); +MODULE_DESCRIPTION("The Linux kernel NFS server"); MODULE_LICENSE("GPL"); module_init(init_nfsd) module_exit(exit_nfsd)
I got this today from modpost: WARNING: modpost: missing MODULE_DESCRIPTION() in fs/nfsd/nfsd.o Add a module description. Signed-off-by: Jeff Layton <jlayton@kernel.org> --- fs/nfsd/nfsctl.c | 1 + 1 file changed, 1 insertion(+)