diff mbox series

junction: export-cache: cast to a type with a known size to ensure sprintf works

Message ID 20240502135320.3445429-1-carnil@debian.org (mailing list archive)
State New
Headers show
Series junction: export-cache: cast to a type with a known size to ensure sprintf works | expand

Commit Message

Salvatore Bonaccorso May 2, 2024, 1:53 p.m. UTC
As reported in Debian, with the 64bit time_t transition for the armel
and armhf architecture, it was found that nfs-utils fails to compile
with:

	libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I../../support/include -I/usr/include/tirpc -I/usr/include/libxml2 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_TIME_BITS=64 -Wdate-time -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -pipe -Wall -Wextra -Werror=strict-prototypes -Werror=missing-prototypes -Werror=missing-declarations -Werror=format=2 -Werror=undef -Werror=missing-include-dirs -Werror=strict-aliasing=2 -Werror=init-self -Werror=implicit-function-declaration -Werror=return-type -Werror=switch -Werror=overflow -Werror=parentheses -Werror=aggregate-return -Werror=unused-result -fno-strict-aliasing -Werror=format-overflow=2 -Werror=int-conversion -Werror=incompatible-pointer-types -Werror=misleading-indentation -Wno-cast-function-type -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -c xml.c  -fPIC -DPIC -o .libs/xml.o
	export-cache.c: In function ‘junction_flush_exports_cache’:
	export-cache.c:110:51: error: format ‘%ld’ expects argument of type ‘long int’, but argument 4 has type ‘time_t’ {aka ‘long long int’} [-Werror=format=]
	  110 |         snprintf(flushtime, sizeof(flushtime), "%ld\n", now);
	      |                                                 ~~^     ~~~
	      |                                                   |     |
	      |                                                   |     time_t {aka long long int}
	      |                                                   long int
	      |                                                 %lld

time_t is not guaranteed to be 64-bit, so it must be coerced into the expected
type for printf. Cast it to long long.

Reported-by: Vladimir Petko <vladimir.petko@canonical.com>
Closes: https://bugzilla.kernel.org/show_bug.cgi?id=218540
Link: https://bugs.debian.org/1067829
Link: https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/2055349
Fixes: 494d22396d3d ("Add LDAP-free version of libjunction to nfs-utils")
Suggested-by: Vladimir Petko <vladimir.petko@canonical.com>
Signed-off-by: Salvatore Bonaccorso <carnil@debian.org>
---
 support/junction/export-cache.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Steve Dickson May 10, 2024, 1:18 p.m. UTC | #1
On 5/2/24 9:53 AM, Salvatore Bonaccorso wrote:
> As reported in Debian, with the 64bit time_t transition for the armel
> and armhf architecture, it was found that nfs-utils fails to compile
> with:
> 
> 	libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I../../support/include -I/usr/include/tirpc -I/usr/include/libxml2 -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_TIME_BITS=64 -Wdate-time -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -pipe -Wall -Wextra -Werror=strict-prototypes -Werror=missing-prototypes -Werror=missing-declarations -Werror=format=2 -Werror=undef -Werror=missing-include-dirs -Werror=strict-aliasing=2 -Werror=init-self -Werror=implicit-function-declaration -Werror=return-type -Werror=switch -Werror=overflow -Werror=parentheses -Werror=aggregate-return -Werror=unused-result -fno-strict-aliasing -Werror=format-overflow=2 -Werror=int-conversion -Werror=incompatible-pointer-types -Werror=misleading-indentation -Wno-cast-function-type -g -O2 -Werror=implicit-function-declaration -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -fstack-clash-protection -Wformat -Werror=format-security -c xml.c  -fPIC -DPIC -o .libs/xml.o
> 	export-cache.c: In function ‘junction_flush_exports_cache’:
> 	export-cache.c:110:51: error: format ‘%ld’ expects argument of type ‘long int’, but argument 4 has type ‘time_t’ {aka ‘long long int’} [-Werror=format=]
> 	  110 |         snprintf(flushtime, sizeof(flushtime), "%ld\n", now);
> 	      |                                                 ~~^     ~~~
> 	      |                                                   |     |
> 	      |                                                   |     time_t {aka long long int}
> 	      |                                                   long int
> 	      |                                                 %lld
> 
> time_t is not guaranteed to be 64-bit, so it must be coerced into the expected
> type for printf. Cast it to long long.
> 
> Reported-by: Vladimir Petko <vladimir.petko@canonical.com>
> Closes: https://bugzilla.kernel.org/show_bug.cgi?id=218540
> Link: https://bugs.debian.org/1067829
> Link: https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/2055349
> Fixes: 494d22396d3d ("Add LDAP-free version of libjunction to nfs-utils")
> Suggested-by: Vladimir Petko <vladimir.petko@canonical.com>
> Signed-off-by: Salvatore Bonaccorso <carnil@debian.org>
Committed...

steved.
> ---
>   support/junction/export-cache.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/support/junction/export-cache.c b/support/junction/export-cache.c
> index 4e578c9b37b1..00187c019d60 100644
> --- a/support/junction/export-cache.c
> +++ b/support/junction/export-cache.c
> @@ -107,7 +107,7 @@ junction_flush_exports_cache(void)
>   		xlog(D_GENERAL, "%s: time(3) failed", __func__);
>   		return FEDFS_ERR_SVRFAULT;
>   	}
> -	snprintf(flushtime, sizeof(flushtime), "%ld\n", now);
> +	snprintf(flushtime, sizeof(flushtime), "%lld\n", (long long)now);
>   
>   	for (i = 0; junction_proc_files[i] != NULL; i++) {
>   		retval = junction_write_time(junction_proc_files[i], flushtime);
diff mbox series

Patch

diff --git a/support/junction/export-cache.c b/support/junction/export-cache.c
index 4e578c9b37b1..00187c019d60 100644
--- a/support/junction/export-cache.c
+++ b/support/junction/export-cache.c
@@ -107,7 +107,7 @@  junction_flush_exports_cache(void)
 		xlog(D_GENERAL, "%s: time(3) failed", __func__);
 		return FEDFS_ERR_SVRFAULT;
 	}
-	snprintf(flushtime, sizeof(flushtime), "%ld\n", now);
+	snprintf(flushtime, sizeof(flushtime), "%lld\n", (long long)now);
 
 	for (i = 0; junction_proc_files[i] != NULL; i++) {
 		retval = junction_write_time(junction_proc_files[i], flushtime);