Message ID | 20180607223111.27792-4-ross.zwisler@linux.intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On 08.06.2018 00:31, Ross Zwisler wrote: > Normally this might not be worth fixing, but several of these are strings > which are displayed to users. > > Signed-off-by: Ross Zwisler <ross.zwisler@linux.intel.com> > --- > hw/core/machine.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/hw/core/machine.c b/hw/core/machine.c > index 617e5f8d75..a21269fa39 100644 > --- a/hw/core/machine.c > +++ b/hw/core/machine.c > @@ -609,7 +609,7 @@ static void machine_class_init(ObjectClass *oc, void *data) > machine_get_igd_gfx_passthru, machine_set_igd_gfx_passthru, > &error_abort); > object_class_property_set_description(oc, "igd-passthru", > - "Set on/off to enable/disable igd passthrou", &error_abort); > + "Set on/off to enable/disable igd passthru", &error_abort); Shouldn't that rather be "passthrough" instead? Thomas
On Fri, Jun 08, 2018 at 07:38:17AM +0200, Thomas Huth wrote: > On 08.06.2018 00:31, Ross Zwisler wrote: > > Normally this might not be worth fixing, but several of these are strings > > which are displayed to users. > > > > Signed-off-by: Ross Zwisler <ross.zwisler@linux.intel.com> > > --- > > hw/core/machine.c | 6 +++--- > > 1 file changed, 3 insertions(+), 3 deletions(-) > > > > diff --git a/hw/core/machine.c b/hw/core/machine.c > > index 617e5f8d75..a21269fa39 100644 > > --- a/hw/core/machine.c > > +++ b/hw/core/machine.c > > @@ -609,7 +609,7 @@ static void machine_class_init(ObjectClass *oc, void *data) > > machine_get_igd_gfx_passthru, machine_set_igd_gfx_passthru, > > &error_abort); > > object_class_property_set_description(oc, "igd-passthru", > > - "Set on/off to enable/disable igd passthrou", &error_abort); > > + "Set on/off to enable/disable igd passthru", &error_abort); > > Shouldn't that rather be "passthrough" instead? Either works, I think. "thru" and "passthru" are short informal versions of "through" and "passthrough", but both the long and short versions of both words are used all over the QEMU source. "passthrou" is clearly wrong. If the longer version is preferred in this case please feel free to fix up when you apply.
On 06/08/2018 12:41 PM, Ross Zwisler wrote: >>> - "Set on/off to enable/disable igd passthrou", &error_abort); >>> + "Set on/off to enable/disable igd passthru", &error_abort); >> >> Shouldn't that rather be "passthrough" instead? > > Either works, I think. "thru" and "passthru" are short informal versions of > "through" and "passthrough", but both the long and short versions of both > words are used all over the QEMU source. "passthrou" is clearly wrong. If > the longer version is preferred in this case please feel free to fix up when > you apply. "passthru" is fine as an abbreviation in source code (and gcc understands it). But in English text presented to the end user, as is the case here, you should use the correct spelling "passthrough", and not an abbreviation.
diff --git a/hw/core/machine.c b/hw/core/machine.c index 617e5f8d75..a21269fa39 100644 --- a/hw/core/machine.c +++ b/hw/core/machine.c @@ -609,7 +609,7 @@ static void machine_class_init(ObjectClass *oc, void *data) machine_get_igd_gfx_passthru, machine_set_igd_gfx_passthru, &error_abort); object_class_property_set_description(oc, "igd-passthru", - "Set on/off to enable/disable igd passthrou", &error_abort); + "Set on/off to enable/disable igd passthru", &error_abort); object_class_property_add_str(oc, "firmware", machine_get_firmware, machine_set_firmware, @@ -633,7 +633,7 @@ static void machine_class_init(ObjectClass *oc, void *data) machine_get_memory_encryption, machine_set_memory_encryption, &error_abort); object_class_property_set_description(oc, "memory-encryption", - "Set memory encyption object to use", &error_abort); + "Set memory encryption object to use", &error_abort); } static void machine_class_base_init(ObjectClass *oc, void *data) @@ -806,7 +806,7 @@ void machine_run_board_init(MachineState *machine) for (i = 0; machine_class->valid_cpu_types[i]; i++) { if (object_class_dynamic_cast(class, machine_class->valid_cpu_types[i])) { - /* The user specificed CPU is in the valid field, we are + /* The user specified CPU is in the valid field, we are * good to go. */ break;
Normally this might not be worth fixing, but several of these are strings which are displayed to users. Signed-off-by: Ross Zwisler <ross.zwisler@linux.intel.com> --- hw/core/machine.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)