mbox series

[0/4] PCI: dwc: Refine the EP code no functionality change

Message ID 20210107091123.8616-1-Zhiqiang.Hou@nxp.com (mailing list archive)
Headers show
Series PCI: dwc: Refine the EP code no functionality change | expand

Message

Z.Q. Hou Jan. 7, 2021, 9:11 a.m. UTC
From: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>

Tune the EP mode code slightly to make it more readable.

Hou Zhiqiang (4):
  PCI: dwc: Change to use an array to store the structure of functions
  PCI: dwc: Add CFG offset info into function's represented structure
  PCI: dwc: Rename callback function func_conf_select and its instance
  PCI: dwc: Change the parameter of function dw_pcie_ep_reset_bar()

 drivers/pci/controller/dwc/pci-dra7xx.c       |   2 +-
 .../pci/controller/dwc/pci-layerscape-ep.c    |   8 +-
 drivers/pci/controller/dwc/pcie-artpec6.c     |   2 +-
 .../pci/controller/dwc/pcie-designware-ep.c   | 192 ++++++++----------
 .../pci/controller/dwc/pcie-designware-plat.c |   3 +-
 drivers/pci/controller/dwc/pcie-designware.h  |  11 +-
 drivers/pci/controller/dwc/pcie-uniphier-ep.c |   3 +-
 7 files changed, 96 insertions(+), 125 deletions(-)

Comments

Z.Q. Hou April 6, 2021, 9:03 a.m. UTC | #1
Hi Lorenzo, Rob and Bjorn,

Any comments on this series?

Thanks,
Zhiqiang

> -----Original Message-----
> From: Z.q. Hou <zhiqiang.hou@nxp.com>
> Sent: 2021年1月7日 17:11
> To: linux-pci@vger.kernel.org; linux-arm-kernel@lists.infradead.org;
> linux-kernel@vger.kernel.org; linux-omap@vger.kernel.org;
> linux-arm-kernel@axis.com; lorenzo.pieralisi@arm.com; robh@kernel.org;
> bhelgaas@google.com
> Cc: kishon@ti.com; M.h. Lian <minghuan.lian@nxp.com>;
> jesper.nilsson@axis.com; jingoohan1@gmail.com;
> gustavo.pimentel@synopsys.com; hayashi.kunihiko@socionext.com; Z.q.
> Hou <zhiqiang.hou@nxp.com>
> Subject: [PATCH 0/4] PCI: dwc: Refine the EP code no functionality change
> 
> From: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> 
> Tune the EP mode code slightly to make it more readable.
> 
> Hou Zhiqiang (4):
>   PCI: dwc: Change to use an array to store the structure of functions
>   PCI: dwc: Add CFG offset info into function's represented structure
>   PCI: dwc: Rename callback function func_conf_select and its instance
>   PCI: dwc: Change the parameter of function dw_pcie_ep_reset_bar()
> 
>  drivers/pci/controller/dwc/pci-dra7xx.c       |   2 +-
>  .../pci/controller/dwc/pci-layerscape-ep.c    |   8 +-
>  drivers/pci/controller/dwc/pcie-artpec6.c     |   2 +-
>  .../pci/controller/dwc/pcie-designware-ep.c   | 192 ++++++++----------
>  .../pci/controller/dwc/pcie-designware-plat.c |   3 +-
>  drivers/pci/controller/dwc/pcie-designware.h  |  11 +-
>  drivers/pci/controller/dwc/pcie-uniphier-ep.c |   3 +-
>  7 files changed, 96 insertions(+), 125 deletions(-)
> 
> --
> 2.17.1