Message ID | 20180302111040.GA6344@amd (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Fri 2018-03-02 12:10:40, Pavel Machek wrote: > Hi! > > > > If this is taking longer to fix, should c85823390215 be reverted in > > > the meantime? It does not seem particulary important/urgent... > > > > No patience between the v4.16 release candidates eh ;) > > > > commit 6662ae6af82df10259a70c7569b4c12ea7f3ba93 > > ("gpiolib: Keep returning EPROBE_DEFER when we should") > > > > and > > > > commit ce27fb2c56db6ccfe8099343bb4afdab15e77e7b > > ("gpio: Handle deferred probing in of_find_gpio() properly") > > > > that are both in Torvalds' tree since yesterday should be fixing > > this, I think? Did you try just using the upstream HEAD? > > Ok, so this code looks pretty crazy to me: I tried removing the > "of_find_spi_gpio" part, and audio started working. Hmm. Looks like audio is working w/o any changes, too. Not sure why festival hung on me before. Pavel
On 03/02/2018 05:10 AM, Pavel Machek wrote: > Hi! > >>> If this is taking longer to fix, should c85823390215 be reverted in >>> the meantime? It does not seem particulary important/urgent... >> >> No patience between the v4.16 release candidates eh ;) >> >> commit 6662ae6af82df10259a70c7569b4c12ea7f3ba93 >> ("gpiolib: Keep returning EPROBE_DEFER when we should") >> >> and >> >> commit ce27fb2c56db6ccfe8099343bb4afdab15e77e7b >> ("gpio: Handle deferred probing in of_find_gpio() properly") >> >> that are both in Torvalds' tree since yesterday should be fixing >> this, I think? Did you try just using the upstream HEAD? > > Ok, so this code looks pretty crazy to me: I tried removing the > "of_find_spi_gpio" part, and audio started working. > > What is going on with the ()s around == s? You made me look up C > operator precedence. > > Hmm, and it is also wrong, right? It turns any error code into ENOENT, > as it tries to do the "special handling". > > * > * This means we don't need to look any further for > * alternate name conventions, and we should really > * preserve the return code for our user to be able to > * retry probing later. > */ > if (IS_ERR(desc) && PTR_ERR(desc) == -EPROBE_DEFER) > return desc; > > if (!IS_ERR(desc) || (PTR_ERR(desc) != -ENOENT)) > break; > } > > /* Special handling for SPI GPIOs if used */ > if (IS_ERR(desc)) > desc = of_find_spi_gpio(dev, con_id, &of_flags); > > /* Special handling for regulator GPIOs if used */ > if (IS_ERR(desc) && PTR_ERR(desc) != -EPROBE_DEFER) > desc = of_find_regulator_gpio(dev, con_id, &of_flags); > > Something like this? > > diff --git a/drivers/gpio/gpiolib-of.c b/drivers/gpio/gpiolib-of.c > index 84e5a9d..f0fab26 100644 > --- a/drivers/gpio/gpiolib-of.c > +++ b/drivers/gpio/gpiolib-of.c > @@ -241,29 +241,17 @@ struct gpio_desc *of_find_gpio(struct device *dev, const char *con_id, > > desc = of_get_named_gpiod_flags(dev->of_node, prop_name, idx, > &of_flags); > - /* > - * -EPROBE_DEFER in our case means that we found a > - * valid GPIO property, but no controller has been > - * registered so far. > - * > - * This means we don't need to look any further for > - * alternate name conventions, and we should really > - * preserve the return code for our user to be able to > - * retry probing later. > - */ > - if (IS_ERR(desc) && PTR_ERR(desc) == -EPROBE_DEFER) > - return desc; > > - if (!IS_ERR(desc) || (PTR_ERR(desc) != -ENOENT)) > + if (!IS_ERR(desc) || PTR_ERR(desc) != -ENOENT) I rather like the () so one doesn't always have to look up C operator precedence to verify.. > break; > } > > /* Special handling for SPI GPIOs if used */ > - if (IS_ERR(desc)) > + if (IS_ERR(desc) && PTR_ERR(desc) == -ENOENT) > desc = of_find_spi_gpio(dev, con_id, &of_flags); > > /* Special handling for regulator GPIOs if used */ > - if (IS_ERR(desc) && PTR_ERR(desc) != -EPROBE_DEFER) > + if (IS_ERR(desc) && PTR_ERR(desc) == -ENOENT) > desc = of_find_regulator_gpio(dev, con_id, &of_flags); > > if (IS_ERR(desc)) > -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Fri 2018-03-02 08:22:52, Andrew F. Davis wrote: > On 03/02/2018 05:10 AM, Pavel Machek wrote: > > Hi! > > > >>> If this is taking longer to fix, should c85823390215 be reverted in > >>> the meantime? It does not seem particulary important/urgent... > >> > >> No patience between the v4.16 release candidates eh ;) > >> > >> commit 6662ae6af82df10259a70c7569b4c12ea7f3ba93 > >> ("gpiolib: Keep returning EPROBE_DEFER when we should") > >> > >> and > >> > >> commit ce27fb2c56db6ccfe8099343bb4afdab15e77e7b > >> ("gpio: Handle deferred probing in of_find_gpio() properly") > >> > >> that are both in Torvalds' tree since yesterday should be fixing > >> this, I think? Did you try just using the upstream HEAD? > > > > Ok, so this code looks pretty crazy to me: I tried removing the > > "of_find_spi_gpio" part, and audio started working. > > > > What is going on with the ()s around == s? You made me look up C > > operator precedence. > > > > Hmm, and it is also wrong, right? It turns any error code into ENOENT, > > as it tries to do the "special handling". > > > > * > > * This means we don't need to look any further for > > * alternate name conventions, and we should really > > * preserve the return code for our user to be able to > > * retry probing later. > > */ > > if (IS_ERR(desc) && PTR_ERR(desc) == -EPROBE_DEFER) > > return desc; > > > > if (!IS_ERR(desc) || (PTR_ERR(desc) != -ENOENT)) > > break; > > } > > > > /* Special handling for SPI GPIOs if used */ > > if (IS_ERR(desc)) > > desc = of_find_spi_gpio(dev, con_id, &of_flags); > > > > /* Special handling for regulator GPIOs if used */ > > if (IS_ERR(desc) && PTR_ERR(desc) != -EPROBE_DEFER) > > desc = of_find_regulator_gpio(dev, con_id, &of_flags); > > > > Something like this? > > > > diff --git a/drivers/gpio/gpiolib-of.c b/drivers/gpio/gpiolib-of.c > > index 84e5a9d..f0fab26 100644 > > --- a/drivers/gpio/gpiolib-of.c > > +++ b/drivers/gpio/gpiolib-of.c > > @@ -241,29 +241,17 @@ struct gpio_desc *of_find_gpio(struct device *dev, const char *con_id, > > > > desc = of_get_named_gpiod_flags(dev->of_node, prop_name, idx, > > &of_flags); > > - /* > > - * -EPROBE_DEFER in our case means that we found a > > - * valid GPIO property, but no controller has been > > - * registered so far. > > - * > > - * This means we don't need to look any further for > > - * alternate name conventions, and we should really > > - * preserve the return code for our user to be able to > > - * retry probing later. > > - */ > > - if (IS_ERR(desc) && PTR_ERR(desc) == -EPROBE_DEFER) > > - return desc; > > > > - if (!IS_ERR(desc) || (PTR_ERR(desc) != -ENOENT)) > > + if (!IS_ERR(desc) || PTR_ERR(desc) != -ENOENT) > > > I rather like the () so one doesn't always have to look up C operator > precedence to verify.. Well, Ok, but then the ()s should be at the other ifs nearby, too. See? > > > break; > > } > > > > /* Special handling for SPI GPIOs if used */ > > - if (IS_ERR(desc)) > > + if (IS_ERR(desc) && PTR_ERR(desc) == -ENOENT) > > desc = of_find_spi_gpio(dev, con_id, &of_flags); > > > > /* Special handling for regulator GPIOs if used */ > > - if (IS_ERR(desc) && PTR_ERR(desc) != -EPROBE_DEFER) > > + if (IS_ERR(desc) && PTR_ERR(desc) == -ENOENT) > > desc = of_find_regulator_gpio(dev, con_id, &of_flags); > > > > if (IS_ERR(desc)) > > Pavel
On Fri, Mar 02, 2018 at 08:22:52AM -0600, Andrew F. Davis wrote: > > diff --git a/drivers/gpio/gpiolib-of.c b/drivers/gpio/gpiolib-of.c > > index 84e5a9d..f0fab26 100644 > > --- a/drivers/gpio/gpiolib-of.c > > +++ b/drivers/gpio/gpiolib-of.c > > @@ -241,29 +241,17 @@ struct gpio_desc *of_find_gpio(struct device *dev, const char *con_id, > > > > desc = of_get_named_gpiod_flags(dev->of_node, prop_name, idx, > > &of_flags); > > - /* > > - * -EPROBE_DEFER in our case means that we found a > > - * valid GPIO property, but no controller has been > > - * registered so far. > > - * > > - * This means we don't need to look any further for > > - * alternate name conventions, and we should really > > - * preserve the return code for our user to be able to > > - * retry probing later. > > - */ > > - if (IS_ERR(desc) && PTR_ERR(desc) == -EPROBE_DEFER) > > - return desc; > > > > - if (!IS_ERR(desc) || (PTR_ERR(desc) != -ENOENT)) > > + if (!IS_ERR(desc) || PTR_ERR(desc) != -ENOENT) > > > I rather like the () so one doesn't always have to look up C operator > precedence to verify.. Too many make it impossible to see which close paren ties up with which open paren. I've spent way too long in the past reformatting code, where people think that () are a good thing, to work out what the comparison is actually doing before then rewriting the damn thing with less () and in a much clearer way. I'm now convinced that unnecessary () are a very bad thing as they severely harm readability as test complexity increases. > > > > break; > > } > > > > /* Special handling for SPI GPIOs if used */ > > - if (IS_ERR(desc)) > > + if (IS_ERR(desc) && PTR_ERR(desc) == -ENOENT) These can be simplified to: if (desc == ERR_PTR(-ENOENT)) since error pointers are unique - ERR_PTR(-ENOENT) is what was returned as an error-pointer, and if IS_ERR(ERR_PTR(-ENOMENT)) etc were false, we'd have big problems as it'd mean we couldn't detect error pointers! As an added bonus, they don't involve any operator precedence questions either.
On 03/02/2018 11:08 AM, Russell King - ARM Linux wrote: > On Fri, Mar 02, 2018 at 08:22:52AM -0600, Andrew F. Davis wrote: >>> diff --git a/drivers/gpio/gpiolib-of.c b/drivers/gpio/gpiolib-of.c >>> index 84e5a9d..f0fab26 100644 >>> --- a/drivers/gpio/gpiolib-of.c >>> +++ b/drivers/gpio/gpiolib-of.c >>> @@ -241,29 +241,17 @@ struct gpio_desc *of_find_gpio(struct device *dev, const char *con_id, >>> >>> desc = of_get_named_gpiod_flags(dev->of_node, prop_name, idx, >>> &of_flags); >>> - /* >>> - * -EPROBE_DEFER in our case means that we found a >>> - * valid GPIO property, but no controller has been >>> - * registered so far. >>> - * >>> - * This means we don't need to look any further for >>> - * alternate name conventions, and we should really >>> - * preserve the return code for our user to be able to >>> - * retry probing later. >>> - */ >>> - if (IS_ERR(desc) && PTR_ERR(desc) == -EPROBE_DEFER) >>> - return desc; >>> >>> - if (!IS_ERR(desc) || (PTR_ERR(desc) != -ENOENT)) >>> + if (!IS_ERR(desc) || PTR_ERR(desc) != -ENOENT) >> >> >> I rather like the () so one doesn't always have to look up C operator >> precedence to verify.. > > Too many make it impossible to see which close paren ties up with > which open paren. I've spent way too long in the past reformatting > code, where people think that () are a good thing, to work out what > the comparison is actually doing before then rewriting the damn > thing with less () and in a much clearer way. I'm now convinced > that unnecessary () are a very bad thing as they severely harm > readability as test complexity increases. > Fair enough, I personally prefer always having a new line per condition when doing chained conditionals: if (something && this == that && !not_this) >> >> >>> break; >>> } >>> >>> /* Special handling for SPI GPIOs if used */ >>> - if (IS_ERR(desc)) >>> + if (IS_ERR(desc) && PTR_ERR(desc) == -ENOENT) > > These can be simplified to: > > if (desc == ERR_PTR(-ENOENT)) > > since error pointers are unique - ERR_PTR(-ENOENT) is what was > returned as an error-pointer, and if IS_ERR(ERR_PTR(-ENOMENT)) etc > were false, we'd have big problems as it'd mean we couldn't detect > error pointers! > > As an added bonus, they don't involve any operator precedence > questions either. > Looks like your suggestion clears up this one anyway. -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/drivers/gpio/gpiolib-of.c b/drivers/gpio/gpiolib-of.c index 84e5a9d..f0fab26 100644 --- a/drivers/gpio/gpiolib-of.c +++ b/drivers/gpio/gpiolib-of.c @@ -241,29 +241,17 @@ struct gpio_desc *of_find_gpio(struct device *dev, const char *con_id, desc = of_get_named_gpiod_flags(dev->of_node, prop_name, idx, &of_flags); - /* - * -EPROBE_DEFER in our case means that we found a - * valid GPIO property, but no controller has been - * registered so far. - * - * This means we don't need to look any further for - * alternate name conventions, and we should really - * preserve the return code for our user to be able to - * retry probing later. - */ - if (IS_ERR(desc) && PTR_ERR(desc) == -EPROBE_DEFER) - return desc; - if (!IS_ERR(desc) || (PTR_ERR(desc) != -ENOENT)) + if (!IS_ERR(desc) || PTR_ERR(desc) != -ENOENT) break; } /* Special handling for SPI GPIOs if used */ - if (IS_ERR(desc)) + if (IS_ERR(desc) && PTR_ERR(desc) == -ENOENT) desc = of_find_spi_gpio(dev, con_id, &of_flags); /* Special handling for regulator GPIOs if used */ - if (IS_ERR(desc) && PTR_ERR(desc) != -EPROBE_DEFER) + if (IS_ERR(desc) && PTR_ERR(desc) == -ENOENT) desc = of_find_regulator_gpio(dev, con_id, &of_flags); if (IS_ERR(desc))