diff mbox

[04/10] omap_hwspinlock: Replace "hweight_long(i & 0xf) != 1" with "!is_power_of_2(i & 0xf)"

Message ID 56659FC2.1070906@gmail.com (mailing list archive)
State New, archived
Headers show

Commit Message

Zhaoxiu Zeng Dec. 7, 2015, 3:03 p.m. UTC
? 2015/12/7 19:08, Ohad Ben-Cohen ??:
> Hi,
> 
> On Sun, Dec 6, 2015 at 12:33 PM, Zhaoxiu Zeng <zhaoxiu.zeng@gmail.com> wrote:
>>
>> From: Zeng Zhaoxiu <zhaoxiu.zeng@gmail.com>
>>
>> Signed-off-by: Zeng Zhaoxiu <zhaoxiu.zeng@gmail.com>
> 
> Please explain why do you think we should make this change.

is_power_of_2 is simple, and faster than "hweightN(x) == 1" on most architectures.
And the "& 0xf" operation is unnecessary, we will check whether or not greater than 8 behind.

> 
> Btw, the original code used is_power_of_2, but we thought hweight is
> more explicit so it was adopted.
> 
> Thanks,
> Ohad.
> 

---
 drivers/hwspinlock/omap_hwspinlock.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Ohad Ben Cohen Dec. 7, 2015, 4:16 p.m. UTC | #1
On Mon, Dec 7, 2015 at 5:03 PM, zhaoxiu.zeng <zhaoxiu.zeng@gmail.com> wrote:
> is_power_of_2 is simple, and faster than "hweightN(x) == 1" on most architectures.

Thanks. I'm not sure that speed is a major concern here, since this
code executes only once during the lifetime of the driver. Readability
is probably more important.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/hwspinlock/omap_hwspinlock.c b/drivers/hwspinlock/omap_hwspinlock.c
index ad2f8ca..1848a4c 100644
--- a/drivers/hwspinlock/omap_hwspinlock.c
+++ b/drivers/hwspinlock/omap_hwspinlock.c
@@ -29,6 +29,7 @@ 
 #include <linux/hwspinlock.h>
 #include <linux/of.h>
 #include <linux/platform_device.h>
+#include <linux/log2.h>
 
 #include "hwspinlock_internal.h"
 
@@ -125,7 +126,7 @@  static int omap_hwspinlock_probe(struct platform_device *pdev)
 		goto iounmap_base;
 
 	/* one of the four lsb's must be set, and nothing else */
-	if (hweight_long(i & 0xf) != 1 || i > 8) {
+	if (!is_power_of_2(i) || i > 8) {
 		ret = -EINVAL;
 		goto iounmap_base;
 	}