diff mbox series

[palo] ipl: Ensure no GCC builtins replace string functions

Message ID 20200520103055.31943-1-jer@gentoo.org (mailing list archive)
State Not Applicable, archived
Headers show
Series [palo] ipl: Ensure no GCC builtins replace string functions | expand

Commit Message

Jeroen Roovers May 20, 2020, 10:30 a.m. UTC
With GCC 10, the ipl is built with the compiler overriding local
definitions of some string functions, causing the ipl to trigger an
HPMC. Fix this by setting the -fno-builtin compiler flag.

Signed-off-by: Jeroen Roovers <jer@gentoo.org>
---
 ipl/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Helge Deller May 20, 2020, 9:47 p.m. UTC | #1
On 20.05.20 12:30, Jeroen Roovers wrote:
> With GCC 10, the ipl is built with the compiler overriding local
> definitions of some string functions, causing the ipl to trigger an
> HPMC. Fix this by setting the -fno-builtin compiler flag.
>
> Signed-off-by: Jeroen Roovers <jer@gentoo.org>

Thanks Jeroen!

I've applied your patch and am preparing for a palo v2.13 release...

Helge


> ---
>  ipl/Makefile | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/ipl/Makefile b/ipl/Makefile
> index 913ec66..c1d608b 100644
> --- a/ipl/Makefile
> +++ b/ipl/Makefile
> @@ -39,7 +39,7 @@ endif
>  VPATH=../lib:.
>
>  AFLAGS	= -I../lib
> -CFLAGS	= -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks
> +CFLAGS	= -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks -fno-builtin
>  LDFLAGS  = -N --section-start .init=0x60000 -e '$$START$$'
>
>  all:	iplelf
>
diff mbox series

Patch

diff --git a/ipl/Makefile b/ipl/Makefile
index 913ec66..c1d608b 100644
--- a/ipl/Makefile
+++ b/ipl/Makefile
@@ -39,7 +39,7 @@  endif
 VPATH=../lib:.
 
 AFLAGS	= -I../lib
-CFLAGS	= -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks
+CFLAGS	= -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks -fno-builtin
 LDFLAGS  = -N --section-start .init=0x60000 -e '$$START$$'
 
 all:	iplelf