Message ID | 20250226-parisc-perf-miscdev-v1-1-8d541ac2092d@igalia.com (mailing list archive) |
---|---|
State | Accepted, archived |
Headers | show |
Series | parisc: perf: use named initializers for struct miscdevice | expand |
On 2/26/25 19:09, Thadeu Lima de Souza Cascardo wrote: > Though struct miscdevice has hardly changed over the years, this is good > practice and also makes the core more readable. > > Signed-off-by: Thadeu Lima de Souza Cascardo <cascardo@igalia.com> > --- > arch/parisc/kernel/perf.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) applied. Thanks! Helge
diff --git a/arch/parisc/kernel/perf.c b/arch/parisc/kernel/perf.c index 5e8e37a722ef0fb3a22a8e0e57cb0fd48886901d..5e10f98ce7b54f75ceac1e8e5cdd1d4f752ed28f 100644 --- a/arch/parisc/kernel/perf.c +++ b/arch/parisc/kernel/perf.c @@ -475,9 +475,9 @@ static const struct file_operations perf_fops = { }; static struct miscdevice perf_dev = { - MISC_DYNAMIC_MINOR, - PA_PERF_DEV, - &perf_fops + .minor = MISC_DYNAMIC_MINOR, + .name = PA_PERF_DEV, + .fops = &perf_fops, }; /*
Though struct miscdevice has hardly changed over the years, this is good practice and also makes the core more readable. Signed-off-by: Thadeu Lima de Souza Cascardo <cascardo@igalia.com> --- arch/parisc/kernel/perf.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) --- base-commit: d082ecbc71e9e0bf49883ee4afd435a77a5101b6 change-id: 20250226-parisc-perf-miscdev-40e4642a12ec Best regards,