From patchwork Sat Apr 18 20:27:26 2009 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Kay Sievers X-Patchwork-Id: 18862 Received: from vger.kernel.org (vger.kernel.org [209.132.176.167]) by demeter.kernel.org (8.14.2/8.14.2) with ESMTP id n3IKRcdS025824 for ; Sat, 18 Apr 2009 20:27:38 GMT Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755158AbZDRU1h (ORCPT ); Sat, 18 Apr 2009 16:27:37 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1754897AbZDRU1h (ORCPT ); Sat, 18 Apr 2009 16:27:37 -0400 Received: from mail-fx0-f158.google.com ([209.85.220.158]:51620 "EHLO mail-fx0-f158.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754118AbZDRU1g (ORCPT ); Sat, 18 Apr 2009 16:27:36 -0400 Received: by fxm2 with SMTP id 2so1366632fxm.37 for ; Sat, 18 Apr 2009 13:27:33 -0700 (PDT) Received: by 10.204.58.9 with SMTP id e9mr3722286bkh.23.1240086453124; Sat, 18 Apr 2009 13:27:33 -0700 (PDT) Received: from ?192.168.178.32? (e179197049.adsl.alicedsl.de [85.179.197.49]) by mx.google.com with ESMTPS id 28sm6538453fkx.33.2009.04.18.13.27.31 (version=TLSv1/SSLv3 cipher=RC4-MD5); Sat, 18 Apr 2009 13:27:32 -0700 (PDT) Subject: Re: [PATCH] pci: keep pci device resource name pointer right. From: Kay Sievers To: Greg KH Cc: Yinghai Lu , Linus Torvalds , Jesse Barnes , Andrew Morton , "H. Peter Anvin" , Ingo Molnar , Thomas Gleixner , "linux-kernel@vger.kernel.org" , linux-pci@vger.kernel.org In-Reply-To: References: <20090416172803.GB16618@elte.hu> <20090416235452.GE21405@elte.hu> <20090417131633.GA30578@elte.hu> <49E8FD0B.2050308@zytor.com> <49E96731.1000501@kernel.org> <49EA27B9.3030004@kernel.org> <20090418192314.GA22107@suse.de> Date: Sat, 18 Apr 2009 22:27:26 +0200 Message-Id: <1240086446.2411.9.camel@poy> Mime-Version: 1.0 X-Mailer: Evolution 2.26.0 Sender: linux-pci-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-pci@vger.kernel.org On Sat, 2009-04-18 at 22:00 +0200, Kay Sievers wrote: > On Sat, Apr 18, 2009 at 21:23, Greg KH wrote: > > On Sat, Apr 18, 2009 at 12:19:21PM -0700, Yinghai Lu wrote: > >> Linus Torvalds wrote: > > >> > Can we not make the rule be that the name should just be set before? > > I guess, that's what they do already, otherwise they could not use dev_name(). > > >> pci_bus_add_device will call device_add. > >> > >> actually in device_add > >> > >> /* first, register with generic layer. */ > >> error = kobject_add(&dev->kobj, dev->kobj.parent, "%s", dev_name(dev)); > >> if (error) > >> goto Error; > >> > >> will get one new name for that kobj, old name is freed. > >> > >> Will try to make kobject_add more smart to reuse the old one. > > > > I don't understand the problem here, how are you going to change the > > kobject core? Is this just because you aren't getting a name for the > > resource? If so, why would the driver core care about this? > > Seems a bit odd what we do when registering a device. > > Usually one sets the name with dev_set_name() which will name the > kobject. When one later registers the device, we reallocate the same > name, so the pointer changes. I guess the problem here is that the pci > code remembers the name pointer after it was set, but it will not be > the same after the device is live. > > We should probably make device_add() pass a NULL as the name, and > kobject_add() in that case use the name that is properly set already. Only to see if we are on the right track, does that fix the problem? If yes, we will fix it properly without the NULL hack deep in the kobject call. Thanks, Kay --- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html diff --git a/drivers/base/core.c b/drivers/base/core.c index d230ff4..1969b20 100644 --- a/drivers/base/core.c +++ b/drivers/base/core.c @@ -890,8 +890,8 @@ int device_add(struct device *dev) if (parent) set_dev_node(dev, dev_to_node(parent)); - /* first, register with generic layer. */ - error = kobject_add(&dev->kobj, dev->kobj.parent, "%s", dev_name(dev)); + /* we require the name to be set before, and pass NULL */ + error = kobject_add(&dev->kobj, dev->kobj.parent, NULL); if (error) goto Error; diff --git a/lib/kobject.c b/lib/kobject.c index a6dec32..48565d6 100644 --- a/lib/kobject.c +++ b/lib/kobject.c @@ -218,6 +218,9 @@ int kobject_set_name_vargs(struct kobject *kobj, const char *fmt, const char *old_name = kobj->name; char *s; + if (kobj->name && !fmt) + return 0; + kobj->name = kvasprintf(GFP_KERNEL, fmt, vargs); if (!kobj->name) return -ENOMEM;