mbox series

[v3,0/3] Improve error handling in Rockchip Inno USB 2.0 PHY driver

Message ID cover.1725524802.git.dsimic@manjaro.org
Headers show
Series Improve error handling in Rockchip Inno USB 2.0 PHY driver | expand

Message

Dragan Simic Sept. 5, 2024, 8:28 a.m. UTC
This is a small series that improves error handling in the probe path
of the Rockchip Innosilicon USB 2.0 PHY driver, by returning the actual
error code in one place and by using dev_err_probe() properly in multiple
places.  It also performs a bunch of small, rather trivial code cleanups,
to make the code neater and a bit easier to read.

Changes in v3:
  - Collected Reviewed-by tags from Heiko for patches 1/3 and 2/3
  - Brought back one empty line as a separator of dissimilar operations
    in patch 1/3, as suggested by Heiko [2]
  - Dropped one backward conversion of dev_err_probe() to dev_err() in
    patch 3/3, as suggested by Heiko, [3] and adjusted the summary and
    description of patch 3/3 accordingly

Changes in v2:
  - Expanded into a small series, after a suggestion from Heiko [1] to
    use dev_err_probe(), because it all happens in the probe path

Link to v2: https://lore.kernel.org/linux-phy/cover.1724225528.git.dsimic@manjaro.org/T/#u
Link to v1: https://lore.kernel.org/linux-phy/5fa7796d71e2f46344e972bc98a54539f55b6109.1723551599.git.dsimic@manjaro.org/T/#u

[1] https://lore.kernel.org/linux-phy/4927264.xgNZFEDtJV@diego/
[2] https://lore.kernel.org/linux-phy/5307900.6fTUFtlzNn@diego/
[3] https://lore.kernel.org/linux-phy/6073817.31tnzDBltd@diego/

Dragan Simic (3):
  phy: phy-rockchip-inno-usb2: Perform trivial code cleanups
  phy: phy-rockchip-inno-usb2: Handle failed extcon allocation better
  phy: phy-rockchip-inno-usb2: Use dev_err_probe() in the probe path

 drivers/phy/rockchip/phy-rockchip-inno-usb2.c | 56 +++++++------------
 1 file changed, 21 insertions(+), 35 deletions(-)