Message ID | 20221027044920.23194-3-hayashi.kunihiko@socionext.com |
---|---|
State | Changes Requested |
Headers | show |
Series | dt-bindings: phy: Fix UniPhier controller node names | expand |
On Thu, Oct 27, 2022 at 01:49:20PM +0900, Kunihiko Hayashi wrote: > The word "glue" is ambiguous for the controller node name. Should put > "sata-controller" instead of "ahci-glue" on the controller node. > And rename a phy node to "sata-phy". > > Signed-off-by: Kunihiko Hayashi <hayashi.kunihiko@socionext.com> > --- > .../devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml > index a3cd45acea28..89b8b133777a 100644 > --- a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml > +++ b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml > @@ -117,14 +117,14 @@ additionalProperties: false > > examples: > - | > - ahci-glue@65700000 { > + sata-controller@65700000 { But is this really the SATA controller aka AHCI? In cases where we don't have a standardized name, I don't think it makes sense changing node names from one non-standard name to another. > compatible = "socionext,uniphier-pxs3-ahci-glue", > "simple-mfd"; > #address-cells = <1>; > #size-cells = <1>; > ranges = <0 0x65700000 0x100>; > > - ahci_phy: phy@10 { > + ahci_phy: sata-phy@10 { > compatible = "socionext,uniphier-pxs3-ahci-phy"; > reg = <0x10 0x10>; > #phy-cells = <0>; > -- > 2.25.1 > >
Hi Rob, On 2022/10/29 4:38, Rob Herring wrote: > On Thu, Oct 27, 2022 at 01:49:20PM +0900, Kunihiko Hayashi wrote: >> The word "glue" is ambiguous for the controller node name. Should put >> "sata-controller" instead of "ahci-glue" on the controller node. >> And rename a phy node to "sata-phy". >> >> Signed-off-by: Kunihiko Hayashi <hayashi.kunihiko@socionext.com> >> --- >> .../devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml | 4 ++-- >> 1 file changed, 2 insertions(+), 2 deletions(-) >> >> diff --git > a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml > b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml >> index a3cd45acea28..89b8b133777a 100644 >> --- a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy. > yaml >> +++ b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy. > yaml >> @@ -117,14 +117,14 @@ additionalProperties: false >> >> examples: >> - | >> - ahci-glue@65700000 { >> + sata-controller@65700000 { > > But is this really the SATA controller aka AHCI? > > In cases where we don't have a standardized name, I don't think it makes > sense changing node names from one non-standard name to another. I see. This can't be named generic, so this change will drop. And "sata-phy" in the same way. Thank you, --- Best Regards Kunihiko Hayashi
On Tue, Nov 1, 2022 at 4:10 AM Kunihiko Hayashi <hayashi.kunihiko@socionext.com> wrote: > > Hi Rob, > > On 2022/10/29 4:38, Rob Herring wrote: > > On Thu, Oct 27, 2022 at 01:49:20PM +0900, Kunihiko Hayashi wrote: > >> The word "glue" is ambiguous for the controller node name. Should put > >> "sata-controller" instead of "ahci-glue" on the controller node. > >> And rename a phy node to "sata-phy". > >> > >> Signed-off-by: Kunihiko Hayashi <hayashi.kunihiko@socionext.com> > >> --- > >> .../devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml | 4 ++-- > >> 1 file changed, 2 insertions(+), 2 deletions(-) > >> > >> diff --git > > a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml > > b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml > >> index a3cd45acea28..89b8b133777a 100644 > >> --- a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy. > > yaml > >> +++ b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy. > > yaml > >> @@ -117,14 +117,14 @@ additionalProperties: false > >> > >> examples: > >> - | > >> - ahci-glue@65700000 { > >> + sata-controller@65700000 { > > > > But is this really the SATA controller aka AHCI? > > > > In cases where we don't have a standardized name, I don't think it makes > > sense changing node names from one non-standard name to another. > > I see. This can't be named generic, so this change will drop. > And "sata-phy" in the same way. I think sata-phy is fine. It may not be added, but usb3-phy or pcie-phy are common already. Rob
On 2022/11/02 4:31, Rob Herring wrote: > On Tue, Nov 1, 2022 at 4:10 AM Kunihiko Hayashi > <hayashi.kunihiko@socionext.com> wrote: >> >> Hi Rob, >> >> On 2022/10/29 4:38, Rob Herring wrote: >>> On Thu, Oct 27, 2022 at 01:49:20PM +0900, Kunihiko Hayashi wrote: >>>> The word "glue" is ambiguous for the controller node name. Should put >>>> "sata-controller" instead of "ahci-glue" on the controller node. >>>> And rename a phy node to "sata-phy". >>>> >>>> Signed-off-by: Kunihiko Hayashi <hayashi.kunihiko@socionext.com> >>>> --- >>>> .../devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml | 4 >>>> ++-- >>>> 1 file changed, 2 insertions(+), 2 deletions(-) >>>> >>>> diff --git >>> a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml >>> b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml >>>> index a3cd45acea28..89b8b133777a 100644 >>>> --- >>>> a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy. >>> yaml >>>> +++ >>>> b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy. >>> yaml >>>> @@ -117,14 +117,14 @@ additionalProperties: false >>>> >>>> examples: >>>> - | >>>> - ahci-glue@65700000 { >>>> + sata-controller@65700000 { >>> >>> But is this really the SATA controller aka AHCI? >>> >>> In cases where we don't have a standardized name, I don't think it makes >>> sense changing node names from one non-standard name to another. >> >> I see. This can't be named generic, so this change will drop. >> And "sata-phy" in the same way. > > I think sata-phy is fine. It may not be added, but usb3-phy or > pcie-phy are common already. I understand. But of cource "phy" is also common, so I defer the change from "phy" to "sata-phy". Thank you, --- Best Regards Kunihiko Hayashi
On 02-11-22, 08:14, Kunihiko Hayashi wrote: > On 2022/11/02 4:31, Rob Herring wrote: > > On Tue, Nov 1, 2022 at 4:10 AM Kunihiko Hayashi > > <hayashi.kunihiko@socionext.com> wrote: > > > > > > Hi Rob, > > > > > > On 2022/10/29 4:38, Rob Herring wrote: > > > > On Thu, Oct 27, 2022 at 01:49:20PM +0900, Kunihiko Hayashi wrote: > > > > > The word "glue" is ambiguous for the controller node name. Should put > > > > > "sata-controller" instead of "ahci-glue" on the controller node. > > > > > And rename a phy node to "sata-phy". > > > > > > > > > > Signed-off-by: Kunihiko Hayashi <hayashi.kunihiko@socionext.com> > > > > > --- > > > > > .../devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml | 4 > > > > > ++-- > > > > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > > > > > > > diff --git > > > > a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml > > > > b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml > > > > > index a3cd45acea28..89b8b133777a 100644 > > > > > --- > > > > > a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy. > > > > yaml > > > > > +++ > > > > > b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy. > > > > yaml > > > > > @@ -117,14 +117,14 @@ additionalProperties: false > > > > > > > > > > examples: > > > > > - | > > > > > - ahci-glue@65700000 { > > > > > + sata-controller@65700000 { > > > > > > > > But is this really the SATA controller aka AHCI? > > > > > > > > In cases where we don't have a standardized name, I don't think it makes > > > > sense changing node names from one non-standard name to another. > > > > > > I see. This can't be named generic, so this change will drop. > > > And "sata-phy" in the same way. > > > > I think sata-phy is fine. It may not be added, but usb3-phy or > > pcie-phy are common already. > I understand. But of cource "phy" is also common, so I defer the change > from "phy" to "sata-phy". Should it not be just phy@xxx does it really need to be foo-phy?
Hi Vinod, On 2022/11/05 16:34, Vinod Koul wrote: > On 02-11-22, 08:14, Kunihiko Hayashi wrote: >> On 2022/11/02 4:31, Rob Herring wrote: >>> On Tue, Nov 1, 2022 at 4:10 AM Kunihiko Hayashi >>> <hayashi.kunihiko@socionext.com> wrote: >>>> >>>> Hi Rob, >>>> >>>> On 2022/10/29 4:38, Rob Herring wrote: >>>>> On Thu, Oct 27, 2022 at 01:49:20PM +0900, Kunihiko Hayashi wrote: >>>>>> The word "glue" is ambiguous for the controller node name. > Should put >>>>>> "sata-controller" instead of "ahci-glue" on the controller node. >>>>>> And rename a phy node to "sata-phy". >>>>>> >>>>>> Signed-off-by: Kunihiko Hayashi <hayashi.kunihiko@socionext.com> >>>>>> --- >>>>>> .../devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml > | 4 >>>>>> ++-- >>>>>> 1 file changed, 2 insertions(+), 2 deletions(-) >>>>>> >>>>>> diff --git >>>>> > a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml >>>>> > b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml >>>>>> index a3cd45acea28..89b8b133777a 100644 >>>>>> --- >>>>>> > a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy. >>>>> yaml >>>>>> +++ >>>>>> > b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy. >>>>> yaml >>>>>> @@ -117,14 +117,14 @@ additionalProperties: false >>>>>> >>>>>> examples: >>>>>> - | >>>>>> - ahci-glue@65700000 { >>>>>> + sata-controller@65700000 { >>>>> >>>>> But is this really the SATA controller aka AHCI? >>>>> >>>>> In cases where we don't have a standardized name, I don't think it > makes >>>>> sense changing node names from one non-standard name to another. >>>> >>>> I see. This can't be named generic, so this change will drop. >>>> And "sata-phy" in the same way. >>> >>> I think sata-phy is fine. It may not be added, but usb3-phy or >>> pcie-phy are common already. >> I understand. But of cource "phy" is also common, so I defer the change >> from "phy" to "sata-phy". > > Should it not be just phy@xxx does it really need to be foo-phy? This change was pointed out in the previous review for our devicetree, so I made this change in the devicetree, however, I think I can leave it as "phy" until the properties that depend on "sata-phy" are defined. Thank you, --- Best Regards Kunihiko Hayashi
diff --git a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml index a3cd45acea28..89b8b133777a 100644 --- a/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml +++ b/Documentation/devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml @@ -117,14 +117,14 @@ additionalProperties: false examples: - | - ahci-glue@65700000 { + sata-controller@65700000 { compatible = "socionext,uniphier-pxs3-ahci-glue", "simple-mfd"; #address-cells = <1>; #size-cells = <1>; ranges = <0 0x65700000 0x100>; - ahci_phy: phy@10 { + ahci_phy: sata-phy@10 { compatible = "socionext,uniphier-pxs3-ahci-phy"; reg = <0x10 0x10>; #phy-cells = <0>;
The word "glue" is ambiguous for the controller node name. Should put "sata-controller" instead of "ahci-glue" on the controller node. And rename a phy node to "sata-phy". Signed-off-by: Kunihiko Hayashi <hayashi.kunihiko@socionext.com> --- .../devicetree/bindings/phy/socionext,uniphier-ahci-phy.yaml | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)