mbox series

[RESEND,0/1] thermal: mediatek: add suspend/resume callback

Message ID 20200408090558.12410-1-michael.kao@mediatek.com (mailing list archive)
Headers show
Series thermal: mediatek: add suspend/resume callback | expand

Message

Michael Kao April 8, 2020, 9:05 a.m. UTC
Change items:

1. Fix typo of measurement.
2. Change name of mtk_thermal_get_bank to mtk_thermal_lock_bank.
3. Change name of mtk_thermal_put_bank to mtk_thermal_unlock_bank.

Unchang items:

1. There are mtk_thermal_get_bank and mtk_thermal_put_bank in the
   mtk_thermal_init_bank. So we also add mtk_thermal_get_bank and
   mtk_thermal_put_bank in the mtk_thermal_disable_sensing. Any
   control and settings of sensor in the thermal controller should
   lock and unlock to prevent thermal controller from reporting
   wrong temperature.

2. The mutex lock was changed in this patch.
   [v4,7/7] thermal: mediatek: use spinlock to protect PTPCORESEL
   (https://patchwork.kernel.org/patch/11452835/)



Louis Yu (1):
  thermal: mediatek: add suspend/resume callback

 drivers/thermal/mtk_thermal.c | 152 ++++++++++++++++++++++++++++++----
 1 file changed, 134 insertions(+), 18 deletions(-)