Message ID | 20220722200007.1839356-1-daniel.lezcano@linexp.org (mailing list archive) |
---|---|
Headers | show |
Series | thermal OF rework | expand |
Hi Rafael, On 22/07/2022 21:59, Daniel Lezcano wrote: > The thermal framework initialization with the device tree appears to > be complicated and hard to make it to evolve. > > It contains duplication of almost the same thermal generic structures > and has an assymetric initialization making hard any kind of serious > changes for more complex features. One of them is the multiple sensors > support per thermal zone. > > In order to set the scene for the aforementioned feature with generic > code, we need to cleanup and rework the device tree initialization. > > However this rework is not obvious because of the multiple components > entering in the composition of a thermal zone and being initialized at > different moments. For instance, a cooling device can be initialized > before a sensor, so the thermal zones must exist before the cooling > device as well as the sensor. This asynchronous initialization forces > the thermal zone to be created with fake ops because they are > mandotory and build a list of cooling devices which is used to lookup > afterwards when the cooling device driver is registering itself. > > As there could be a large number of changes, this first series provide > some steps forward for a simpler device tree initialization. > > More series for cleanup and code duplication removal will follow. > > Changelog: > > - v6: > - Folded patches 8, 9, 10 > - Removed thermal_zone_get_trips() and thermal_zone_get_num_trips() > - Moved tz->ntrips => tz->num_trips changes into patch 11 to fix the > git bisecting > I believe all the comments were addressed, is it fine if I merge this series ?
Hi Daniel, On Mon, Jul 25, 2022 at 6:34 PM Daniel Lezcano <daniel.lezcano@linaro.org> wrote: > > > Hi Rafael, > > On 22/07/2022 21:59, Daniel Lezcano wrote: > > The thermal framework initialization with the device tree appears to > > be complicated and hard to make it to evolve. > > > > It contains duplication of almost the same thermal generic structures > > and has an assymetric initialization making hard any kind of serious > > changes for more complex features. One of them is the multiple sensors > > support per thermal zone. > > > > In order to set the scene for the aforementioned feature with generic > > code, we need to cleanup and rework the device tree initialization. > > > > However this rework is not obvious because of the multiple components > > entering in the composition of a thermal zone and being initialized at > > different moments. For instance, a cooling device can be initialized > > before a sensor, so the thermal zones must exist before the cooling > > device as well as the sensor. This asynchronous initialization forces > > the thermal zone to be created with fake ops because they are > > mandotory and build a list of cooling devices which is used to lookup > > afterwards when the cooling device driver is registering itself. > > > > As there could be a large number of changes, this first series provide > > some steps forward for a simpler device tree initialization. > > > > More series for cleanup and code duplication removal will follow. > > > > Changelog: > > > > - v6: > > - Folded patches 8, 9, 10 > > - Removed thermal_zone_get_trips() and thermal_zone_get_num_trips() > > - Moved tz->ntrips => tz->num_trips changes into patch 11 to fix the > > git bisecting > > > > I believe all the comments were addressed, is it fine if I merge this > series ? Yes, please!
Hi Daniel, On 7/25/22 17:34, Daniel Lezcano wrote: > > Hi Rafael, > > On 22/07/2022 21:59, Daniel Lezcano wrote: >> The thermal framework initialization with the device tree appears to >> be complicated and hard to make it to evolve. >> >> It contains duplication of almost the same thermal generic structures >> and has an assymetric initialization making hard any kind of serious >> changes for more complex features. One of them is the multiple sensors >> support per thermal zone. >> >> In order to set the scene for the aforementioned feature with generic >> code, we need to cleanup and rework the device tree initialization. >> >> However this rework is not obvious because of the multiple components >> entering in the composition of a thermal zone and being initialized at >> different moments. For instance, a cooling device can be initialized >> before a sensor, so the thermal zones must exist before the cooling >> device as well as the sensor. This asynchronous initialization forces >> the thermal zone to be created with fake ops because they are >> mandotory and build a list of cooling devices which is used to lookup >> afterwards when the cooling device driver is registering itself. >> >> As there could be a large number of changes, this first series provide >> some steps forward for a simpler device tree initialization. >> >> More series for cleanup and code duplication removal will follow. >> >> Changelog: >> >> - v6: >> - Folded patches 8, 9, 10 >> - Removed thermal_zone_get_trips() and thermal_zone_get_num_trips() >> - Moved tz->ntrips => tz->num_trips changes into patch 11 to fix the >> git bisecting >> > > I believe all the comments were addressed, is it fine if I merge this > series ? > > My apologies for being quiet, I was on holiday last week. Please don't wait for me, I'm still catching up with internal stuff. Based on your changelog I can see you've addressed my comments. Regards, Lukasz