diff mbox series

[RFC] PM / Domains: enable domain idle state accounting

Message ID 20200925024200.6429-1-ilina@codeaurora.org (mailing list archive)
State RFC, archived
Headers show
Series [RFC] PM / Domains: enable domain idle state accounting | expand

Commit Message

Lina Iyer Sept. 25, 2020, 2:42 a.m. UTC
To enable better debug of PM domains, let's keep a track of the success
and failures in entering each domain idle state.

This statistics is exported in debugfs when reading the idle_states
node, associated with each PM domain.

Signed-off-by: Lina Iyer <ilina@codeaurora.org>

---
This patch depends-on: https://lkml.org/lkml/2020/9/24/465
---
 drivers/base/power/domain.c | 7 +++++--
 include/linux/pm_domain.h   | 2 ++
 2 files changed, 7 insertions(+), 2 deletions(-)

Comments

Rafael J. Wysocki Sept. 25, 2020, 3:29 p.m. UTC | #1
On Fri, Sep 25, 2020 at 4:42 AM Lina Iyer <ilina@codeaurora.org> wrote:
>
> To enable better debug of PM domains, let's keep a track of the success
> and failures in entering each domain idle state.
>
> This statistics is exported in debugfs when reading the idle_states
> node, associated with each PM domain.
>
> Signed-off-by: Lina Iyer <ilina@codeaurora.org>
>
> ---
> This patch depends-on: https://lkml.org/lkml/2020/9/24/465
> ---
>  drivers/base/power/domain.c | 7 +++++--
>  include/linux/pm_domain.h   | 2 ++
>  2 files changed, 7 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/base/power/domain.c b/drivers/base/power/domain.c
> index f001ac6326fb..ba3355f935da 100644
> --- a/drivers/base/power/domain.c
> +++ b/drivers/base/power/domain.c
> @@ -564,6 +564,7 @@ static int genpd_power_off(struct generic_pm_domain *genpd, bool one_dev_on,
>
>         genpd->status = GENPD_STATE_OFF;
>         genpd_update_accounting(genpd);
> +       genpd->states[genpd->state_idx].usage++;
>
>         list_for_each_entry(link, &genpd->child_links, child_node) {
>                 genpd_sd_counter_dec(link->parent);
> @@ -574,6 +575,7 @@ static int genpd_power_off(struct generic_pm_domain *genpd, bool one_dev_on,
>
>         return 0;
>  busy:
> +       genpd->states[genpd->state_idx].failed++;

What about consistently calling these "rejected" instead of "failed"?

>         if (nr_calls)
>                 __raw_notifier_call_chain(&genpd->power_notifiers,
>                                           GENPD_STATE_ON, NULL,
> @@ -3053,7 +3055,7 @@ static int idle_states_show(struct seq_file *s, void *data)
>         if (ret)
>                 return -ERESTARTSYS;
>
> -       seq_puts(s, "State          Time Spent(ms)\n");
> +       seq_puts(s, "State          Time Spent(ms) Usage          Failed\n");
>
>         for (i = 0; i < genpd->state_count; i++) {
>                 ktime_t delta = 0;
> @@ -3065,7 +3067,8 @@ static int idle_states_show(struct seq_file *s, void *data)
>
>                 msecs = ktime_to_ms(
>                         ktime_add(genpd->states[i].idle_time, delta));
> -               seq_printf(s, "S%-13i %lld\n", i, msecs);
> +               seq_printf(s, "S%-13i %-14lld %-14llu %llu\n", i, msecs,
> +                             genpd->states[i].usage, genpd->states[i].failed);
>         }
>
>         genpd_unlock(genpd);
> diff --git a/include/linux/pm_domain.h b/include/linux/pm_domain.h
> index 3b2b561ce846..c30994ec0cec 100644
> --- a/include/linux/pm_domain.h
> +++ b/include/linux/pm_domain.h
> @@ -82,6 +82,8 @@ struct genpd_power_state {
>         s64 power_off_latency_ns;
>         s64 power_on_latency_ns;
>         s64 residency_ns;
> +       u64 usage;
> +       u64 failed;
>         struct fwnode_handle *fwnode;
>         ktime_t idle_time;
>         void *data;
> --
> The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
> a Linux Foundation Collaborative Project
>
Lina Iyer Sept. 25, 2020, 3:41 p.m. UTC | #2
On Fri, Sep 25 2020 at 09:29 -0600, Rafael J. Wysocki wrote:
>On Fri, Sep 25, 2020 at 4:42 AM Lina Iyer <ilina@codeaurora.org> wrote:
>>
>> To enable better debug of PM domains, let's keep a track of the success
>> and failures in entering each domain idle state.
>>
>> This statistics is exported in debugfs when reading the idle_states
>> node, associated with each PM domain.
>>
>> Signed-off-by: Lina Iyer <ilina@codeaurora.org>
>>
>> ---
>> This patch depends-on: https://lkml.org/lkml/2020/9/24/465
>> ---
>>  drivers/base/power/domain.c | 7 +++++--
>>  include/linux/pm_domain.h   | 2 ++
>>  2 files changed, 7 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/base/power/domain.c b/drivers/base/power/domain.c
>> index f001ac6326fb..ba3355f935da 100644
>> --- a/drivers/base/power/domain.c
>> +++ b/drivers/base/power/domain.c
>> @@ -564,6 +564,7 @@ static int genpd_power_off(struct generic_pm_domain *genpd, bool one_dev_on,
>>
>>         genpd->status = GENPD_STATE_OFF;
>>         genpd_update_accounting(genpd);
>> +       genpd->states[genpd->state_idx].usage++;
>>
>>         list_for_each_entry(link, &genpd->child_links, child_node) {
>>                 genpd_sd_counter_dec(link->parent);
>> @@ -574,6 +575,7 @@ static int genpd_power_off(struct generic_pm_domain *genpd, bool one_dev_on,
>>
>>         return 0;
>>  busy:
>> +       genpd->states[genpd->state_idx].failed++;
>
>What about consistently calling these "rejected" instead of "failed"?
>
I wasn't sure, will change these too. Thanks Rafael.

--Lina

>>         if (nr_calls)
>>                 __raw_notifier_call_chain(&genpd->power_notifiers,
>>                                           GENPD_STATE_ON, NULL,
>> @@ -3053,7 +3055,7 @@ static int idle_states_show(struct seq_file *s, void *data)
>>         if (ret)
>>                 return -ERESTARTSYS;
>>
>> -       seq_puts(s, "State          Time Spent(ms)\n");
>> +       seq_puts(s, "State          Time Spent(ms) Usage          Failed\n");
>>
>>         for (i = 0; i < genpd->state_count; i++) {
>>                 ktime_t delta = 0;
>> @@ -3065,7 +3067,8 @@ static int idle_states_show(struct seq_file *s, void *data)
>>
>>                 msecs = ktime_to_ms(
>>                         ktime_add(genpd->states[i].idle_time, delta));
>> -               seq_printf(s, "S%-13i %lld\n", i, msecs);
>> +               seq_printf(s, "S%-13i %-14lld %-14llu %llu\n", i, msecs,
>> +                             genpd->states[i].usage, genpd->states[i].failed);
>>         }
>>
>>         genpd_unlock(genpd);
>> diff --git a/include/linux/pm_domain.h b/include/linux/pm_domain.h
>> index 3b2b561ce846..c30994ec0cec 100644
>> --- a/include/linux/pm_domain.h
>> +++ b/include/linux/pm_domain.h
>> @@ -82,6 +82,8 @@ struct genpd_power_state {
>>         s64 power_off_latency_ns;
>>         s64 power_on_latency_ns;
>>         s64 residency_ns;
>> +       u64 usage;
>> +       u64 failed;
>>         struct fwnode_handle *fwnode;
>>         ktime_t idle_time;
>>         void *data;
>> --
>> The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
>> a Linux Foundation Collaborative Project
>>
diff mbox series

Patch

diff --git a/drivers/base/power/domain.c b/drivers/base/power/domain.c
index f001ac6326fb..ba3355f935da 100644
--- a/drivers/base/power/domain.c
+++ b/drivers/base/power/domain.c
@@ -564,6 +564,7 @@  static int genpd_power_off(struct generic_pm_domain *genpd, bool one_dev_on,
 
 	genpd->status = GENPD_STATE_OFF;
 	genpd_update_accounting(genpd);
+	genpd->states[genpd->state_idx].usage++;
 
 	list_for_each_entry(link, &genpd->child_links, child_node) {
 		genpd_sd_counter_dec(link->parent);
@@ -574,6 +575,7 @@  static int genpd_power_off(struct generic_pm_domain *genpd, bool one_dev_on,
 
 	return 0;
 busy:
+	genpd->states[genpd->state_idx].failed++;
 	if (nr_calls)
 		__raw_notifier_call_chain(&genpd->power_notifiers,
 					  GENPD_STATE_ON, NULL,
@@ -3053,7 +3055,7 @@  static int idle_states_show(struct seq_file *s, void *data)
 	if (ret)
 		return -ERESTARTSYS;
 
-	seq_puts(s, "State          Time Spent(ms)\n");
+	seq_puts(s, "State          Time Spent(ms) Usage          Failed\n");
 
 	for (i = 0; i < genpd->state_count; i++) {
 		ktime_t delta = 0;
@@ -3065,7 +3067,8 @@  static int idle_states_show(struct seq_file *s, void *data)
 
 		msecs = ktime_to_ms(
 			ktime_add(genpd->states[i].idle_time, delta));
-		seq_printf(s, "S%-13i %lld\n", i, msecs);
+		seq_printf(s, "S%-13i %-14lld %-14llu %llu\n", i, msecs,
+			      genpd->states[i].usage, genpd->states[i].failed);
 	}
 
 	genpd_unlock(genpd);
diff --git a/include/linux/pm_domain.h b/include/linux/pm_domain.h
index 3b2b561ce846..c30994ec0cec 100644
--- a/include/linux/pm_domain.h
+++ b/include/linux/pm_domain.h
@@ -82,6 +82,8 @@  struct genpd_power_state {
 	s64 power_off_latency_ns;
 	s64 power_on_latency_ns;
 	s64 residency_ns;
+	u64 usage;
+	u64 failed;
 	struct fwnode_handle *fwnode;
 	ktime_t idle_time;
 	void *data;