diff mbox series

[03/10] tools/power turbostat: Rename arl_features to lnl_features

Message ID 20241114075946.118577-4-rui.zhang@intel.com (mailing list archive)
State Accepted, archived
Delegated to: Len Brown
Headers show
Series tools/power turbostat: Fixes, enabling and enhancements | expand

Commit Message

Zhang Rui Nov. 14, 2024, 7:59 a.m. UTC
As ARL shares the same features with ADL/RPL/MTL, now 'arl_features' is
used by Lunarlake platform only.

Rename 'arl_features' to 'lnl_features'.

No functional change.

Signed-off-by: Zhang Rui <rui.zhang@intel.com>
---
 tools/power/x86/turbostat/turbostat.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/tools/power/x86/turbostat/turbostat.c b/tools/power/x86/turbostat/turbostat.c
index b35f63c2b206..3d59718516df 100644
--- a/tools/power/x86/turbostat/turbostat.c
+++ b/tools/power/x86/turbostat/turbostat.c
@@ -746,7 +746,7 @@  static const struct platform_features adl_features = {
 	.enable_tsc_tweak = 1,
 };
 
-static const struct platform_features arl_features = {
+static const struct platform_features lnl_features = {
 	.has_msr_misc_feature_control = 1,
 	.has_msr_misc_pwr_mgmt = 1,
 	.has_nhm_msrs = 1,
@@ -1008,7 +1008,7 @@  static const struct platform_data turbostat_pdata[] = {
 	{ INTEL_ARROWLAKE_H, &adl_features },
 	{ INTEL_ARROWLAKE_U, &adl_features },
 	{ INTEL_ARROWLAKE, &adl_features },
-	{ INTEL_LUNARLAKE_M, &arl_features },
+	{ INTEL_LUNARLAKE_M, &lnl_features },
 	{ INTEL_ATOM_SILVERMONT, &slv_features },
 	{ INTEL_ATOM_SILVERMONT_D, &slvd_features },
 	{ INTEL_ATOM_AIRMONT, &amt_features },