mbox series

[OLK-5.10,v3,0/4] md: bugfix of writing raid sysfs

Message ID 20230515134808.3936750-1-linan666@huaweicloud.com (mailing list archive)
Headers show
Series md: bugfix of writing raid sysfs | expand

Message

Li Nan May 15, 2023, 1:48 p.m. UTC
From: Li Nan <linan122@huawei.com>

The patch series fix the bug of writing raid sysfs.

Changes in v2:
 - in patch 1, move check out of md_bitmap_checkpage().
 - in patch 2, use div64_u64() and DIV64_U64_ROUND_UP() instead of directly
   '/', and chang old_delay/old_delay to unsigned int.
 - in patch 4, use 'goto' to make changes more readable.

Changes in v2:
 - add patch "md/raid10: optimize check_decay_read_errors()".
 - in patch 2, return ret-value of strict_strtoul_scaled if error occurs.
 - in patch 3, optimize format.

Li Nan (4):
  md/raid10: fix slab-out-of-bounds in md_bitmap_get_counter
  md/raid10: fix overflow in safe_delay_store
  md/raid10: fix wrong setting of max_corr_read_errors
  md/raid10: optimize check_decay_read_errors()

 drivers/md/md-bitmap.c | 17 ++++-----
 drivers/md/md.c        | 78 ++++++++++++++++++++++++++----------------
 drivers/md/raid10.c    | 41 +++++++++++++---------
 3 files changed, 82 insertions(+), 54 deletions(-)

Comments

Song Liu May 19, 2023, 10:07 p.m. UTC | #1
On Mon, May 15, 2023 at 6:49 AM <linan666@huaweicloud.com> wrote:
>
> From: Li Nan <linan122@huawei.com>
>
> The patch series fix the bug of writing raid sysfs.
>
> Changes in v2:
>  - in patch 1, move check out of md_bitmap_checkpage().
>  - in patch 2, use div64_u64() and DIV64_U64_ROUND_UP() instead of directly
>    '/', and chang old_delay/old_delay to unsigned int.
>  - in patch 4, use 'goto' to make changes more readable.
>
> Changes in v2:
>  - add patch "md/raid10: optimize check_decay_read_errors()".
>  - in patch 2, return ret-value of strict_strtoul_scaled if error occurs.
>  - in patch 3, optimize format.
>
> Li Nan (4):
>   md/raid10: fix slab-out-of-bounds in md_bitmap_get_counter
>   md/raid10: fix overflow in safe_delay_store
>   md/raid10: fix wrong setting of max_corr_read_errors
>   md/raid10: optimize check_decay_read_errors()

I applied 1/4 to md-next.

Thanks,
Song
Song Liu May 19, 2023, 10:08 p.m. UTC | #2
Btw, what does "OLK-5.10" mean?

Song


On Fri, May 19, 2023 at 3:07 PM Song Liu <song@kernel.org> wrote:
>
> On Mon, May 15, 2023 at 6:49 AM <linan666@huaweicloud.com> wrote:
> >
> > From: Li Nan <linan122@huawei.com>
> >
> > The patch series fix the bug of writing raid sysfs.
> >
> > Changes in v2:
> >  - in patch 1, move check out of md_bitmap_checkpage().
> >  - in patch 2, use div64_u64() and DIV64_U64_ROUND_UP() instead of directly
> >    '/', and chang old_delay/old_delay to unsigned int.
> >  - in patch 4, use 'goto' to make changes more readable.
> >
> > Changes in v2:
> >  - add patch "md/raid10: optimize check_decay_read_errors()".
> >  - in patch 2, return ret-value of strict_strtoul_scaled if error occurs.
> >  - in patch 3, optimize format.
> >
> > Li Nan (4):
> >   md/raid10: fix slab-out-of-bounds in md_bitmap_get_counter
> >   md/raid10: fix overflow in safe_delay_store
> >   md/raid10: fix wrong setting of max_corr_read_errors
> >   md/raid10: optimize check_decay_read_errors()
>
> I applied 1/4 to md-next.
>
> Thanks,
> Song
Li Nan May 20, 2023, 12:51 a.m. UTC | #3
在 2023/5/20 6:08, Song Liu 写道:
> Btw, what does "OLK-5.10" mean?
> 
> Song
> 

Sry, it is a slip of the pen.