diff mbox

[v3,4/4] MIPS: Deprecate VPE Loader

Message ID 1476193356-1350-5-git-send-email-matt.redfearn@imgtec.com
State Superseded
Headers show

Commit Message

Matt Redfearn Oct. 11, 2016, 1:42 p.m. UTC
The MIPS remote processor driver (CONFIG_MIPS_RPROC) provides a more
standard mechanism for using one or more VPs as coprocessors running
separate firmware.

Here we deprecate this mechanism before it is removed.

Signed-off-by: Matt Redfearn <matt.redfearn@imgtec.com>
---

Changes in v3: None
Changes in v2: None

 arch/mips/Kconfig | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Hauke Mehrtens Oct. 12, 2016, 11:09 a.m. UTC | #1
This interface is currently used by the Intel / Lantiq voice Firmware.
This firmware is used by all Intel / Lantiq MIPS SoCs when they should
support analog voice.

What is the proposed timeline for the removal of this interface?

Hauke

On 10/11/2016 03:42 PM, Matt Redfearn wrote:
> The MIPS remote processor driver (CONFIG_MIPS_RPROC) provides a more
> standard mechanism for using one or more VPs as coprocessors running
> separate firmware.
> 
> Here we deprecate this mechanism before it is removed.
> 
> Signed-off-by: Matt Redfearn <matt.redfearn@imgtec.com>
> ---
> 
> Changes in v3: None
> Changes in v2: None
> 
>  arch/mips/Kconfig | 5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)
> 
> diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
> index fd2468e71e63..3e767c373c7b 100644
> --- a/arch/mips/Kconfig
> +++ b/arch/mips/Kconfig
> @@ -2264,7 +2264,7 @@ comment "MIPS R2-to-R6 emulator is only available for UP kernels"
>  	depends on SMP && CPU_MIPSR6
>  
>  config MIPS_VPE_LOADER
> -	bool "VPE loader support."
> +	bool "VPE loader support (DEPRECATED)"
>  	depends on SYS_SUPPORTS_MULTITHREADING && MODULES
>  	select CPU_MIPSR2_IRQ_VI
>  	select CPU_MIPSR2_IRQ_EI
> @@ -2273,6 +2273,9 @@ config MIPS_VPE_LOADER
>  	  Includes a loader for loading an elf relocatable object
>  	  onto another VPE and running it.
>  
> +	  Unless you have a specific need, you should use CONFIG_MIPS_RPROC
> +          instead of this.
> +
>  config MIPS_VPE_LOADER_CMP
>  	bool
>  	default "y"
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-remoteproc" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Matt Redfearn Oct. 17, 2016, 11:01 a.m. UTC | #2
Hi Hauke,


On 12/10/16 12:09, Hauke Mehrtens wrote:
> This interface is currently used by the Intel / Lantiq voice Firmware.
> This firmware is used by all Intel / Lantiq MIPS SoCs when they should
> support analog voice.
>
> What is the proposed timeline for the removal of this interface?

Ultimately I guess that's Ralf's call, but when I've discussed this with 
him previously, he wasn't aware of any users of this feature. But if 
there are indeed active users then that will slow down it's removal to 
give them sufficient time to migrate or otherwise stop using it.

Thanks,
Matt

>
> Hauke
>
> On 10/11/2016 03:42 PM, Matt Redfearn wrote:
>> The MIPS remote processor driver (CONFIG_MIPS_RPROC) provides a more
>> standard mechanism for using one or more VPs as coprocessors running
>> separate firmware.
>>
>> Here we deprecate this mechanism before it is removed.
>>
>> Signed-off-by: Matt Redfearn <matt.redfearn@imgtec.com>
>> ---
>>
>> Changes in v3: None
>> Changes in v2: None
>>
>>   arch/mips/Kconfig | 5 ++++-
>>   1 file changed, 4 insertions(+), 1 deletion(-)
>>
>> diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
>> index fd2468e71e63..3e767c373c7b 100644
>> --- a/arch/mips/Kconfig
>> +++ b/arch/mips/Kconfig
>> @@ -2264,7 +2264,7 @@ comment "MIPS R2-to-R6 emulator is only available for UP kernels"
>>   	depends on SMP && CPU_MIPSR6
>>   
>>   config MIPS_VPE_LOADER
>> -	bool "VPE loader support."
>> +	bool "VPE loader support (DEPRECATED)"
>>   	depends on SYS_SUPPORTS_MULTITHREADING && MODULES
>>   	select CPU_MIPSR2_IRQ_VI
>>   	select CPU_MIPSR2_IRQ_EI
>> @@ -2273,6 +2273,9 @@ config MIPS_VPE_LOADER
>>   	  Includes a loader for loading an elf relocatable object
>>   	  onto another VPE and running it.
>>   
>> +	  Unless you have a specific need, you should use CONFIG_MIPS_RPROC
>> +          instead of this.
>> +
>>   config MIPS_VPE_LOADER_CMP
>>   	bool
>>   	default "y"
>>

--
To unsubscribe from this list: send the line "unsubscribe linux-remoteproc" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
index fd2468e71e63..3e767c373c7b 100644
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -2264,7 +2264,7 @@  comment "MIPS R2-to-R6 emulator is only available for UP kernels"
 	depends on SMP && CPU_MIPSR6
 
 config MIPS_VPE_LOADER
-	bool "VPE loader support."
+	bool "VPE loader support (DEPRECATED)"
 	depends on SYS_SUPPORTS_MULTITHREADING && MODULES
 	select CPU_MIPSR2_IRQ_VI
 	select CPU_MIPSR2_IRQ_EI
@@ -2273,6 +2273,9 @@  config MIPS_VPE_LOADER
 	  Includes a loader for loading an elf relocatable object
 	  onto another VPE and running it.
 
+	  Unless you have a specific need, you should use CONFIG_MIPS_RPROC
+          instead of this.
+
 config MIPS_VPE_LOADER_CMP
 	bool
 	default "y"