diff mbox series

[2/2] remoteproc: fix kernel doc for struct rproc_ops

Message ID 20210706142156.952794-2-aisheng.dong@nxp.com (mailing list archive)
State Accepted
Commit 147b589c5f446d602215577835356a96c40a4044
Headers show
Series [1/2] remoteproc: fix an typo in fw_elf_get_class code comments | expand

Commit Message

Dong Aisheng July 6, 2021, 2:21 p.m. UTC
The load_rsc_table was removed since the
commit c1d35c1ab424 ("remoteproc: Rename "load_rsc_table" to "parse_fw"")
but got added back again by mistake in the below commit:
commit b1a17513a2d6 ("remoteproc: add vendor resources handling").

The patch fixed a small code indent issue which not worth
a separate patch.

Fixes: b1a17513a2d6 ("remoteproc: add vendor resources handling")
Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
---
 include/linux/remoteproc.h | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Comments

Mathieu Poirier July 12, 2021, 5:41 p.m. UTC | #1
On Tue, Jul 06, 2021 at 10:21:56PM +0800, Dong Aisheng wrote:
> The load_rsc_table was removed since the
> commit c1d35c1ab424 ("remoteproc: Rename "load_rsc_table" to "parse_fw"")
> but got added back again by mistake in the below commit:
> commit b1a17513a2d6 ("remoteproc: add vendor resources handling").
> 
> The patch fixed a small code indent issue which not worth
> a separate patch.
> 
> Fixes: b1a17513a2d6 ("remoteproc: add vendor resources handling")
> Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
> ---
>  include/linux/remoteproc.h | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>

Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org>

Bjorn - checkpatch gets confused with the two double quotes in the changelog.  I
checked the syntax and everything is conformant to the guidelines.

> diff --git a/include/linux/remoteproc.h b/include/linux/remoteproc.h
> index a5b37bc10865..83c09ac36b13 100644
> --- a/include/linux/remoteproc.h
> +++ b/include/linux/remoteproc.h
> @@ -369,9 +369,8 @@ enum rsc_handling_status {
>   * @da_to_va:	optional platform hook to perform address translations
>   * @parse_fw:	parse firmware to extract information (e.g. resource table)
>   * @handle_rsc:	optional platform hook to handle vendor resources. Should return
> - * RSC_HANDLED if resource was handled, RSC_IGNORED if not handled and a
> - * negative value on error
> - * @load_rsc_table:	load resource table from firmware image
> + *		RSC_HANDLED if resource was handled, RSC_IGNORED if not handled
> + *		and a negative value on error
>   * @find_loaded_rsc_table: find the loaded resource table from firmware image
>   * @get_loaded_rsc_table: get resource table installed in memory
>   *			  by external entity
> -- 
> 2.25.1
>
diff mbox series

Patch

diff --git a/include/linux/remoteproc.h b/include/linux/remoteproc.h
index a5b37bc10865..83c09ac36b13 100644
--- a/include/linux/remoteproc.h
+++ b/include/linux/remoteproc.h
@@ -369,9 +369,8 @@  enum rsc_handling_status {
  * @da_to_va:	optional platform hook to perform address translations
  * @parse_fw:	parse firmware to extract information (e.g. resource table)
  * @handle_rsc:	optional platform hook to handle vendor resources. Should return
- * RSC_HANDLED if resource was handled, RSC_IGNORED if not handled and a
- * negative value on error
- * @load_rsc_table:	load resource table from firmware image
+ *		RSC_HANDLED if resource was handled, RSC_IGNORED if not handled
+ *		and a negative value on error
  * @find_loaded_rsc_table: find the loaded resource table from firmware image
  * @get_loaded_rsc_table: get resource table installed in memory
  *			  by external entity