mbox series

[00/13] usb: renesas_usbhs: refactor this driver

Message ID 1561441137-3090-1-git-send-email-yoshihiro.shimoda.uh@renesas.com (mailing list archive)
Headers show
Series usb: renesas_usbhs: refactor this driver | expand

Message

Yoshihiro Shimoda June 25, 2019, 5:38 a.m. UTC
This patch series is based on Greg's usb.git / usb-next branch.

The previous code had redundant memory allocations so that
the code readability was not good. I believe this patch series
makes it better.

Yoshihiro Shimoda (13):
  usb: renesas_usbhs: revise the irq_vbus comments
  usb: renesas_usbhs: remove notify_hotplug callback
  usb: renesas_usbhs: move macros from mod.c to the mod.h
  usb: renesas_usbhs: Avoid to write platform_data's value
  usb: renesas_usbhs: Use a specific flag instead of type for multi_clks
  usb: renesas_usbhs: Remove type member from renesas_usbhs_driver_param
  usb: renesas_usbhs: Use dev_of_node macro instead of open coded
  usb: renesas_usbhs: Add has_new_pipe_configs flag
  usb: renesas_usbhs: Add struct device * declaration in usbhs_probe()
  usb: renesas_usbhs: move device tree properties parsing
  usb: renesas_usbhs: Add a common function for the .get_id
  usb: renesas_usbhs: Use renesas_usbhs_platform_info on
    of_device_id.data
  usb: renesas_usbhs: Use struct platform_callback pointer

 drivers/usb/renesas_usbhs/common.c     | 197 +++++++++++----------------------
 drivers/usb/renesas_usbhs/common.h     |  11 +-
 drivers/usb/renesas_usbhs/fifo.c       |   3 +-
 drivers/usb/renesas_usbhs/mod.c        |  23 ++--
 drivers/usb/renesas_usbhs/mod.h        |  26 ++++-
 drivers/usb/renesas_usbhs/mod_gadget.c |   7 +-
 drivers/usb/renesas_usbhs/rcar2.c      |  22 ++--
 drivers/usb/renesas_usbhs/rcar2.h      |   3 +-
 drivers/usb/renesas_usbhs/rcar3.c      |  33 ++++--
 drivers/usb/renesas_usbhs/rcar3.h      |   5 +-
 drivers/usb/renesas_usbhs/rza.c        |  18 +--
 drivers/usb/renesas_usbhs/rza.h        |   4 +-
 drivers/usb/renesas_usbhs/rza2.c       |  22 ++--
 include/linux/usb/renesas_usbhs.h      |  35 +-----
 14 files changed, 168 insertions(+), 241 deletions(-)

Comments

gregkh@linuxfoundation.org June 26, 2019, 2:34 a.m. UTC | #1
On Tue, Jun 25, 2019 at 02:38:44PM +0900, Yoshihiro Shimoda wrote:
> This patch series is based on Greg's usb.git / usb-next branch.
> 
> The previous code had redundant memory allocations so that
> the code readability was not good. I believe this patch series
> makes it better.

Nice cleanups, thanks for this!

greg k-h