This patch series is based on the latest net.git / main branch.
Changes from v1:
https://lore.kernel.org/all/20231121055255.3627949-1-yoshihiro.shimoda.uh@renesas.com/
- Separate a patch because fixing 2 issues.
- Add fixing wrong type of return value.
- Use goto for improving code readability.
Yoshihiro Shimoda (3):
net: rswitch: Fix type of ret in rswitch_start_xmit()
net: rswitch: Fix return value in rswitch_start_xmit()
net: rswitch: Fix missing dev_kfree_skb_any() in error path
drivers/net/ethernet/renesas/rswitch.c | 22 +++++++++++++---------
1 file changed, 13 insertions(+), 9 deletions(-)