diff mbox

clk: shmobile: Remove ARCH_SHMOBILE_MULTI

Message ID 1456189051-519-1-git-send-email-horms+renesas@verge.net.au (mailing list archive)
State Accepted
Delegated to: Geert Uytterhoeven
Headers show

Commit Message

Simon Horman Feb. 23, 2016, 12:57 a.m. UTC
As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.

This is part of an ongoing process to migrate from ARCH_SHMOBILE to
ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.

Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
---
 drivers/clk/Makefile | 1 -
 1 file changed, 1 deletion(-)

 Based on clk-next

Comments

Geert Uytterhoeven Feb. 23, 2016, 8:17 a.m. UTC | #1
On Tue, Feb 23, 2016 at 1:57 AM, Simon Horman
<horms+renesas@verge.net.au> wrote:
> As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
> that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
> drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.
>
> This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
>
> Signed-off-by: Simon Horman <horms+renesas@verge.net.au>

Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>

> ---
>  drivers/clk/Makefile | 1 -
>  1 file changed, 1 deletion(-)

> -obj-$(CONFIG_ARCH_SHMOBILE_MULTI)      += shmobile/
>  obj-$(CONFIG_ARCH_RENESAS)             += shmobile/

Should we rename clk/shmobile/ to clk/renesas/?
Or is that too much of a hassle?

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds
Geert Uytterhoeven Feb. 23, 2016, 8:19 a.m. UTC | #2
CC The New Mike ;-)

On Tue, Feb 23, 2016 at 1:57 AM, Simon Horman
<horms+renesas@verge.net.au> wrote:
> As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
> that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
> drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.
>
> This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
>
> Signed-off-by: Simon Horman <horms+renesas@verge.net.au>

Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>

> ---
>  drivers/clk/Makefile | 1 -
>  1 file changed, 1 deletion(-)
>
>  Based on clk-next
>
> diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
> index bae4be6501df..b19af449d2f3 100644
> --- a/drivers/clk/Makefile
> +++ b/drivers/clk/Makefile
> @@ -70,7 +70,6 @@ obj-$(CONFIG_COMMON_CLK_PXA)          += pxa/
>  obj-$(CONFIG_COMMON_CLK_QCOM)          += qcom/
>  obj-$(CONFIG_ARCH_ROCKCHIP)            += rockchip/
>  obj-$(CONFIG_COMMON_CLK_SAMSUNG)       += samsung/
> -obj-$(CONFIG_ARCH_SHMOBILE_MULTI)      += shmobile/

Should we rename clk/shmobile/ to clk/renesas/?
Or is that too much of a hassle?

>  obj-$(CONFIG_ARCH_RENESAS)             += shmobile/
>  obj-$(CONFIG_ARCH_SIRF)                        += sirf/
>  obj-$(CONFIG_ARCH_SOCFPGA)             += socfpga/

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds
Simon Horman Feb. 23, 2016, 9:10 a.m. UTC | #3
On Tue, Feb 23, 2016 at 09:19:27AM +0100, Geert Uytterhoeven wrote:
> CC The New Mike ;-)
> 
> On Tue, Feb 23, 2016 at 1:57 AM, Simon Horman
> <horms+renesas@verge.net.au> wrote:
> > As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
> > that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
> > drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.
> >
> > This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> > ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> > appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
> >
> > Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
> 
> Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>
> 
> > ---
> >  drivers/clk/Makefile | 1 -
> >  1 file changed, 1 deletion(-)
> >
> >  Based on clk-next
> >
> > diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
> > index bae4be6501df..b19af449d2f3 100644
> > --- a/drivers/clk/Makefile
> > +++ b/drivers/clk/Makefile
> > @@ -70,7 +70,6 @@ obj-$(CONFIG_COMMON_CLK_PXA)          += pxa/
> >  obj-$(CONFIG_COMMON_CLK_QCOM)          += qcom/
> >  obj-$(CONFIG_ARCH_ROCKCHIP)            += rockchip/
> >  obj-$(CONFIG_COMMON_CLK_SAMSUNG)       += samsung/
> > -obj-$(CONFIG_ARCH_SHMOBILE_MULTI)      += shmobile/
> 
> Should we rename clk/shmobile/ to clk/renesas/?
> Or is that too much of a hassle?

I think it is a good idea.  And I suspect it shouldn't be too difficult if
we coordinate things with Mike to handle any in-flight patches for that
directory.

> >  obj-$(CONFIG_ARCH_RENESAS)             += shmobile/
> >  obj-$(CONFIG_ARCH_SIRF)                        += sirf/
> >  obj-$(CONFIG_ARCH_SOCFPGA)             += socfpga/
Stephen Boyd Feb. 25, 2016, 11:44 p.m. UTC | #4
On 02/23, Simon Horman wrote:
> On Tue, Feb 23, 2016 at 09:19:27AM +0100, Geert Uytterhoeven wrote:
> > CC The New Mike ;-)
> > 
> > On Tue, Feb 23, 2016 at 1:57 AM, Simon Horman
> > <horms+renesas@verge.net.au> wrote:
> > > As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
> > > that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
> > > drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.
> > >
> > > This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> > > ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> > > appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
> > >
> > > Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
> > 
> > Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>
> > 

Applied to clk-next

> > >  drivers/clk/Makefile | 1 -
> > >  1 file changed, 1 deletion(-)
> > >
> > >  Based on clk-next
> > >
> > > diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
> > > index bae4be6501df..b19af449d2f3 100644
> > > --- a/drivers/clk/Makefile
> > > +++ b/drivers/clk/Makefile
> > > @@ -70,7 +70,6 @@ obj-$(CONFIG_COMMON_CLK_PXA)          += pxa/
> > >  obj-$(CONFIG_COMMON_CLK_QCOM)          += qcom/
> > >  obj-$(CONFIG_ARCH_ROCKCHIP)            += rockchip/
> > >  obj-$(CONFIG_COMMON_CLK_SAMSUNG)       += samsung/
> > > -obj-$(CONFIG_ARCH_SHMOBILE_MULTI)      += shmobile/
> > 
> > Should we rename clk/shmobile/ to clk/renesas/?
> > Or is that too much of a hassle?
> 
> I think it is a good idea.  And I suspect it shouldn't be too difficult if
> we coordinate things with Mike to handle any in-flight patches for that
> directory.

Feel free to send the patch.
Simon Horman March 3, 2016, 5:02 a.m. UTC | #5
On Thu, Feb 25, 2016 at 03:44:34PM -0800, Stephen Boyd wrote:
> On 02/23, Simon Horman wrote:
> > On Tue, Feb 23, 2016 at 09:19:27AM +0100, Geert Uytterhoeven wrote:
> > > CC The New Mike ;-)
> > > 
> > > On Tue, Feb 23, 2016 at 1:57 AM, Simon Horman
> > > <horms+renesas@verge.net.au> wrote:
> > > > As of 9b5ba0df4ea4 ("ARM: shmobile: Introduce ARCH_RENESAS") all platforms
> > > > that use Renesas clock drivers now select ARCH_RENESAS. As it is present in
> > > > drivers/clk/Makefile ARCH_SHMOBILE_MULTI may now be removed.
> > > >
> > > > This is part of an ongoing process to migrate from ARCH_SHMOBILE to
> > > > ARCH_RENESAS the motivation for which being that RENESAS seems to be a more
> > > > appropriate name than SHMOBILE for the majority of Renesas ARM based SoCs.
> > > >
> > > > Signed-off-by: Simon Horman <horms+renesas@verge.net.au>
> > > 
> > > Acked-by: Geert Uytterhoeven <geert+renesas@glider.be>
> > > 
> 
> Applied to clk-next
> 
> > > >  drivers/clk/Makefile | 1 -
> > > >  1 file changed, 1 deletion(-)
> > > >
> > > >  Based on clk-next
> > > >
> > > > diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
> > > > index bae4be6501df..b19af449d2f3 100644
> > > > --- a/drivers/clk/Makefile
> > > > +++ b/drivers/clk/Makefile
> > > > @@ -70,7 +70,6 @@ obj-$(CONFIG_COMMON_CLK_PXA)          += pxa/
> > > >  obj-$(CONFIG_COMMON_CLK_QCOM)          += qcom/
> > > >  obj-$(CONFIG_ARCH_ROCKCHIP)            += rockchip/
> > > >  obj-$(CONFIG_COMMON_CLK_SAMSUNG)       += samsung/
> > > > -obj-$(CONFIG_ARCH_SHMOBILE_MULTI)      += shmobile/
> > > 
> > > Should we rename clk/shmobile/ to clk/renesas/?
> > > Or is that too much of a hassle?
> > 
> > I think it is a good idea.  And I suspect it shouldn't be too difficult if
> > we coordinate things with Mike to handle any in-flight patches for that
> > directory.
> 
> Feel free to send the patch.

Done :)
diff mbox

Patch

diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
index bae4be6501df..b19af449d2f3 100644
--- a/drivers/clk/Makefile
+++ b/drivers/clk/Makefile
@@ -70,7 +70,6 @@  obj-$(CONFIG_COMMON_CLK_PXA)		+= pxa/
 obj-$(CONFIG_COMMON_CLK_QCOM)		+= qcom/
 obj-$(CONFIG_ARCH_ROCKCHIP)		+= rockchip/
 obj-$(CONFIG_COMMON_CLK_SAMSUNG)	+= samsung/
-obj-$(CONFIG_ARCH_SHMOBILE_MULTI)	+= shmobile/
 obj-$(CONFIG_ARCH_RENESAS)		+= shmobile/
 obj-$(CONFIG_ARCH_SIRF)			+= sirf/
 obj-$(CONFIG_ARCH_SOCFPGA)		+= socfpga/