diff mbox series

[1/2] clk: renesas: r8a779a0: Add PWM clock

Message ID 20230502170618.55967-2-wsa+renesas@sang-engineering.com (mailing list archive)
State Accepted
Delegated to: Geert Uytterhoeven
Headers show
Series r8a779a0: enable PWM | expand

Commit Message

Wolfram Sang May 2, 2023, 5:06 p.m. UTC
Tested-by: Kieran Bingham <kieran.bingham+renesas@ideasonboard.com>
Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
---
 drivers/clk/renesas/r8a779a0-cpg-mssr.c | 1 +
 1 file changed, 1 insertion(+)

Comments

Geert Uytterhoeven May 3, 2023, 10:09 a.m. UTC | #1
Hi Wolfram,

On Tue, May 2, 2023 at 7:06 PM Wolfram Sang
<wsa+renesas@sang-engineering.com> wrote:
> Tested-by: Kieran Bingham <kieran.bingham+renesas@ideasonboard.com>
> Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com>

Thanks for your patch!

> --- a/drivers/clk/renesas/r8a779a0-cpg-mssr.c
> +++ b/drivers/clk/renesas/r8a779a0-cpg-mssr.c
> @@ -170,6 +170,7 @@ static const struct mssr_mod_clk r8a779a0_mod_clks[] __initconst = {
>         DEF_MOD("msi3",         621,    R8A779A0_CLK_MSO),
>         DEF_MOD("msi4",         622,    R8A779A0_CLK_MSO),
>         DEF_MOD("msi5",         623,    R8A779A0_CLK_MSO),
> +       DEF_MOD("pwm",          628,    R8A779A0_CLK_S1D8),

Do you mind if I rename this to "pwm0" while applying, to match the docs?

Reviewed-by: Geert Uytterhoeven <geert+renesas@glider.be>
i.e. will queue in renesas-clk-for-v6.5.

>         DEF_MOD("rpc-if",       629,    R8A779A0_CLK_RPCD2),
>         DEF_MOD("scif0",        702,    R8A779A0_CLK_S1D8),
>         DEF_MOD("scif1",        703,    R8A779A0_CLK_S1D8),

Gr{oetje,eeting}s,

                        Geert
Wolfram Sang May 3, 2023, 12:41 p.m. UTC | #2
> > +       DEF_MOD("pwm",          628,    R8A779A0_CLK_S1D8),
> 
> Do you mind if I rename this to "pwm0" while applying, to match the docs?

No, feel free. I think it is a bit misleading because the clock is used
up to pwm4. But if the docs have it that way...
Geert Uytterhoeven May 3, 2023, 12:44 p.m. UTC | #3
Hi Wolfram,

On Wed, May 3, 2023 at 2:41 PM Wolfram Sang
<wsa+renesas@sang-engineering.com> wrote:
> > > +       DEF_MOD("pwm",          628,    R8A779A0_CLK_S1D8),
> >
> > Do you mind if I rename this to "pwm0" while applying, to match the docs?
>
> No, feel free. I think it is a bit misleading because the clock is used
> up to pwm4. But if the docs have it that way...

The preliminary R-Car V3U docs _are_ misleading... But it's probably
the best we'd ever get ;-)

Gr{oetje,eeting}s,

                        Geert
Kieran Bingham May 3, 2023, 7:37 p.m. UTC | #4
Quoting Geert Uytterhoeven (2023-05-03 11:09:29)
> Hi Wolfram,
> 
> On Tue, May 2, 2023 at 7:06 PM Wolfram Sang
> <wsa+renesas@sang-engineering.com> wrote:
> > Tested-by: Kieran Bingham <kieran.bingham+renesas@ideasonboard.com>
> > Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
> 
> Thanks for your patch!
> 
> > --- a/drivers/clk/renesas/r8a779a0-cpg-mssr.c
> > +++ b/drivers/clk/renesas/r8a779a0-cpg-mssr.c
> > @@ -170,6 +170,7 @@ static const struct mssr_mod_clk r8a779a0_mod_clks[] __initconst = {
> >         DEF_MOD("msi3",         621,    R8A779A0_CLK_MSO),
> >         DEF_MOD("msi4",         622,    R8A779A0_CLK_MSO),
> >         DEF_MOD("msi5",         623,    R8A779A0_CLK_MSO),
> > +       DEF_MOD("pwm",          628,    R8A779A0_CLK_S1D8),
> 
> Do you mind if I rename this to "pwm0" while applying, to match the docs?
> 
> Reviewed-by: Geert Uytterhoeven <geert+renesas@glider.be>
> i.e. will queue in renesas-clk-for-v6.5.

Either way is fine with me, and I've seen this work now so:

Reviewed-by: Kieran Bingham <kieran.bingham+renesas@ideasonboard.com>

> 
> >         DEF_MOD("rpc-if",       629,    R8A779A0_CLK_RPCD2),
> >         DEF_MOD("scif0",        702,    R8A779A0_CLK_S1D8),
> >         DEF_MOD("scif1",        703,    R8A779A0_CLK_S1D8),
> 
> Gr{oetje,eeting}s,
> 
>                         Geert
> 
> -- 
> Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org
> 
> In personal conversations with technical people, I call myself a hacker. But
> when I'm talking to journalists I just say "programmer" or something like that.
>                                 -- Linus Torvalds
diff mbox series

Patch

diff --git a/drivers/clk/renesas/r8a779a0-cpg-mssr.c b/drivers/clk/renesas/r8a779a0-cpg-mssr.c
index fcc8279647a6..136a0d4e7ed6 100644
--- a/drivers/clk/renesas/r8a779a0-cpg-mssr.c
+++ b/drivers/clk/renesas/r8a779a0-cpg-mssr.c
@@ -170,6 +170,7 @@  static const struct mssr_mod_clk r8a779a0_mod_clks[] __initconst = {
 	DEF_MOD("msi3",		621,	R8A779A0_CLK_MSO),
 	DEF_MOD("msi4",		622,	R8A779A0_CLK_MSO),
 	DEF_MOD("msi5",		623,	R8A779A0_CLK_MSO),
+	DEF_MOD("pwm",		628,	R8A779A0_CLK_S1D8),
 	DEF_MOD("rpc-if",	629,	R8A779A0_CLK_RPCD2),
 	DEF_MOD("scif0",	702,	R8A779A0_CLK_S1D8),
 	DEF_MOD("scif1",	703,	R8A779A0_CLK_S1D8),