@@ -171,20 +171,20 @@ patternProperties:
interrupts:
description:
- I2C core will treat "irq" interrupt (or the very first interrupt if
- not using interrupt names) as primary interrupt for the target.
+ If not using interrupt-names, the first interrupt will be treated as
+ the primary interrupt for the target.
interrupt-names:
anyOf:
- {} # Any name is allowed.
- - items:
+ - contains:
enum:
- irq
- wakeup
- - smbus_alert
description:
- Names which are recognized by I2C core, other names are left to
- individual bindings.
+ Generic names are "irq" for the primary interrupt and "wakeup"
+ for the wakeup interrupt. Other names are left to individual
+ bindings.
wakeup-source:
description:
Schemas should be OS agnostic, so don't mention what the "I2C core" will do because this only applies to Linux. Also, drop the generic "smbus_alert" naming because this belongs to controllers not targets, so we don't want to describe it here. Finally, use "contains" instead of "items" because the enum is not exhaustive. Signed-off-by: Wolfram Sang <wsa+renesas@sang-engineering.com> --- dtschema/schemas/i2c/i2c-controller.yaml | 12 ++++++------ 1 file changed, 6 insertions(+), 6 deletions(-)