diff mbox series

[v2,1/3] usb: renesas_usbhs: Correct function references in comment

Message ID 20250407105002.107181-2-prabhakar.mahadev-lad.rj@bp.renesas.com (mailing list archive)
State Accepted
Delegated to: Geert Uytterhoeven
Headers show
Series usb: renesas_usbhs: Reorder clock handling | expand

Commit Message

Lad, Prabhakar April 7, 2025, 10:50 a.m. UTC
From: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com>

Update the comment to reference `usbhs_mod_probe()` instead of
`usbhs_mod_init()`, and replace `dev_set_drvdata()` with
`platform_set_drvdata()`, as these are the correct functions used
in this context.

Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com>
---
 drivers/usb/renesas_usbhs/common.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Kuninori Morimoto April 7, 2025, 10:29 p.m. UTC | #1
Hi

> Update the comment to reference `usbhs_mod_probe()` instead of
> `usbhs_mod_init()`, and replace `dev_set_drvdata()` with
> `platform_set_drvdata()`, as these are the correct functions used
> in this context.
> 
> Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com>
> ---

Acked-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>

Thank you for your help !!

Best regards
---
Kuninori Morimoto
Yoshihiro Shimoda April 8, 2025, 9:54 a.m. UTC | #2
Hello Prabhakar-san,

> From: Prabhakar, Sent: Monday, April 7, 2025 7:50 PM
> 
> Update the comment to reference `usbhs_mod_probe()` instead of
> `usbhs_mod_init()`, and replace `dev_set_drvdata()` with
> `platform_set_drvdata()`, as these are the correct functions used
> in this context.
> 
> Signed-off-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com>

Thank you for the patch!

Reviewed-by: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>

Best regards,
Yoshihiro Shimoda

> ---
>  drivers/usb/renesas_usbhs/common.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/usb/renesas_usbhs/common.c b/drivers/usb/renesas_usbhs/common.c
> index 4b35ef216125..03d4d40c90b3 100644
> --- a/drivers/usb/renesas_usbhs/common.c
> +++ b/drivers/usb/renesas_usbhs/common.c
> @@ -698,7 +698,7 @@ static int usbhs_probe(struct platform_device *pdev)
>  	if (ret < 0)
>  		goto probe_end_fifo_exit;
> 
> -	/* dev_set_drvdata should be called after usbhs_mod_init */
> +	/* platform_set_drvdata() should be called after usbhs_mod_probe() */
>  	platform_set_drvdata(pdev, priv);
> 
>  	ret = reset_control_deassert(priv->rsts);
> --
> 2.49.0
diff mbox series

Patch

diff --git a/drivers/usb/renesas_usbhs/common.c b/drivers/usb/renesas_usbhs/common.c
index 4b35ef216125..03d4d40c90b3 100644
--- a/drivers/usb/renesas_usbhs/common.c
+++ b/drivers/usb/renesas_usbhs/common.c
@@ -698,7 +698,7 @@  static int usbhs_probe(struct platform_device *pdev)
 	if (ret < 0)
 		goto probe_end_fifo_exit;
 
-	/* dev_set_drvdata should be called after usbhs_mod_init */
+	/* platform_set_drvdata() should be called after usbhs_mod_probe() */
 	platform_set_drvdata(pdev, priv);
 
 	ret = reset_control_deassert(priv->rsts);