diff mbox series

[1/5] ARM: dts: koelsch: Rename sw2 to keyboard

Message ID 3d718cf69e21b1ceea0c29c0e841b9bdda44533d.1619785905.git.geert+renesas@glider.be (mailing list archive)
State Accepted
Delegated to: Geert Uytterhoeven
Headers show
Series ARM: dts: rcar2: Configure pull up for GPIO keys | expand

Commit Message

Geert Uytterhoeven April 30, 2021, 1:10 p.m. UTC
Rename "sw2_pins" and "sw2" to "keyboard_pins" resp. "keyboard", to
comply with generic name recommendations.

Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
---
 arch/arm/boot/dts/r8a7791-koelsch.dts | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Niklas Söderlund May 1, 2021, 7:10 a.m. UTC | #1
Hi Geert,

Thanks for your work.

On 2021-04-30 15:10:51 +0200, Geert Uytterhoeven wrote:
> Rename "sw2_pins" and "sw2" to "keyboard_pins" resp. "keyboard", to
> comply with generic name recommendations.
> 
> Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>

Reviewed-by: Niklas Söderlund <niklas.soderlund+renesas@ragnatech.se>

> ---
>  arch/arm/boot/dts/r8a7791-koelsch.dts | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/arm/boot/dts/r8a7791-koelsch.dts b/arch/arm/boot/dts/r8a7791-koelsch.dts
> index 61e881bbbf6ee5aa..2a8b6fd9095cceba 100644
> --- a/arch/arm/boot/dts/r8a7791-koelsch.dts
> +++ b/arch/arm/boot/dts/r8a7791-koelsch.dts
> @@ -81,7 +81,7 @@ lbsc {
>  	keyboard {
>  		compatible = "gpio-keys";
>  
> -		pinctrl-0 = <&sw2_pins>;
> +		pinctrl-0 = <&keyboard_pins>;
>  		pinctrl-names = "default";
>  
>  		key-1 {
> @@ -622,7 +622,7 @@ sound_clk_pins: sound_clk {
>  		function = "audio_clk";
>  	};
>  
> -	sw2_pins: sw2 {
> +	keyboard_pins: keyboard {
>  		pins = "GP_5_0", "GP_5_1", "GP_5_2", "GP_5_3";
>  		bias-pull-up;
>  	};
> -- 
> 2.25.1
>
diff mbox series

Patch

diff --git a/arch/arm/boot/dts/r8a7791-koelsch.dts b/arch/arm/boot/dts/r8a7791-koelsch.dts
index 61e881bbbf6ee5aa..2a8b6fd9095cceba 100644
--- a/arch/arm/boot/dts/r8a7791-koelsch.dts
+++ b/arch/arm/boot/dts/r8a7791-koelsch.dts
@@ -81,7 +81,7 @@  lbsc {
 	keyboard {
 		compatible = "gpio-keys";
 
-		pinctrl-0 = <&sw2_pins>;
+		pinctrl-0 = <&keyboard_pins>;
 		pinctrl-names = "default";
 
 		key-1 {
@@ -622,7 +622,7 @@  sound_clk_pins: sound_clk {
 		function = "audio_clk";
 	};
 
-	sw2_pins: sw2 {
+	keyboard_pins: keyboard {
 		pins = "GP_5_0", "GP_5_1", "GP_5_2", "GP_5_3";
 		bias-pull-up;
 	};