diff mbox series

riscv, libbpf: use a0 for RC register

Message ID 20220706140204.47926-1-dlan@gentoo.org (mailing list archive)
State New, archived
Headers show
Series riscv, libbpf: use a0 for RC register | expand

Commit Message

Yixun Lan July 6, 2022, 2:02 p.m. UTC
According to the RISC-V calling convention register usage here[1],
a0 is used as return value register, so rename it to make it consistent
with the spec.

[1] section 18.2, table 18.2
https://riscv.org/wp-content/uploads/2015/01/riscv-calling.pdf

Fixes: 589fed479ba1 ("riscv, libbpf: Add RISC-V (RV64) support to bpf_tracing.h")
Signed-off-by: Yixun Lan <dlan@gentoo.org>

---

I'm adding a Fixes tag here, although the original version may just work fine,
and shouldn't be considered as a real error. But, the benefit is that we could
make it consistent with RISC-V spec, and all other tools will follow the same usage.

thanks, and let's me if there is any issue that I may not noticed..
---
 tools/lib/bpf/bpf_tracing.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Björn Töpel July 7, 2022, 8:53 a.m. UTC | #1
On Wed, 6 Jul 2022 at 16:03, Yixun Lan <dlan@gentoo.org> wrote:
>
> According to the RISC-V calling convention register usage here[1],
> a0 is used as return value register, so rename it to make it consistent
> with the spec.
>
> [1] section 18.2, table 18.2
> https://riscv.org/wp-content/uploads/2015/01/riscv-calling.pdf
>
> Fixes: 589fed479ba1 ("riscv, libbpf: Add RISC-V (RV64) support to bpf_tracing.h")
> Signed-off-by: Yixun Lan <dlan@gentoo.org>

Nice catch!

Acked-by: Björn Töpel <bjorn@kernel.org>
Amjad Ouled-Ameur July 7, 2022, 2:04 p.m. UTC | #2
Acked-by: Amjad OULED-AMEUR <ouledameur.amjad@gmail.com>
patchwork-bot+netdevbpf@kernel.org July 7, 2022, 2:40 p.m. UTC | #3
Hello:

This patch was applied to bpf/bpf-next.git (master)
by Daniel Borkmann <daniel@iogearbox.net>:

On Wed,  6 Jul 2022 22:02:04 +0800 you wrote:
> According to the RISC-V calling convention register usage here[1],
> a0 is used as return value register, so rename it to make it consistent
> with the spec.
> 
> [1] section 18.2, table 18.2
> https://riscv.org/wp-content/uploads/2015/01/riscv-calling.pdf
> 
> [...]

Here is the summary with links:
  - riscv, libbpf: use a0 for RC register
    https://git.kernel.org/bpf/bpf-next/c/935dc35c7531

You are awesome, thank you!
diff mbox series

Patch

diff --git a/tools/lib/bpf/bpf_tracing.h b/tools/lib/bpf/bpf_tracing.h
index 01ce121c302df..11f9096407fc4 100644
--- a/tools/lib/bpf/bpf_tracing.h
+++ b/tools/lib/bpf/bpf_tracing.h
@@ -233,7 +233,7 @@  struct pt_regs___arm64 {
 #define __PT_PARM5_REG a4
 #define __PT_RET_REG ra
 #define __PT_FP_REG s0
-#define __PT_RC_REG a5
+#define __PT_RC_REG a0
 #define __PT_SP_REG sp
 #define __PT_IP_REG pc
 /* riscv does not select ARCH_HAS_SYSCALL_WRAPPER. */