Message ID | 20210804130625.15449-8-michael.riesch@wolfvision.net (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | arm64: dts: rockchip: rk3568-evb1-v10: add sd card support | expand |
Hi Michael, Could you add a commit message to all patches in this serie? On 8/4/21 3:06 PM, Michael Riesch wrote: > Signed-off-by: Michael Riesch <michael.riesch@wolfvision.net> > --- > v2: > - rename alias to match convention > > arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts | 15 +++++++++++++++ > 1 file changed, 15 insertions(+) > > diff --git a/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts b/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts > index ed96f27c64a3..c4da6436059d 100644 > --- a/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts > +++ b/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts > @@ -17,6 +17,7 @@ > ethernet0 = &gmac0; > ethernet1 = &gmac1; > mmc0 = &sdhci; > + mmc1 = &sdmmc0; mmc aliases are sort on reg address based on availability without number gap. sdmmc0: mmc@fe2b0000 {} sdhci: mmc@fe310000 {} > }; > > chosen: chosen { > @@ -353,6 +354,20 @@ > status = "okay"; > }; > > +&sdmmc0 { > + bus-width = <4>; > + cap-sd-highspeed; > + cd-gpios = <&gpio0 RK_PA4 GPIO_ACTIVE_LOW>; > + disable-wp; > + pinctrl-names = "default"; > + pinctrl-0 = <&sdmmc0_bus4 &sdmmc0_clk &sdmmc0_cmd &sdmmc0_det>; pinctrl-names below pinctrl-0 like the rest of rk356x.dtsi > + sd-uhs-sdr104; > + supports-sd; Check mmc-controller.yaml, rockchip-dw-mshc.yaml and synopsys-dw-mshc-common.yaml for properties. > + vmmc-supply = <&vcc3v3_sd>; > + vqmmc-supply = <&vccio_sd>; > + status = "okay"; > +}; > + > &uart2 { > status = "okay"; > }; >
Hi Johan, Thanks for your comments, I'll try to implement the requested changes and prepare a v3 tomorrow. On 8/4/21 4:30 PM, Johan Jonker wrote: > Hi Michael, > > Could you add a commit message to all patches in this serie? Well the short commit message (i.e., the subject line) pretty much wraps it all up in my opinion, hence no need for an extended commit message. Is there anything in particular you would like to see or have explained that requires an extended message? I would like to refrain from adding an extended commit message just for the sake of having one. > On 8/4/21 3:06 PM, Michael Riesch wrote: >> Signed-off-by: Michael Riesch <michael.riesch@wolfvision.net> >> --- >> v2: >> - rename alias to match convention >> >> arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts | 15 +++++++++++++++ >> 1 file changed, 15 insertions(+) >> >> diff --git a/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts b/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts >> index ed96f27c64a3..c4da6436059d 100644 >> --- a/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts >> +++ b/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts >> @@ -17,6 +17,7 @@ >> ethernet0 = &gmac0; >> ethernet1 = &gmac1; > >> mmc0 = &sdhci; >> + mmc1 = &sdmmc0; > > mmc aliases are sort on reg address based on availability without number > gap. > > sdmmc0: mmc@fe2b0000 {} > sdhci: mmc@fe310000 {} I'll turn these around. >> }; >> >> chosen: chosen { >> @@ -353,6 +354,20 @@ >> status = "okay"; >> }; >> >> +&sdmmc0 { >> + bus-width = <4>; >> + cap-sd-highspeed; >> + cd-gpios = <&gpio0 RK_PA4 GPIO_ACTIVE_LOW>; >> + disable-wp; > >> + pinctrl-names = "default"; >> + pinctrl-0 = <&sdmmc0_bus4 &sdmmc0_clk &sdmmc0_cmd &sdmmc0_det>; > > pinctrl-names below pinctrl-0 like the rest of rk356x.dtsi OK! >> + sd-uhs-sdr104; > >> + supports-sd; > > Check mmc-controller.yaml, rockchip-dw-mshc.yaml and > synopsys-dw-mshc-common.yaml for properties. I am afraid I don't quite follow. What exactly should I check? I am pretty sure that the properties I used are described in the mentioned yaml files. Regards, Michael > >> + vmmc-supply = <&vcc3v3_sd>; >> + vqmmc-supply = <&vccio_sd>; >> + status = "okay"; >> +}; >> + >> &uart2 { >> status = "okay"; >> }; >>
Hi Michael, Am Mittwoch, 4. August 2021, 20:49:45 CEST schrieb Michael Riesch: > Hi Johan, > > Thanks for your comments, I'll try to implement the requested changes > and prepare a v3 tomorrow. > > On 8/4/21 4:30 PM, Johan Jonker wrote: > > Hi Michael, > > > > Could you add a commit message to all patches in this serie? > > Well the short commit message (i.e., the subject line) pretty much wraps > it all up in my opinion, hence no need for an extended commit message. > Is there anything in particular you would like to see or have explained > that requires an extended message? I would like to refrain from adding > an extended commit message just for the sake of having one. it's just a matter of style, and yes having a non-empty commit message is preferred in most parts of the kernel. Even if it's just a simple one-liner ;-), for example "Enable the sdmmc node on the rk3568-evb1 with the 4 lanes connected on it" Heiko > > > On 8/4/21 3:06 PM, Michael Riesch wrote: > >> Signed-off-by: Michael Riesch <michael.riesch@wolfvision.net> > >> --- > >> v2: > >> - rename alias to match convention > >> > >> arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts | 15 +++++++++++++++ > >> 1 file changed, 15 insertions(+) > >> > >> diff --git a/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts b/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts > >> index ed96f27c64a3..c4da6436059d 100644 > >> --- a/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts > >> +++ b/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts > >> @@ -17,6 +17,7 @@ > >> ethernet0 = &gmac0; > >> ethernet1 = &gmac1; > > > >> mmc0 = &sdhci; > >> + mmc1 = &sdmmc0; > > > > mmc aliases are sort on reg address based on availability without number > > gap. > > > > sdmmc0: mmc@fe2b0000 {} > > sdhci: mmc@fe310000 {} > > I'll turn these around. > > >> }; > >> > >> chosen: chosen { > >> @@ -353,6 +354,20 @@ > >> status = "okay"; > >> }; > >> > >> +&sdmmc0 { > >> + bus-width = <4>; > >> + cap-sd-highspeed; > >> + cd-gpios = <&gpio0 RK_PA4 GPIO_ACTIVE_LOW>; > >> + disable-wp; > > > >> + pinctrl-names = "default"; > >> + pinctrl-0 = <&sdmmc0_bus4 &sdmmc0_clk &sdmmc0_cmd &sdmmc0_det>; > > > > pinctrl-names below pinctrl-0 like the rest of rk356x.dtsi > > OK! > > >> + sd-uhs-sdr104; > > > >> + supports-sd; > > > > Check mmc-controller.yaml, rockchip-dw-mshc.yaml and > > synopsys-dw-mshc-common.yaml for properties. > > I am afraid I don't quite follow. What exactly should I check? I am > pretty sure that the properties I used are described in the mentioned > yaml files. > > Regards, Michael > > > > >> + vmmc-supply = <&vcc3v3_sd>; > >> + vqmmc-supply = <&vccio_sd>; > >> + status = "okay"; > >> +}; > >> + > >> &uart2 { > >> status = "okay"; > >> }; > >> >
diff --git a/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts b/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts index ed96f27c64a3..c4da6436059d 100644 --- a/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts +++ b/arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts @@ -17,6 +17,7 @@ ethernet0 = &gmac0; ethernet1 = &gmac1; mmc0 = &sdhci; + mmc1 = &sdmmc0; }; chosen: chosen { @@ -353,6 +354,20 @@ status = "okay"; }; +&sdmmc0 { + bus-width = <4>; + cap-sd-highspeed; + cd-gpios = <&gpio0 RK_PA4 GPIO_ACTIVE_LOW>; + disable-wp; + pinctrl-names = "default"; + pinctrl-0 = <&sdmmc0_bus4 &sdmmc0_clk &sdmmc0_cmd &sdmmc0_det>; + sd-uhs-sdr104; + supports-sd; + vmmc-supply = <&vcc3v3_sd>; + vqmmc-supply = <&vccio_sd>; + status = "okay"; +}; + &uart2 { status = "okay"; };
Signed-off-by: Michael Riesch <michael.riesch@wolfvision.net> --- v2: - rename alias to match convention arch/arm64/boot/dts/rockchip/rk3568-evb1-v10.dts | 15 +++++++++++++++ 1 file changed, 15 insertions(+)