diff mbox

ARM: SAMSUNG: Remove unused s5p_device_ehci

Message ID 000001cec55c$b70f0100$252d0300$%han@samsung.com (mailing list archive)
State New, archived
Headers show

Commit Message

Jingoo Han Oct. 10, 2013, 2:02 a.m. UTC
Since commit ca91435 "ARM: EXYNOS: Remove unused board files",
s5p_device_ehci is not used anymore. Thus, s5p_device_ehci can
be removed. Also, unnecessary S5P_DEV_USB_EHCI option is removed.

Signed-off-by: Jingoo Han <jg1.han@samsung.com>
---
 arch/arm/plat-samsung/Kconfig             |    5 -----
 arch/arm/plat-samsung/devs.c              |   34 -----------------------------
 arch/arm/plat-samsung/include/plat/devs.h |    1 -
 3 files changed, 40 deletions(-)

Comments

Hi,

On 10/10/2013 11:02 AM, Jingoo Han wrote:
> Since commit ca91435 "ARM: EXYNOS: Remove unused board files",
> s5p_device_ehci is not used anymore. Thus, s5p_device_ehci can
> be removed. Also, unnecessary S5P_DEV_USB_EHCI option is removed.
> 
> Signed-off-by: Jingoo Han <jg1.han@samsung.com>

Reviewed-by: Sylwester Nawrocki <s.nawrocki@samsung.com>

> diff --git a/arch/arm/plat-samsung/devs.c b/arch/arm/plat-samsung/devs.c
> index 8ce0ac0..25f40c9 100644
> --- a/arch/arm/plat-samsung/devs.c
> +++ b/arch/arm/plat-samsung/devs.c
> @@ -49,7 +49,6 @@
>  #include <plat/devs.h>
>  #include <plat/adc.h>
>  #include <linux/platform_data/ata-samsung_cf.h>
> -#include <linux/platform_data/usb-ehci-s5p.h>

Are you planning to remove also this file altogether ? Probably the
s5p-ehci driver could be cleaned up then and the platform_data handling
dropped from it as a follow up.

Thanks,
Sylwester
--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Jingoo Han Oct. 10, 2013, 2:40 a.m. UTC | #2
On Thursday, October 10, 2013 11:26 AM, Sylwester Nawrocki wrote:
> On 10/10/2013 11:02 AM, Jingoo Han wrote:
> > Since commit ca91435 "ARM: EXYNOS: Remove unused board files",
> > s5p_device_ehci is not used anymore. Thus, s5p_device_ehci can
> > be removed. Also, unnecessary S5P_DEV_USB_EHCI option is removed.
> >
> > Signed-off-by: Jingoo Han <jg1.han@samsung.com>
> 
> Reviewed-by: Sylwester Nawrocki <s.nawrocki@samsung.com>
> 
> > diff --git a/arch/arm/plat-samsung/devs.c b/arch/arm/plat-samsung/devs.c
> > index 8ce0ac0..25f40c9 100644
> > --- a/arch/arm/plat-samsung/devs.c
> > +++ b/arch/arm/plat-samsung/devs.c
> > @@ -49,7 +49,6 @@
> >  #include <plat/devs.h>
> >  #include <plat/adc.h>
> >  #include <linux/platform_data/ata-samsung_cf.h>
> > -#include <linux/platform_data/usb-ehci-s5p.h>
> 
> Are you planning to remove also this file altogether ? Probably the
> s5p-ehci driver could be cleaned up then and the platform_data handling
> dropped from it as a follow up.

Hi Sylwester Nawrocki,

I will rename s5p-ehci to s5p-exynos, then drop platform_data handling
from it. These will be separate patches.
Thank you your comment. :-)

Best regards,
Jingoo Han

--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Tomasz Figa Oct. 10, 2013, 5:17 a.m. UTC | #3
Hi Jingoo,

On Thursday 10 of October 2013 11:40:22 Jingoo Han wrote:
> On Thursday, October 10, 2013 11:26 AM, Sylwester Nawrocki wrote:
> > On 10/10/2013 11:02 AM, Jingoo Han wrote:
> > > Since commit ca91435 "ARM: EXYNOS: Remove unused board files",
> > > s5p_device_ehci is not used anymore. Thus, s5p_device_ehci can
> > > be removed. Also, unnecessary S5P_DEV_USB_EHCI option is removed.
> > > 
> > > Signed-off-by: Jingoo Han <jg1.han@samsung.com>
> > 
> > Reviewed-by: Sylwester Nawrocki <s.nawrocki@samsung.com>
> > 
> > > diff --git a/arch/arm/plat-samsung/devs.c b/arch/arm/plat-samsung/devs.c
> > > index 8ce0ac0..25f40c9 100644
> > > --- a/arch/arm/plat-samsung/devs.c
> > > +++ b/arch/arm/plat-samsung/devs.c
> > > @@ -49,7 +49,6 @@
> > > 
> > >  #include <plat/devs.h>
> > >  #include <plat/adc.h>
> > >  #include <linux/platform_data/ata-samsung_cf.h>
> > > 
> > > -#include <linux/platform_data/usb-ehci-s5p.h>
> > 
> > Are you planning to remove also this file altogether ? Probably the
> > s5p-ehci driver could be cleaned up then and the platform_data handling
> > dropped from it as a follow up.
> 
> Hi Sylwester Nawrocki,
> 
> I will rename s5p-ehci to s5p-exynos, then drop platform_data handling
> from it. These will be separate patches.
> Thank you your comment. :-)

I'd recommend keeping driver name as is. S5PV210 is going to receive DT 
support soon and it will be also able to use this driver.

Otherwise this looks fine.

Best regards,
Tomasz

--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Jingoo Han Oct. 10, 2013, 5:29 a.m. UTC | #4
On Thursday, October 10, 2013 2:18 PM, Tomasz Figa wrote:
> On Thursday 10 of October 2013 11:40:22 Jingoo Han wrote:
> > On Thursday, October 10, 2013 11:26 AM, Sylwester Nawrocki wrote:

[....]

> > > Are you planning to remove also this file altogether ? Probably the
> > > s5p-ehci driver could be cleaned up then and the platform_data handling
> > > dropped from it as a follow up.
> >
> > Hi Sylwester Nawrocki,
> >
> > I will rename s5p-ehci to s5p-exynos, then drop platform_data handling
> > from it. These will be separate patches.
> > Thank you your comment. :-)
> 
> I'd recommend keeping driver name as is. S5PV210 is going to receive DT
> support soon and it will be also able to use this driver.
> 

Hi Tomasz Figa,

Now, Exynos EHCI and OHCI driver's name is different as below:
 ehci-s5p.c
 ohci-exynos.c

I want to use same name. There is no reason to keep the different names.
Also I want to use '-exynos.c' even though S5PV210 can support EHCI and OHCI.
 ehci-exynos.c
 ohci-exynos.c

Then, do you want to use the following names?
 ehci-s5p.c
 ohci-s5p.c

Best regards,
Jingoo Han

--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Tomasz Figa Oct. 10, 2013, 5:40 a.m. UTC | #5
On Thursday 10 of October 2013 14:29:58 Jingoo Han wrote:
> On Thursday, October 10, 2013 2:18 PM, Tomasz Figa wrote:
> > On Thursday 10 of October 2013 11:40:22 Jingoo Han wrote:
> > > On Thursday, October 10, 2013 11:26 AM, Sylwester Nawrocki wrote:
> [....]
> 
> > > > Are you planning to remove also this file altogether ? Probably the
> > > > s5p-ehci driver could be cleaned up then and the platform_data
> > > > handling
> > > > dropped from it as a follow up.
> > > 
> > > Hi Sylwester Nawrocki,
> > > 
> > > I will rename s5p-ehci to s5p-exynos, then drop platform_data handling
> > > from it. These will be separate patches.
> > > Thank you your comment. :-)
> > 
> > I'd recommend keeping driver name as is. S5PV210 is going to receive DT
> > support soon and it will be also able to use this driver.
> 
> Hi Tomasz Figa,
> 
> Now, Exynos EHCI and OHCI driver's name is different as below:
>  ehci-s5p.c
>  ohci-exynos.c

Hmm, right, this inconsistency is a good point.

> I want to use same name. There is no reason to keep the different names.
> Also I want to use '-exynos.c' even though S5PV210 can support EHCI and
> OHCI. ehci-exynos.c
>  ohci-exynos.c

OK. S5PV210 is basically Exynos 3, so I guess it's fine. Although I'd suggest 
having a note in Kconfig entries of these drivers that they can be also used on 
S5PV210.

Best regards,
Tomasz

--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/arch/arm/plat-samsung/Kconfig b/arch/arm/plat-samsung/Kconfig
index 7dfba93..99bfbb3 100644
--- a/arch/arm/plat-samsung/Kconfig
+++ b/arch/arm/plat-samsung/Kconfig
@@ -382,11 +382,6 @@  config S5P_DEV_TV
 	help
 	  Compile in platform device definition for TV interface
 
-config S5P_DEV_USB_EHCI
-	bool
-	help
-	  Compile in platform device definition for USB EHCI
-
 config S3C24XX_PWM
 	bool "PWM device support"
 	select PWM
diff --git a/arch/arm/plat-samsung/devs.c b/arch/arm/plat-samsung/devs.c
index 8ce0ac0..25f40c9 100644
--- a/arch/arm/plat-samsung/devs.c
+++ b/arch/arm/plat-samsung/devs.c
@@ -49,7 +49,6 @@ 
 #include <plat/devs.h>
 #include <plat/adc.h>
 #include <linux/platform_data/ata-samsung_cf.h>
-#include <linux/platform_data/usb-ehci-s5p.h>
 #include <plat/fb.h>
 #include <plat/fb-s3c2410.h>
 #include <plat/hdmi.h>
@@ -1359,39 +1358,6 @@  void __init s3c24xx_udc_set_platdata(struct s3c2410_udc_mach_info *pd)
 }
 #endif /* CONFIG_PLAT_S3C24XX */
 
-/* USB EHCI Host Controller */
-
-#ifdef CONFIG_S5P_DEV_USB_EHCI
-static struct resource s5p_ehci_resource[] = {
-	[0] = DEFINE_RES_MEM(S5P_PA_EHCI, SZ_256),
-	[1] = DEFINE_RES_IRQ(IRQ_USB_HOST),
-};
-
-struct platform_device s5p_device_ehci = {
-	.name		= "s5p-ehci",
-	.id		= -1,
-	.num_resources	= ARRAY_SIZE(s5p_ehci_resource),
-	.resource	= s5p_ehci_resource,
-	.dev		= {
-		.dma_mask		= &samsung_device_dma_mask,
-		.coherent_dma_mask	= DMA_BIT_MASK(32),
-	}
-};
-
-void __init s5p_ehci_set_platdata(struct s5p_ehci_platdata *pd)
-{
-	struct s5p_ehci_platdata *npd;
-
-	npd = s3c_set_platdata(pd, sizeof(struct s5p_ehci_platdata),
-			&s5p_device_ehci);
-
-	if (!npd->phy_init)
-		npd->phy_init = s5p_usb_phy_init;
-	if (!npd->phy_exit)
-		npd->phy_exit = s5p_usb_phy_exit;
-}
-#endif /* CONFIG_S5P_DEV_USB_EHCI */
-
 /* USB HSOTG */
 
 #ifdef CONFIG_S3C_DEV_USB_HSOTG
diff --git a/arch/arm/plat-samsung/include/plat/devs.h b/arch/arm/plat-samsung/include/plat/devs.h
index 0dc4ac4..eece188 100644
--- a/arch/arm/plat-samsung/include/plat/devs.h
+++ b/arch/arm/plat-samsung/include/plat/devs.h
@@ -75,7 +75,6 @@  extern struct platform_device s3c_device_usb_hsotg;
 extern struct platform_device s3c_device_usb_hsudc;
 extern struct platform_device s3c_device_wdt;
 
-extern struct platform_device s5p_device_ehci;
 extern struct platform_device s5p_device_fimc0;
 extern struct platform_device s5p_device_fimc1;
 extern struct platform_device s5p_device_fimc2;