diff mbox

[v2,2/3] clk: Add __clk_hw_set_clk helper function

Message ID 1423749510-14525-3-git-send-email-javier.martinez@collabora.co.uk (mailing list archive)
State New, archived
Headers show

Commit Message

Javier Martinez Canillas Feb. 12, 2015, 1:58 p.m. UTC
After the clk API change to return a per-user clock instance, both the
struct clk_core and struct clk pointers from the hw clock needs to be
assigned to clock that share the same state.

In the future the struct clk_core will be removed and this is going to
change again so to avoid having to change the assignments twice in all
the drivers, add a helper function to have an indirection level.

Signed-off-by: Javier Martinez Canillas <javier.martinez@collabora.co.uk>
---

Changes since v1: None, new patch.
---
 include/linux/clk-provider.h | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Stephen Boyd Feb. 12, 2015, 7:55 p.m. UTC | #1
On 02/12/15 05:58, Javier Martinez Canillas wrote:
> After the clk API change to return a per-user clock instance, both the
> struct clk_core and struct clk pointers from the hw clock needs to be
> assigned to clock that share the same state.
>
> In the future the struct clk_core will be removed and this is going to

s/clk_core/clk/?

> change again so to avoid having to change the assignments twice in all
> the drivers, add a helper function to have an indirection level.
>
> Signed-off-by: Javier Martinez Canillas <javier.martinez@collabora.co.uk>
> ---

Reviewed-by: Stephen Boyd <sboyd@codeaurora.org>
Javier Martinez Canillas Feb. 13, 2015, 7:28 a.m. UTC | #2
Hello Stephen,

On 02/12/2015 08:55 PM, Stephen Boyd wrote:
> On 02/12/15 05:58, Javier Martinez Canillas wrote:
>> After the clk API change to return a per-user clock instance, both the
>> struct clk_core and struct clk pointers from the hw clock needs to be
>> assigned to clock that share the same state.
>>
>> In the future the struct clk_core will be removed and this is going to
> 
> s/clk_core/clk/?
>

hrmm, I thought that the plan was to eventually merge clk_core into clk_hw.

In any case, if I got it backwards then I guess that the commit message
could be fixed up by Mike when the patches are applied?

>> change again so to avoid having to change the assignments twice in all
>> the drivers, add a helper function to have an indirection level.
>>
>> Signed-off-by: Javier Martinez Canillas <javier.martinez@collabora.co.uk>
>> ---
> 
> Reviewed-by: Stephen Boyd <sboyd@codeaurora.org>
> 

Thanks a lot for your review.

Best regards,
Javier
--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/include/linux/clk-provider.h b/include/linux/clk-provider.h
index 17dd6e9439d1..5591ea71a8d1 100644
--- a/include/linux/clk-provider.h
+++ b/include/linux/clk-provider.h
@@ -590,6 +590,12 @@  long __clk_mux_determine_rate_closest(struct clk_hw *hw, unsigned long rate,
 			      unsigned long *best_parent_rate,
 			      struct clk_hw **best_parent_p);
 
+static inline void __clk_hw_set_clk(struct clk_hw *dst, struct clk_hw *src)
+{
+	dst->clk = src->clk;
+	dst->core = src->core;
+}
+
 /*
  * FIXME clock api without lock protection
  */