mbox series

[v7,00/15] Fix qla2xxx endianness annotations

Message ID 20200518211712.11395-1-bvanassche@acm.org (mailing list archive)
Headers show
Series Fix qla2xxx endianness annotations | expand

Message

Bart Van Assche May 18, 2020, 9:16 p.m. UTC
Hi Martin,

This patch series fixes the endianness annotations in the qla2xxx driver.
Please consider this patch series for the v5.8 kernel.

Thanks,

Bart.

Changes compared to v6:
- Changed the endianness of qla27xx_fwdt_template.firmware_version from
  CPU-endian into little endian.

Changes compared to v5:
- Added Reviewed-by tags posted as replies to v4 and v5.

Changes compared to v4:
- Addressed Hannes' and most of Arun's review comments.
- Suppressed a clang warning for the patch that suppresses a gcc warning.
- Included three new patches. Two of these patches compensate for recently
  introduced changes (broken C=2 build and using register offsets instead of
  register names) and one new patch to make the last patch in this series
  easier to read.

Changes compared to v3:
- Included several source code cleanup patches, e.g. to address isssues
  detected by checkpatch.

Changes compared to v2:
- Removed one BUILD_BUG_ON() statement.

Changes compared to v1:
- Left out the raw_smp_processor_id() patch because it may take time to achieve
  agreement about this patch.
- Added three patches to this series: two patches for verifying structure size
  at compile time and one patch for changing function names from upper case to
  lower case.

Bart Van Assche (15):
  qla2xxx: Fix spelling of a variable name
  qla2xxx: Suppress two recently introduced compiler warnings
  qla2xxx: Simplify the functions for dumping firmware
  qla2xxx: Sort BUILD_BUG_ON() statements alphabetically
  qla2xxx: Add more BUILD_BUG_ON() statements
  qla2xxx: Make a gap in struct qla2xxx_offld_chain explicit
  qla2xxx: Increase the size of struct qla_fcp_prio_cfg to
    FCP_PRIO_CFG_SIZE
  qla2xxx: Change two hardcoded constants into offsetof() / sizeof()
    expressions
  qla2xxx: Use register names instead of register offsets
  qla2xxx: Fix the code that reads from mailbox registers
  qla2xxx: Change {RD,WRT}_REG_*() function names from upper case into
    lower case
  qla2xxx: Cast explicitly to uint16_t / uint32_t
  qla2xxx: Use make_handle() instead of open-coding it
  qla2xxx: Fix endianness annotations in header files
  qla2xxx: Fix endianness annotations in source files

 drivers/scsi/qla2xxx/qla_attr.c    |   3 +-
 drivers/scsi/qla2xxx/qla_bsg.c     |   8 +-
 drivers/scsi/qla2xxx/qla_dbg.c     | 826 +++++++++++++----------------
 drivers/scsi/qla2xxx/qla_dbg.h     | 443 ++++++++--------
 drivers/scsi/qla2xxx/qla_def.h     | 715 +++++++++++++------------
 drivers/scsi/qla2xxx/qla_fw.h      | 768 +++++++++++++--------------
 drivers/scsi/qla2xxx/qla_gbl.h     |  21 +-
 drivers/scsi/qla2xxx/qla_init.c    | 286 +++++-----
 drivers/scsi/qla2xxx/qla_inline.h  |   8 +-
 drivers/scsi/qla2xxx/qla_iocb.c    | 135 ++---
 drivers/scsi/qla2xxx/qla_isr.c     | 237 ++++-----
 drivers/scsi/qla2xxx/qla_mbx.c     | 123 +++--
 drivers/scsi/qla2xxx/qla_mid.c     |   4 +-
 drivers/scsi/qla2xxx/qla_mr.c      | 115 ++--
 drivers/scsi/qla2xxx/qla_mr.h      |  32 +-
 drivers/scsi/qla2xxx/qla_nvme.c    |  16 +-
 drivers/scsi/qla2xxx/qla_nvme.h    |  64 +--
 drivers/scsi/qla2xxx/qla_nx.c      | 163 +++---
 drivers/scsi/qla2xxx/qla_nx.h      |  36 +-
 drivers/scsi/qla2xxx/qla_nx2.c     |  18 +-
 drivers/scsi/qla2xxx/qla_os.c      | 124 +++--
 drivers/scsi/qla2xxx/qla_sup.c     | 323 +++++------
 drivers/scsi/qla2xxx/qla_target.c  | 104 ++--
 drivers/scsi/qla2xxx/qla_target.h  | 232 ++++----
 drivers/scsi/qla2xxx/qla_tmpl.c    |  41 +-
 drivers/scsi/qla2xxx/qla_tmpl.h    |   2 +-
 drivers/scsi/qla2xxx/tcm_qla2xxx.c |  14 +
 include/trace/events/qla.h         |   7 +
 28 files changed, 2454 insertions(+), 2414 deletions(-)

Comments

Martin K. Petersen May 20, 2020, 2:30 a.m. UTC | #1
On Mon, 18 May 2020 14:16:57 -0700, Bart Van Assche wrote:

> This patch series fixes the endianness annotations in the qla2xxx driver.
> Please consider this patch series for the v5.8 kernel.
> 
> Thanks,
> 
> Bart.
> 
> [...]

Applied to 5.8/scsi-queue, thanks!

[01/15] scsi: qla2xxx: Fix spelling of a variable name
        https://git.kernel.org/mkp/scsi/c/246ee22583ed
[02/15] scsi: qla2xxx: Suppress two recently introduced compiler warnings
        https://git.kernel.org/mkp/scsi/c/fbbc95a49d5b
[03/15] scsi: qla2xxx: Simplify the functions for dumping firmware
        https://git.kernel.org/mkp/scsi/c/8ae178760b23
[04/15] scsi: qla2xxx: Sort BUILD_BUG_ON() statements alphabetically
        https://git.kernel.org/mkp/scsi/c/59d23cf3f2e4
[05/15] scsi: qla2xxx: Add more BUILD_BUG_ON() statements
        https://git.kernel.org/mkp/scsi/c/8a73a0e002b3
[06/15] scsi: qla2xxx: Make a gap in struct qla2xxx_offld_chain explicit
        https://git.kernel.org/mkp/scsi/c/66f863677715
[07/15] scsi: qla2xxx: Increase the size of struct qla_fcp_prio_cfg to FCP_PRIO_CFG_SIZE
        https://git.kernel.org/mkp/scsi/c/d9ab5f1f05fc
[08/15] scsi: qla2xxx: Change two hardcoded constants into offsetof() / sizeof() expressions
        https://git.kernel.org/mkp/scsi/c/e544b720ef31
[09/15] scsi: qla2xxx: Use register names instead of register offsets
        https://git.kernel.org/mkp/scsi/c/c38884162218
[10/15] scsi: qla2xxx: Fix the code that reads from mailbox registers
        https://git.kernel.org/mkp/scsi/c/37139da1b097
[11/15] scsi: qla2xxx: Change {RD,WRT}_REG_*() function names from upper case into lower case
        https://git.kernel.org/mkp/scsi/c/04474d3a1c96
[12/15] scsi: qla2xxx: Cast explicitly to uint16_t / uint32_t
        https://git.kernel.org/mkp/scsi/c/ab053c09ee20
[13/15] scsi: qla2xxx: Use make_handle() instead of open-coding it
        https://git.kernel.org/mkp/scsi/c/2a4b684ab0aa
[14/15] scsi: qla2xxx: Fix endianness annotations in header files
        https://git.kernel.org/mkp/scsi/c/21038b0900d1
[15/15] scsi: qla2xxx: Fix endianness annotations in source files
        https://git.kernel.org/mkp/scsi/c/7ffa5b939751