mbox series

[0/2] scsi: megaraid/megaraid_sas: Use max helper for comparison and assignment

Message ID cover.1674900575.git.drv@mailo.com (mailing list archive)
Headers show
Series scsi: megaraid/megaraid_sas: Use max helper for comparison and assignment | expand

Message

Deepak R Varma Jan. 28, 2023, 10:38 a.m. UTC
This patch set proposes to replace the current if/else or "? :" based logical
evaluation and value assignment by the recommended max() helper macro. Resultant
code is better in terms of type checking and improved readability. 

Deepak R Varma (2):
  scsi: megaraid: Use max helper for comparison and assignment
  scsi: megaraid_sas: Use max helper for comparison and assignment

 drivers/scsi/megaraid.c                   | 3 +--
 drivers/scsi/megaraid/megaraid_sas_base.c | 5 +----
 2 files changed, 2 insertions(+), 6 deletions(-)