Message ID | 20230518075841.40363-8-njavali@marvell.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | qla2xxx klocwork fixes | expand |
On 5/18/23 00:58, Nilesh Javali wrote: > + port_dstate_str_sz = sizeof(port_dstate_str)/sizeof(char *); Please use ARRAY_SIZE() instead of open-coding it. > @@ -121,7 +123,8 @@ qla2x00_set_fcport_disc_state(fc_port_t *fcport, int state) > old_val, (old_val << shiftbits) | state)) { > ql_dbg(ql_dbg_disc, fcport->vha, 0x2134, > "FCPort %8phC disc_state transition: %s to %s - portid=%06x.\n", > - fcport->port_name, port_dstate_str[old_val & mask], > + fcport->port_name, ((old_val & mask) < port_dstate_str_sz) ? > + port_dstate_str[old_val & mask] : "Unknown", > port_dstate_str[state], fcport->d_id.b24); Please do not introduce more parentheses than necessary. The outer parentheses can be removed from the ((old_val & mask) < port_dstate_str_sz) expression without reducing readability. Thanks, Bart.
diff --git a/drivers/scsi/qla2xxx/qla_inline.h b/drivers/scsi/qla2xxx/qla_inline.h index cce6e425c121..ee70cf337242 100644 --- a/drivers/scsi/qla2xxx/qla_inline.h +++ b/drivers/scsi/qla2xxx/qla_inline.h @@ -109,11 +109,13 @@ qla2x00_set_fcport_disc_state(fc_port_t *fcport, int state) { int old_val; uint8_t shiftbits, mask; + uint8_t port_dstate_str_sz; /* This will have to change when the max no. of states > 16 */ shiftbits = 4; mask = (1 << shiftbits) - 1; + port_dstate_str_sz = sizeof(port_dstate_str)/sizeof(char *); fcport->disc_state = state; while (1) { old_val = atomic_read(&fcport->shadow_disc_state); @@ -121,7 +123,8 @@ qla2x00_set_fcport_disc_state(fc_port_t *fcport, int state) old_val, (old_val << shiftbits) | state)) { ql_dbg(ql_dbg_disc, fcport->vha, 0x2134, "FCPort %8phC disc_state transition: %s to %s - portid=%06x.\n", - fcport->port_name, port_dstate_str[old_val & mask], + fcport->port_name, ((old_val & mask) < port_dstate_str_sz) ? + port_dstate_str[old_val & mask] : "Unknown", port_dstate_str[state], fcport->d_id.b24); return; }