diff mbox series

KEYS: Variable type completion

Message ID 20220816180110.8625-1-gaoxin@cdjrlc.com (mailing list archive)
State Handled Elsewhere
Headers show
Series KEYS: Variable type completion | expand

Commit Message

Xin Gao Aug. 16, 2022, 6:01 p.m. UTC
'unsigned int' is better than 'unsigned'.

Signed-off-by: Xin Gao <gaoxin@cdjrlc.com>
---
 security/keys/keyctl.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Al Viro Aug. 16, 2022, 6:14 p.m. UTC | #1
On Wed, Aug 17, 2022 at 02:01:10AM +0800, Xin Gao wrote:
> 'unsigned int' is better than 'unsigned'.

Explain.

You keep sending rather pointless patches with declarative
commit messages instead of explanations.  Why is 'unsigned
int' better than 'unsigned'?  Demonstrate understanding -
simple reference to checkpatch.pl does *NOT* count.
diff mbox series

Patch

diff --git a/security/keys/keyctl.c b/security/keys/keyctl.c
index 96a92a645216..4564505e7594 100644
--- a/security/keys/keyctl.c
+++ b/security/keys/keyctl.c
@@ -44,7 +44,7 @@  static const unsigned char keyrings_capabilities[2] = {
 
 static int key_get_type_from_user(char *type,
 				  const char __user *_type,
-				  unsigned len)
+				  unsigned int len)
 {
 	int ret;