diff mbox series

[2/2] lsm: rename variable to avoid shadowing

Message ID 20241125105926.47141-1-cgoettsche@seltendoof.de (mailing list archive)
State New
Headers show
Series [1/2] lsm: constify function parameters | expand

Commit Message

Christian Göttsche Nov. 25, 2024, 10:59 a.m. UTC
From: Christian Göttsche <cgzones@googlemail.com>

The function dump_common_audit_data() contains two variables with the
name comm: one declared at the top and one nested one.
Rename the nested variable to improve readability and make future refactorings
of the function less error prone.

Reported by clang:

    security/lsm_audit.c:302:10: error: declaration shadows a local variable [-Werror,-Wshadow]
      302 |                                 char comm[sizeof(tsk->comm)];
          |                                      ^
    security/lsm_audit.c:200:7: note: previous declaration is here
      200 |         char comm[sizeof(current->comm)];
          |              ^

Signed-off-by: Christian Göttsche <cgzones@googlemail.com>
---
 security/lsm_audit.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/security/lsm_audit.c b/security/lsm_audit.c
index f1fe99f2221d..429096bf8fe0 100644
--- a/security/lsm_audit.c
+++ b/security/lsm_audit.c
@@ -299,10 +299,10 @@  static void dump_common_audit_data(struct audit_buffer *ab,
 		if (tsk) {
 			pid_t pid = task_tgid_nr(tsk);
 			if (pid) {
-				char comm[sizeof(tsk->comm)];
+				char tskcomm[sizeof(tsk->comm)];
 				audit_log_format(ab, " opid=%d ocomm=", pid);
 				audit_log_untrustedstring(ab,
-				    memcpy(comm, tsk->comm, sizeof(comm)));
+				    memcpy(tskcomm, tsk->comm, sizeof(tskcomm)));
 			}
 		}
 		break;