Message ID | 20230824132832.78705-4-ilpo.jarvinen@linux.intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | None | expand |
On Thu, 2023-08-24 at 16:28 +0300, Ilpo Järvinen wrote: > Instead of a if condition with a line split, use the usual error > handling pattern with a separate variable to improve readability. > > No functional changes intended. > > Signed-off-by: Ilpo Järvinen <ilpo.jarvinen@linux.intel.com> > --- > arch/sh/drivers/pci/common.c | 7 ++++--- > 1 file changed, 4 insertions(+), 3 deletions(-) > > diff --git a/arch/sh/drivers/pci/common.c b/arch/sh/drivers/pci/common.c > index 2fd2b77e12ce..f59e5b9a6a80 100644 > --- a/arch/sh/drivers/pci/common.c > +++ b/arch/sh/drivers/pci/common.c > @@ -53,15 +53,16 @@ int __init pci_is_66mhz_capable(struct pci_channel *hose, > unsigned short vid; > int cap66 = -1; > u16 stat; > + int ret; > > pr_info("PCI: Checking 66MHz capabilities...\n"); > > for (pci_devfn = 0; pci_devfn < 0xff; pci_devfn++) { > if (PCI_FUNC(pci_devfn)) > continue; > - if (early_read_config_word(hose, top_bus, current_bus, > - pci_devfn, PCI_VENDOR_ID, &vid) != > - PCIBIOS_SUCCESSFUL) > + ret = early_read_config_word(hose, top_bus, current_bus, > + pci_devfn, PCI_VENDOR_ID, &vid); > + if (ret != PCIBIOS_SUCCESSFUL) > continue; > if (vid == 0xffff) > continue; Acked-by: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
diff --git a/arch/sh/drivers/pci/common.c b/arch/sh/drivers/pci/common.c index 2fd2b77e12ce..f59e5b9a6a80 100644 --- a/arch/sh/drivers/pci/common.c +++ b/arch/sh/drivers/pci/common.c @@ -53,15 +53,16 @@ int __init pci_is_66mhz_capable(struct pci_channel *hose, unsigned short vid; int cap66 = -1; u16 stat; + int ret; pr_info("PCI: Checking 66MHz capabilities...\n"); for (pci_devfn = 0; pci_devfn < 0xff; pci_devfn++) { if (PCI_FUNC(pci_devfn)) continue; - if (early_read_config_word(hose, top_bus, current_bus, - pci_devfn, PCI_VENDOR_ID, &vid) != - PCIBIOS_SUCCESSFUL) + ret = early_read_config_word(hose, top_bus, current_bus, + pci_devfn, PCI_VENDOR_ID, &vid); + if (ret != PCIBIOS_SUCCESSFUL) continue; if (vid == 0xffff) continue;
Instead of a if condition with a line split, use the usual error handling pattern with a separate variable to improve readability. No functional changes intended. Signed-off-by: Ilpo Järvinen <ilpo.jarvinen@linux.intel.com> --- arch/sh/drivers/pci/common.c | 7 ++++--- 1 file changed, 4 insertions(+), 3 deletions(-)