diff mbox

[1/2] usb: renesas_usbhs: Add device tree bindings documentation

Message ID 53DB7EBA.3080004@renesas.com (mailing list archive)
State Awaiting Upstream
Headers show

Commit Message

Yoshihiro Shimoda Aug. 1, 2014, 11:49 a.m. UTC
Document the device tree bindings for the Renesas USBHS controller.

Signed-off-by: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
---
 .../devicetree/bindings/usb/renesas_usbhs.txt      |   24 ++++++++++++++++++++
 1 file changed, 24 insertions(+)
 create mode 100644 Documentation/devicetree/bindings/usb/renesas_usbhs.txt

Comments

Sergei Shtylyov Aug. 1, 2014, 1:35 p.m. UTC | #1
Hello.

On 08/01/2014 03:49 PM, Yoshihiro Shimoda wrote:

> Document the device tree bindings for the Renesas USBHS controller.

> Signed-off-by: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
> ---
>   .../devicetree/bindings/usb/renesas_usbhs.txt      |   24 ++++++++++++++++++++
>   1 file changed, 24 insertions(+)
>   create mode 100644 Documentation/devicetree/bindings/usb/renesas_usbhs.txt

> diff --git a/Documentation/devicetree/bindings/usb/renesas_usbhs.txt b/Documentation/devicetree/bindings/usb/renesas_usbhs.txt
> new file mode 100644
> index 0000000..e9faa65
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/usb/renesas_usbhs.txt
> @@ -0,0 +1,24 @@
> +Renesas Electronics USBHS driver
> +
> +Required properties:
> +  - compatible: Must contain one of the following:
> +	- "renesas,usbhs-r8a7790"
> +	- "renesas,usbhs-r8a7791"
> +  - reg: Base address and length of the register for the USBHS
> +  - interrupts: Interrupt specifier for the USBHS
> +  - clocks: A list of phandle + clock specifier pairs
> +
> +Optional properties:
> +  - buswait_bwait: Integer to use BUSWAIT register

   Should be named "renesas,buswait-bwait" or probably just "renesas,buswait".

> +  - enable-gpio: A gpio specifier to check GPIO determining if USB function

   Should also be prefixed with "renesas,".

[...]

WBR, Sergei

--
To unsubscribe from this list: send the line "unsubscribe linux-sh" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Yoshihiro Shimoda Aug. 4, 2014, 4:24 a.m. UTC | #2
Hello,

(2014/08/01 22:35), Sergei Shtylyov wrote:
> Hello.
> 
> On 08/01/2014 03:49 PM, Yoshihiro Shimoda wrote:
> 
>> Document the device tree bindings for the Renesas USBHS controller.
> 
>> Signed-off-by: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
>> ---
>>   .../devicetree/bindings/usb/renesas_usbhs.txt      |   24 ++++++++++++++++++++
>>   1 file changed, 24 insertions(+)
>>   create mode 100644 Documentation/devicetree/bindings/usb/renesas_usbhs.txt
> 
>> diff --git a/Documentation/devicetree/bindings/usb/renesas_usbhs.txt b/Documentation/devicetree/bindings/usb/renesas_usbhs.txt
>> new file mode 100644
>> index 0000000..e9faa65
>> --- /dev/null
>> +++ b/Documentation/devicetree/bindings/usb/renesas_usbhs.txt
>> @@ -0,0 +1,24 @@
>> +Renesas Electronics USBHS driver
>> +
>> +Required properties:
>> +  - compatible: Must contain one of the following:
>> +	- "renesas,usbhs-r8a7790"
>> +	- "renesas,usbhs-r8a7791"
>> +  - reg: Base address and length of the register for the USBHS
>> +  - interrupts: Interrupt specifier for the USBHS
>> +  - clocks: A list of phandle + clock specifier pairs
>> +
>> +Optional properties:
>> +  - buswait_bwait: Integer to use BUSWAIT register
> 
>    Should be named "renesas,buswait-bwait" or probably just "renesas,buswait".

Thank you for the point. I will fix this name to "renesas,buswait".

>> +  - enable-gpio: A gpio specifier to check GPIO determining if USB function
> 
>    Should also be prefixed with "renesas,".

I will fix this name to "renesas,enable-gpio".

Best regards,
Yoshihiro Shimoda

> [...]
> 
> WBR, Sergei
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-sh" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/Documentation/devicetree/bindings/usb/renesas_usbhs.txt b/Documentation/devicetree/bindings/usb/renesas_usbhs.txt
new file mode 100644
index 0000000..e9faa65
--- /dev/null
+++ b/Documentation/devicetree/bindings/usb/renesas_usbhs.txt
@@ -0,0 +1,24 @@ 
+Renesas Electronics USBHS driver
+
+Required properties:
+  - compatible: Must contain one of the following:
+	- "renesas,usbhs-r8a7790"
+	- "renesas,usbhs-r8a7791"
+  - reg: Base address and length of the register for the USBHS
+  - interrupts: Interrupt specifier for the USBHS
+  - clocks: A list of phandle + clock specifier pairs
+
+Optional properties:
+  - buswait_bwait: Integer to use BUSWAIT register
+  - enable-gpio: A gpio specifier to check GPIO determining if USB function
+		 should be enabled
+  - phys: phandle + phy specifier pair
+  - phy-names: must be "usb"
+
+Example:
+	usbhs: usb@e6590000 {
+		compatible = "renesas,usbhs-r8a7790";
+		reg = <0 0xe6590000 0 0x100>;
+		interrupts = <0 107 IRQ_TYPE_LEVEL_HIGH>;
+		clocks = <&mstp7_clks R8A7790_CLK_HSUSB>;
+	};