mbox series

[v2,0/3] libtraceevent: Fix double free in process_sizeof()

Message ID 20230324200924.287521-1-rostedt@goodmis.org (mailing list archive)
Headers show
Series libtraceevent: Fix double free in process_sizeof() | expand

Message

Steven Rostedt March 24, 2023, 8:09 p.m. UTC
From: "Steven Rostedt (Google)" <rostedt@goodmis.org>

Google's fuzz testing found a double free in process_sizeof(). That was an
easy fix, but the reason the bug happened was because of that silly "ok"
variable called "ok", which is meaningless for what it is used for.

Also, remove the unneeded test of !ok at the end of the if/else block.

Changes since v1: https://lore.kernel.org/all/20230324200145.287158-1-rostedt@goodmis.org/

- Fix commit message of patch 3 that used "end" originally, but then I thought
  that too was too ambiguous.

Steven Rostedt (Google) (3):
  libtraceevent: Fix double free in parsing sizeof()
  libtraceevent: No need for testing ok in else if (!ok) in
    process_sizeof()
  libtraceevent: Rename "ok" to "token_has_paren" in process_sizeof()

 src/event-parse.c | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)