diff mbox series

trace-cmd: Generate proper soname

Message ID 20190725014808.3646716-1-chutzpah@gentoo.org (mailing list archive)
State Accepted
Commit cb525176be1279034c9a7853a5deea355815e28b
Headers show
Series trace-cmd: Generate proper soname | expand

Commit Message

Patrick McLean July 25, 2019, 1:48 a.m. UTC
From: Patrick McLean <patrick.mclean@sony.com>

The previous soname patch was an earlier version that included the full
path to the build output as the soname (not sure how that happened).
This just uses the basename as the soname, so ld will be able to
properly find the library.
---
 scripts/utils.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Steven Rostedt July 25, 2019, 1:59 a.m. UTC | #1
On Wed, 24 Jul 2019 18:48:08 -0700
Patrick McLean <chutzpah@gentoo.org> wrote:

> From: Patrick McLean <patrick.mclean@sony.com>
> 
> The previous soname patch was an earlier version that included the full
> path to the build output as the soname (not sure how that happened).
> This just uses the basename as the soname, so ld will be able to
> properly find the library.

Ah, so now I need to release a 2.8.4?

Thanks, ;-)

I'll wait till Friday before adding a 2.8.4.

-- Steve

> ---
>  scripts/utils.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/scripts/utils.mk b/scripts/utils.mk
> index 9eb127d..98d7b3c 100644
> --- a/scripts/utils.mk
> +++ b/scripts/utils.mk
> @@ -54,7 +54,7 @@ do_build_static_lib =				\
>  
>  do_compile_shared_library =			\
>  	($(print_shared_lib_compile)		\
> -	$(CC) --shared $^ -Wl,-soname,$@ -o $@)
> +	$(CC) --shared $^ -Wl,-soname,$(@F) -o $@)
>  
>  do_compile_plugin_obj =				\
>  	($(print_plugin_obj_compile)		\
Steven Rostedt July 25, 2019, 12:49 p.m. UTC | #2
On Wed, 24 Jul 2019 18:48:08 -0700
Patrick McLean <chutzpah@gentoo.org> wrote:

> From: Patrick McLean <patrick.mclean@sony.com>
> 
> The previous soname patch was an earlier version that included the full
> path to the build output as the soname (not sure how that happened).
> This just uses the basename as the soname, so ld will be able to
> properly find the library.

Hi Patrick,

You forgot to add the Signed-off-by, can you reply to this with one.
Thanks. I can't add it without it.

-- Steve

> ---
>  scripts/utils.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/scripts/utils.mk b/scripts/utils.mk
> index 9eb127d..98d7b3c 100644
> --- a/scripts/utils.mk
> +++ b/scripts/utils.mk
> @@ -54,7 +54,7 @@ do_build_static_lib =				\
>  
>  do_compile_shared_library =			\
>  	($(print_shared_lib_compile)		\
> -	$(CC) --shared $^ -Wl,-soname,$@ -o $@)
> +	$(CC) --shared $^ -Wl,-soname,$(@F) -o $@)
>  
>  do_compile_plugin_obj =				\
>  	($(print_plugin_obj_compile)		\
Patrick McLean July 25, 2019, 5:08 p.m. UTC | #3
On Thu, 25 Jul 2019 08:49:32 -0400
Steven Rostedt <rostedt@goodmis.org> wrote:

> On Wed, 24 Jul 2019 18:48:08 -0700
> Patrick McLean <chutzpah@gentoo.org> wrote:
> 
> > From: Patrick McLean <patrick.mclean@sony.com>
> > 
> > The previous soname patch was an earlier version that included the
> > full path to the build output as the soname (not sure how that
> > happened). This just uses the basename as the soname, so ld will be
> > able to properly find the library.  
> 
> Hi Patrick,
> 
> You forgot to add the Signed-off-by, can you reply to this with one.
> Thanks. I can't add it without it.
> 
My apologies.

> -- Steve
> 

Signed-off-by: Patrick McLean <patrick.mclean@sony.com>
> > ---
> >  scripts/utils.mk | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/scripts/utils.mk b/scripts/utils.mk
> > index 9eb127d..98d7b3c 100644
> > --- a/scripts/utils.mk
> > +++ b/scripts/utils.mk
> > @@ -54,7 +54,7 @@ do_build_static_lib
> > =				\ 
> >  do_compile_shared_library =			\
> >  	($(print_shared_lib_compile)		\
> > -	$(CC) --shared $^ -Wl,-soname,$@ -o $@)
> > +	$(CC) --shared $^ -Wl,-soname,$(@F) -o $@)
> >  
> >  do_compile_plugin_obj =				\
> >  	($(print_plugin_obj_compile)		\  
>
diff mbox series

Patch

diff --git a/scripts/utils.mk b/scripts/utils.mk
index 9eb127d..98d7b3c 100644
--- a/scripts/utils.mk
+++ b/scripts/utils.mk
@@ -54,7 +54,7 @@  do_build_static_lib =				\
 
 do_compile_shared_library =			\
 	($(print_shared_lib_compile)		\
-	$(CC) --shared $^ -Wl,-soname,$@ -o $@)
+	$(CC) --shared $^ -Wl,-soname,$(@F) -o $@)
 
 do_compile_plugin_obj =				\
 	($(print_plugin_obj_compile)		\