diff mbox series

kernelshark: Rename tracefs_get_tracing_dir() to the new tracefs_tracing_dir()

Message ID 20201221142458.5d5607c6@gandalf.local.home (mailing list archive)
State Accepted
Commit 533b5d04400d926c688b7b2e1066163d1a7a4bd2
Headers show
Series kernelshark: Rename tracefs_get_tracing_dir() to the new tracefs_tracing_dir() | expand

Commit Message

Steven Rostedt Dec. 21, 2020, 7:24 p.m. UTC
From: "Steven Rostedt (VMware)" <rostedt@goodmis.org>

libtracefs is renaming tracefs_get_tracing_dir() to tracefs_tracing_dir() as
there is no "tracefs_put_tracing_dir()" for this function. Since libtracefs
has not been officially released, it is fine to break API, as it is with
kernelshark v2.0 has not yet been official released that uses the old API.

Signen-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
---
 src/KsCaptureDialog.cpp | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Yordan Karadzhov Jan. 4, 2021, 5:03 p.m. UTC | #1
On 21.12.20 г. 21:24 ч., Steven Rostedt wrote:
> From: "Steven Rostedt (VMware)" <rostedt@goodmis.org>
> 
> libtracefs is renaming tracefs_get_tracing_dir() to tracefs_tracing_dir() as
> there is no "tracefs_put_tracing_dir()" for this function. Since libtracefs
> has not been officially released, it is fine to break API, as it is with
> kernelshark v2.0 has not yet been official released that uses the old API.
> 
> Signen-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
> ---
>   src/KsCaptureDialog.cpp | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/src/KsCaptureDialog.cpp b/src/KsCaptureDialog.cpp
> index 63fd5d6..7253ab6 100644
> --- a/src/KsCaptureDialog.cpp
> +++ b/src/KsCaptureDialog.cpp
> @@ -26,7 +26,7 @@ extern "C" {
>   
>   static inline tep_handle *local_events()
>   {
> -	return tracefs_local_events(tracefs_get_tracing_dir());
> +	return tracefs_local_events(tracefs_tracing_dir());
>   }
>   
>   /**
> @@ -204,7 +204,7 @@ QStringList KsCaptureControl::_getPlugins()
>   	QStringList pluginList;
>   	char **all_plugins;
>   
> -	all_plugins = tracefs_tracers(tracefs_get_tracing_dir());
> +	all_plugins = tracefs_tracers(tracefs_tracing_dir());
>   
>   	if (!all_plugins)
>   		return pluginList;
> 

Thanks Steven!
I applied this one on my side before all KS 2.0 patches.

Reviewed-by: Yordan Karadzhov (VMware) <y.karadz@gmail.com>
diff mbox series

Patch

diff --git a/src/KsCaptureDialog.cpp b/src/KsCaptureDialog.cpp
index 63fd5d6..7253ab6 100644
--- a/src/KsCaptureDialog.cpp
+++ b/src/KsCaptureDialog.cpp
@@ -26,7 +26,7 @@  extern "C" {
 
 static inline tep_handle *local_events()
 {
-	return tracefs_local_events(tracefs_get_tracing_dir());
+	return tracefs_local_events(tracefs_tracing_dir());
 }
 
 /**
@@ -204,7 +204,7 @@  QStringList KsCaptureControl::_getPlugins()
 	QStringList pluginList;
 	char **all_plugins;
 
-	all_plugins = tracefs_tracers(tracefs_get_tracing_dir());
+	all_plugins = tracefs_tracers(tracefs_tracing_dir());
 
 	if (!all_plugins)
 		return pluginList;