mbox series

[v3,0/9] device connection: Add support for device graphs

Message ID 20190213074557.66028-1-heikki.krogerus@linux.intel.com (mailing list archive)
Headers show
Series device connection: Add support for device graphs | expand

Message

Heikki Krogerus Feb. 13, 2019, 7:45 a.m. UTC
Hi,

This is the third version of my proposal to add device graph parsing
to the device connection API. There was only one problem reported in
v2 by Jun - kernel-doc entry was missing for the new fwnode member in
struct usb_role_switch_desc - and it's now fixed.

The second version of the series:
https://lkml.org/lkml/2019/1/30/622

The commit message from v1:

This series adds support for OF and ACPI device graph parsing to the
device connection API.

Handling the graph is straightforward, but because I'm adding that
fwnode member to struct device_connection, I had to make sure all the
existing users consider it.

The plan is to only support matching with fwnode in the future, so no
more device name matching. The software fwnodes that we now have in
kernel should make that possible, once we add support for references
to them.

The original RFC:
https://lkml.org/lkml/2018/10/24/619

thanks,

Heikki Krogerus (9):
  platform/x86: intel_cht_int33fe: Prepare for better mux naming scheme
  usb: typec: Rationalize the API for the muxes
  platform/x86: intel_cht_int33fe: Remove old style mux connections
  device connection: Add fwnode member to struct device_connection
  usb: typec: mux: Find the muxes by also matching against the device
    node
  usb: roles: Find the muxes by also matching against the device node
  usb: typec: Find the ports by also matching against the device node
  device connection: Prepare support for firmware described connections
  device connection: Find device connections also from device graphs

 drivers/base/devcon.c                    | 62 ++++++++++++++-
 drivers/platform/x86/intel_cht_int33fe.c | 15 ++--
 drivers/usb/roles/class.c                | 21 +++++-
 drivers/usb/typec/class.c                | 31 ++++++--
 drivers/usb/typec/mux.c                  | 96 ++++++++++++++++++++----
 include/linux/device.h                   |  6 ++
 include/linux/usb/role.h                 |  2 +
 include/linux/usb/typec_mux.h            |  3 +-
 8 files changed, 196 insertions(+), 40 deletions(-)

Comments

Greg KH Feb. 14, 2019, 10:10 a.m. UTC | #1
On Wed, Feb 13, 2019 at 10:45:48AM +0300, Heikki Krogerus wrote:
> Hi,
> 
> This is the third version of my proposal to add device graph parsing
> to the device connection API. There was only one problem reported in
> v2 by Jun - kernel-doc entry was missing for the new fwnode member in
> struct usb_role_switch_desc - and it's now fixed.
> 
> The second version of the series:
> https://lkml.org/lkml/2019/1/30/622
> 
> The commit message from v1:
> 
> This series adds support for OF and ACPI device graph parsing to the
> device connection API.
> 
> Handling the graph is straightforward, but because I'm adding that
> fwnode member to struct device_connection, I had to make sure all the
> existing users consider it.
> 
> The plan is to only support matching with fwnode in the future, so no
> more device name matching. The software fwnodes that we now have in
> kernel should make that possible, once we add support for references
> to them.
> 
> The original RFC:
> https://lkml.org/lkml/2018/10/24/619

All now merged, thanks.

greg k-h
Heikki Krogerus Feb. 15, 2019, 12:47 p.m. UTC | #2
Hi Greg,

On Thu, Feb 14, 2019 at 11:10:44AM +0100, Greg Kroah-Hartman wrote:
> On Wed, Feb 13, 2019 at 10:45:48AM +0300, Heikki Krogerus wrote:
> > Hi,
> > 
> > This is the third version of my proposal to add device graph parsing
> > to the device connection API. There was only one problem reported in
> > v2 by Jun - kernel-doc entry was missing for the new fwnode member in
> > struct usb_role_switch_desc - and it's now fixed.
> > 
> > The second version of the series:
> > https://lkml.org/lkml/2019/1/30/622
> > 
> > The commit message from v1:
> > 
> > This series adds support for OF and ACPI device graph parsing to the
> > device connection API.
> > 
> > Handling the graph is straightforward, but because I'm adding that
> > fwnode member to struct device_connection, I had to make sure all the
> > existing users consider it.
> > 
> > The plan is to only support matching with fwnode in the future, so no
> > more device name matching. The software fwnodes that we now have in
> > kernel should make that possible, once we add support for references
> > to them.
> > 
> > The original RFC:
> > https://lkml.org/lkml/2018/10/24/619
> 
> All now merged, thanks.

It looks like you have not followed the order of the patches in this
series.

You applied at least the patch 4/9 ("device connection: Add fwnode
member to struct device_connection") as the last patch to your
usb-next branch. The rest of the series, patches starting from 5/9,
depend on that patch.

thanks,
Greg KH Feb. 18, 2019, 8:07 a.m. UTC | #3
On Fri, Feb 15, 2019 at 02:47:15PM +0200, Heikki Krogerus wrote:
> Hi Greg,
> 
> On Thu, Feb 14, 2019 at 11:10:44AM +0100, Greg Kroah-Hartman wrote:
> > On Wed, Feb 13, 2019 at 10:45:48AM +0300, Heikki Krogerus wrote:
> > > Hi,
> > > 
> > > This is the third version of my proposal to add device graph parsing
> > > to the device connection API. There was only one problem reported in
> > > v2 by Jun - kernel-doc entry was missing for the new fwnode member in
> > > struct usb_role_switch_desc - and it's now fixed.
> > > 
> > > The second version of the series:
> > > https://lkml.org/lkml/2019/1/30/622
> > > 
> > > The commit message from v1:
> > > 
> > > This series adds support for OF and ACPI device graph parsing to the
> > > device connection API.
> > > 
> > > Handling the graph is straightforward, but because I'm adding that
> > > fwnode member to struct device_connection, I had to make sure all the
> > > existing users consider it.
> > > 
> > > The plan is to only support matching with fwnode in the future, so no
> > > more device name matching. The software fwnodes that we now have in
> > > kernel should make that possible, once we add support for references
> > > to them.
> > > 
> > > The original RFC:
> > > https://lkml.org/lkml/2018/10/24/619
> > 
> > All now merged, thanks.
> 
> It looks like you have not followed the order of the patches in this
> series.
> 
> You applied at least the patch 4/9 ("device connection: Add fwnode
> member to struct device_connection") as the last patch to your
> usb-next branch. The rest of the series, patches starting from 5/9,
> depend on that patch.

Ugh, did I just apply them out of order?  I can't rewrite my tree now,
sorry about that, odd that my sorting didn't work.

I think all of the patches are now in the tree, so I didn't miss
anything, is there anything I can do now?  Want me to revert them and
then add them back in the correct order?

thanks,

greg k-h
Heikki Krogerus Feb. 18, 2019, 8:51 a.m. UTC | #4
On Mon, Feb 18, 2019 at 09:07:27AM +0100, Greg Kroah-Hartman wrote:
> On Fri, Feb 15, 2019 at 02:47:15PM +0200, Heikki Krogerus wrote:
> > Hi Greg,
> > 
> > On Thu, Feb 14, 2019 at 11:10:44AM +0100, Greg Kroah-Hartman wrote:
> > > On Wed, Feb 13, 2019 at 10:45:48AM +0300, Heikki Krogerus wrote:
> > > > Hi,
> > > > 
> > > > This is the third version of my proposal to add device graph parsing
> > > > to the device connection API. There was only one problem reported in
> > > > v2 by Jun - kernel-doc entry was missing for the new fwnode member in
> > > > struct usb_role_switch_desc - and it's now fixed.
> > > > 
> > > > The second version of the series:
> > > > https://lkml.org/lkml/2019/1/30/622
> > > > 
> > > > The commit message from v1:
> > > > 
> > > > This series adds support for OF and ACPI device graph parsing to the
> > > > device connection API.
> > > > 
> > > > Handling the graph is straightforward, but because I'm adding that
> > > > fwnode member to struct device_connection, I had to make sure all the
> > > > existing users consider it.
> > > > 
> > > > The plan is to only support matching with fwnode in the future, so no
> > > > more device name matching. The software fwnodes that we now have in
> > > > kernel should make that possible, once we add support for references
> > > > to them.
> > > > 
> > > > The original RFC:
> > > > https://lkml.org/lkml/2018/10/24/619
> > > 
> > > All now merged, thanks.
> > 
> > It looks like you have not followed the order of the patches in this
> > series.
> > 
> > You applied at least the patch 4/9 ("device connection: Add fwnode
> > member to struct device_connection") as the last patch to your
> > usb-next branch. The rest of the series, patches starting from 5/9,
> > depend on that patch.
> 
> Ugh, did I just apply them out of order?  I can't rewrite my tree now,
> sorry about that, odd that my sorting didn't work.
> 
> I think all of the patches are now in the tree, so I didn't miss
> anything, is there anything I can do now?  Want me to revert them and
> then add them back in the correct order?

The problem is with bisecting, so I'm not sure if reverting helps. I
don't think there's anything else that can be done about this now.


thanks,