mbox series

[0/9] usb: cdns3: Improvements for cdns3 DRD code

Message ID 20200701062004.29908-1-pawell@cadence.com (mailing list archive)
Headers show
Series usb: cdns3: Improvements for cdns3 DRD code | expand

Message

Pawel Laszczak July 1, 2020, 6:19 a.m. UTC
Series introduce some improvements to drd.c, drd.h and core.c files of 
cdns3 driver.

Except for the first (1/9) patch that removes not needed function,
the rest patches make improvements suggested by Dan Carpenter
during reviewing CDNSP driver.
CDNSP is the next Cadence USBSSP  driver which will be upstreamed.
The DRD part is similar for both CDNS3 and CDNSP and Greg suggested
to merge the similar part of DRD code. As first step I want to merge 
some improvemnts.

Pawel Laszczak (9):
  usb: cdns3: Improvement: removed cdns3_get_current_role_driver
    function.
  usb: cdns3: Improvement: removed not needed variables initialization
  usb: cnds3: Improvement: deleted !=
  usb: cdns3: Improvement: return IRQ_NONE explicitly.
  usb: cdns3: Improvement: changed return type from int to bool
  usb: cdns3: Added CDNS3_ID_PERIPHERAL and CDNS3_ID_HOST
  usb: cdns3: Improvement: removed 'goto not_otg'
  usb: cdns3: Improvement: removed overwriting some error code
  usb: cdns3: Impovement: simplify *switch_gadet and *switch_host

 drivers/usb/cdns3/core.c   |  39 +++------
 drivers/usb/cdns3/drd.c    | 165 ++++++++++++++++++++-----------------
 drivers/usb/cdns3/drd.h    |  13 ++-
 drivers/usb/cdns3/gadget.c |   4 +-
 drivers/usb/cdns3/host.c   |   4 +-
 5 files changed, 114 insertions(+), 111 deletions(-)

Comments

Peter Chen July 7, 2020, 6:18 a.m. UTC | #1
On 20-07-01 08:19:55, Pawel Laszczak wrote:
> Series introduce some improvements to drd.c, drd.h and core.c files of 
> cdns3 driver.
> 
> Except for the first (1/9) patch that removes not needed function,
> the rest patches make improvements suggested by Dan Carpenter
> during reviewing CDNSP driver.
> CDNSP is the next Cadence USBSSP  driver which will be upstreamed.
> The DRD part is similar for both CDNS3 and CDNSP and Greg suggested
> to merge the similar part of DRD code. As first step I want to merge 
> some improvemnts.
> 
> Pawel Laszczak (9):
>   usb: cdns3: Improvement: removed cdns3_get_current_role_driver
>     function.
>   usb: cdns3: Improvement: removed not needed variables initialization
>   usb: cnds3: Improvement: deleted !=
>   usb: cdns3: Improvement: return IRQ_NONE explicitly.
>   usb: cdns3: Improvement: changed return type from int to bool
>   usb: cdns3: Added CDNS3_ID_PERIPHERAL and CDNS3_ID_HOST
>   usb: cdns3: Improvement: removed 'goto not_otg'
>   usb: cdns3: Improvement: removed overwriting some error code
>   usb: cdns3: Impovement: simplify *switch_gadet and *switch_host
> 

There is no part named "Improvement", please replace it with
drd/core/gadget etc.

Peter

>  drivers/usb/cdns3/core.c   |  39 +++------
>  drivers/usb/cdns3/drd.c    | 165 ++++++++++++++++++++-----------------
>  drivers/usb/cdns3/drd.h    |  13 ++-
>  drivers/usb/cdns3/gadget.c |   4 +-
>  drivers/usb/cdns3/host.c   |   4 +-
>  5 files changed, 114 insertions(+), 111 deletions(-)
> 
> -- 
> 2.17.1
>