diff mbox series

[v8,4/4] arm64: boot: dts: qcom: pm8150b: Add DTS node for PMIC VBUS booster

Message ID 20200812071925.315-5-wcheng@codeaurora.org (mailing list archive)
State Superseded
Headers show
Series Introduce PMIC based USB type C detection | expand

Commit Message

Wesley Cheng Aug. 12, 2020, 7:19 a.m. UTC
Add the required DTS node for the USB VBUS output regulator, which is
available on PM8150B.  This will provide the VBUS source to connected
peripherals.

Signed-off-by: Wesley Cheng <wcheng@codeaurora.org>
---
 arch/arm64/boot/dts/qcom/pm8150b.dtsi   | 6 ++++++
 arch/arm64/boot/dts/qcom/sm8150-mtp.dts | 4 ++++
 2 files changed, 10 insertions(+)

Comments

Sergey Shtylyov Aug. 12, 2020, 9:34 a.m. UTC | #1
Hello!

On 12.08.2020 10:19, Wesley Cheng wrote:

> Add the required DTS node for the USB VBUS output regulator, which is
> available on PM8150B.  This will provide the VBUS source to connected
> peripherals.
> 
> Signed-off-by: Wesley Cheng <wcheng@codeaurora.org>
> ---
>   arch/arm64/boot/dts/qcom/pm8150b.dtsi   | 6 ++++++
>   arch/arm64/boot/dts/qcom/sm8150-mtp.dts | 4 ++++
>   2 files changed, 10 insertions(+)
> 
> diff --git a/arch/arm64/boot/dts/qcom/pm8150b.dtsi b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
> index 053c659734a7..9e560c1ca30d 100644
> --- a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
> +++ b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
> @@ -53,6 +53,12 @@ power-on@800 {
>   			status = "disabled";
>   		};
>   
> +		pm8150b_vbus: dcdc@1100 {

    s/dcdc/regulator/? What is "dcdc", anyway?
    The device nodes must have the generic names, according to the DT spec.

> +			compatible = "qcom,pm8150b-vbus-reg";
> +			status = "disabled";
> +			reg = <0x1100>;
> +		};
> +
>   		pm8150b_typec: typec@1500 {
>   			compatible = "qcom,pm8150b-usb-typec";
>   			status = "disabled";
[...]

MBR, Sergei
Wesley Cheng Aug. 20, 2020, 7:47 a.m. UTC | #2
On 8/12/2020 2:34 AM, Sergei Shtylyov wrote:
> Hello!
> 
> On 12.08.2020 10:19, Wesley Cheng wrote:
> 
>> Add the required DTS node for the USB VBUS output regulator, which is
>> available on PM8150B.  This will provide the VBUS source to connected
>> peripherals.
>>
>> Signed-off-by: Wesley Cheng <wcheng@codeaurora.org>
>> ---
>>   arch/arm64/boot/dts/qcom/pm8150b.dtsi   | 6 ++++++
>>   arch/arm64/boot/dts/qcom/sm8150-mtp.dts | 4 ++++
>>   2 files changed, 10 insertions(+)
>>
>> diff --git a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>> b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>> index 053c659734a7..9e560c1ca30d 100644
>> --- a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>> +++ b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>> @@ -53,6 +53,12 @@ power-on@800 {
>>               status = "disabled";
>>           };
>>   +        pm8150b_vbus: dcdc@1100 {
> 
>    s/dcdc/regulator/? What is "dcdc", anyway?
>    The device nodes must have the generic names, according to the DT spec.
> 

Hi Sergei,

Thanks for the comment!

DCDC is the label that we use for the DC to DC converter block, since
the VBUS booster will output 5V to the connected devices.  Would it make
more sense to have "dc-dc?"

Thanks
Wesley

>> +            compatible = "qcom,pm8150b-vbus-reg";
>> +            status = "disabled";
>> +            reg = <0x1100>;
>> +        };
>> +
>>           pm8150b_typec: typec@1500 {
>>               compatible = "qcom,pm8150b-usb-typec";
>>               status = "disabled";
> [...]
> 
> MBR, Sergei
Sergey Shtylyov Aug. 20, 2020, 9:06 a.m. UTC | #3
On 20.08.2020 10:47, Wesley Cheng wrote:

[...]
>>> Add the required DTS node for the USB VBUS output regulator, which is
>>> available on PM8150B.  This will provide the VBUS source to connected
>>> peripherals.
>>>
>>> Signed-off-by: Wesley Cheng <wcheng@codeaurora.org>
>>> ---
>>>    arch/arm64/boot/dts/qcom/pm8150b.dtsi   | 6 ++++++
>>>    arch/arm64/boot/dts/qcom/sm8150-mtp.dts | 4 ++++
>>>    2 files changed, 10 insertions(+)
>>>
>>> diff --git a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>>> b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>>> index 053c659734a7..9e560c1ca30d 100644
>>> --- a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>>> +++ b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>>> @@ -53,6 +53,12 @@ power-on@800 {
>>>                status = "disabled";
>>>            };
>>>    +        pm8150b_vbus: dcdc@1100 {
>>
>>     s/dcdc/regulator/? What is "dcdc", anyway?
>>     The device nodes must have the generic names, according to the DT spec.
>>
> 
> Hi Sergei,
> 
> Thanks for the comment!

     You're welcome.

> DCDC is the label that we use for the DC to DC converter block, since
> the VBUS booster will output 5V to the connected devices.  Would it make
> more sense to have "dc-dc?"

    Better use s/th like "regulator-dcdc". As I said, the names should be 
generic, reflecting the device class.

> Thanks
> Wesley
> 
>>> +            compatible = "qcom,pm8150b-vbus-reg";
>>> +            status = "disabled";
>>> +            reg = <0x1100>;
>>> +        };
>>> +
>>>            pm8150b_typec: typec@1500 {
>>>                compatible = "qcom,pm8150b-usb-typec";
>>>                status = "disabled";
>> [...]

MBR, Sergei
Bjorn Andersson Aug. 30, 2020, 5:52 p.m. UTC | #4
On Thu 20 Aug 07:47 UTC 2020, Wesley Cheng wrote:

> 
> 
> On 8/12/2020 2:34 AM, Sergei Shtylyov wrote:
> > Hello!
> > 
> > On 12.08.2020 10:19, Wesley Cheng wrote:
> > 
> >> Add the required DTS node for the USB VBUS output regulator, which is
> >> available on PM8150B.  This will provide the VBUS source to connected
> >> peripherals.
> >>
> >> Signed-off-by: Wesley Cheng <wcheng@codeaurora.org>
> >> ---
> >>   arch/arm64/boot/dts/qcom/pm8150b.dtsi   | 6 ++++++
> >>   arch/arm64/boot/dts/qcom/sm8150-mtp.dts | 4 ++++
> >>   2 files changed, 10 insertions(+)
> >>
> >> diff --git a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
> >> b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
> >> index 053c659734a7..9e560c1ca30d 100644
> >> --- a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
> >> +++ b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
> >> @@ -53,6 +53,12 @@ power-on@800 {
> >>               status = "disabled";
> >>           };
> >>   +        pm8150b_vbus: dcdc@1100 {
> > 
> >    s/dcdc/regulator/? What is "dcdc", anyway?
> >    The device nodes must have the generic names, according to the DT spec.
> > 
> 
> Hi Sergei,
> 
> Thanks for the comment!
> 
> DCDC is the label that we use for the DC to DC converter block, since
> the VBUS booster will output 5V to the connected devices.  Would it make
> more sense to have "dc-dc?"
> 

At this level it's just a regulator at 0x1100, so it should be
"regulator@1100". If you would like a more useful name in the running
system you should be able to use the "regulator-name" property.

Regards,
Bjorn

> Thanks
> Wesley
> 
> >> +            compatible = "qcom,pm8150b-vbus-reg";
> >> +            status = "disabled";
> >> +            reg = <0x1100>;
> >> +        };
> >> +
> >>           pm8150b_typec: typec@1500 {
> >>               compatible = "qcom,pm8150b-usb-typec";
> >>               status = "disabled";
> > [...]
> > 
> > MBR, Sergei
> 
> -- 
> The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
> a Linux Foundation Collaborative Project
Wesley Cheng Sept. 3, 2020, 9:50 p.m. UTC | #5
On 8/30/2020 10:52 AM, Bjorn Andersson wrote:
> On Thu 20 Aug 07:47 UTC 2020, Wesley Cheng wrote:
> 
>>
>>
>> On 8/12/2020 2:34 AM, Sergei Shtylyov wrote:
>>> Hello!
>>>
>>> On 12.08.2020 10:19, Wesley Cheng wrote:
>>>
>>>> Add the required DTS node for the USB VBUS output regulator, which is
>>>> available on PM8150B.  This will provide the VBUS source to connected
>>>> peripherals.
>>>>
>>>> Signed-off-by: Wesley Cheng <wcheng@codeaurora.org>
>>>> ---
>>>>   arch/arm64/boot/dts/qcom/pm8150b.dtsi   | 6 ++++++
>>>>   arch/arm64/boot/dts/qcom/sm8150-mtp.dts | 4 ++++
>>>>   2 files changed, 10 insertions(+)
>>>>
>>>> diff --git a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>>>> b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>>>> index 053c659734a7..9e560c1ca30d 100644
>>>> --- a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>>>> +++ b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
>>>> @@ -53,6 +53,12 @@ power-on@800 {
>>>>               status = "disabled";
>>>>           };
>>>>   +        pm8150b_vbus: dcdc@1100 {
>>>
>>>    s/dcdc/regulator/? What is "dcdc", anyway?
>>>    The device nodes must have the generic names, according to the DT spec.
>>>
>>
>> Hi Sergei,
>>
>> Thanks for the comment!
>>
>> DCDC is the label that we use for the DC to DC converter block, since
>> the VBUS booster will output 5V to the connected devices.  Would it make
>> more sense to have "dc-dc?"
>>
> 
> At this level it's just a regulator at 0x1100, so it should be
> "regulator@1100". If you would like a more useful name in the running
> system you should be able to use the "regulator-name" property.
> 
> Regards,
> Bjorn
> 

Hi Bjorn,

Thanks for the suggestion.  Sounds good, I will just use the "regulator"
name for now.

Thanks
Wesley

>> Thanks
>> Wesley
>>
>>>> +            compatible = "qcom,pm8150b-vbus-reg";
>>>> +            status = "disabled";
>>>> +            reg = <0x1100>;
>>>> +        };
>>>> +
>>>>           pm8150b_typec: typec@1500 {
>>>>               compatible = "qcom,pm8150b-usb-typec";
>>>>               status = "disabled";
>>> [...]
>>>
>>> MBR, Sergei
>>
>> -- 
>> The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum,
>> a Linux Foundation Collaborative Project
diff mbox series

Patch

diff --git a/arch/arm64/boot/dts/qcom/pm8150b.dtsi b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
index 053c659734a7..9e560c1ca30d 100644
--- a/arch/arm64/boot/dts/qcom/pm8150b.dtsi
+++ b/arch/arm64/boot/dts/qcom/pm8150b.dtsi
@@ -53,6 +53,12 @@  power-on@800 {
 			status = "disabled";
 		};
 
+		pm8150b_vbus: dcdc@1100 {
+			compatible = "qcom,pm8150b-vbus-reg";
+			status = "disabled";
+			reg = <0x1100>;
+		};
+
 		pm8150b_typec: typec@1500 {
 			compatible = "qcom,pm8150b-usb-typec";
 			status = "disabled";
diff --git a/arch/arm64/boot/dts/qcom/sm8150-mtp.dts b/arch/arm64/boot/dts/qcom/sm8150-mtp.dts
index 6c6325c3af59..ba3b5b802954 100644
--- a/arch/arm64/boot/dts/qcom/sm8150-mtp.dts
+++ b/arch/arm64/boot/dts/qcom/sm8150-mtp.dts
@@ -409,6 +409,10 @@  &ufs_mem_phy {
 	vdda-pll-max-microamp = <19000>;
 };
 
+&pm8150b_vbus {
+	status = "okay";
+};
+
 &usb_1_hsphy {
 	status = "okay";
 	vdda-pll-supply = <&vdd_usb_hs_core>;