mbox series

[v1,net-next,00/10] Use build_skb and reorganize some code in ENA

Message ID 20210608160118.3767932-1-shayagr@amazon.com (mailing list archive)
Headers show
Series Use build_skb and reorganize some code in ENA | expand

Message

Shay Agroskin June 8, 2021, 4:01 p.m. UTC
Hi all,
this patchset introduces several changes:

- Use build_skb() on RX side.
  This allows to ensure that the headers are in the linear part

- Batch some code into functions and remove some of the code to make it more
  readable and less error prone

- Fix RST format and outdated description in ENA documentation

- Improve cache alignment in the code

Please review

Shay Agroskin (10):
  net: ena: optimize data access in fast-path code
  net: ena: Remove unused code
  net: ena: Improve error logging in driver
  net: ena: use build_skb() in RX path
  net: ena: add jiffies of last napi call to stats
  net: ena: Remove module param and change message severity
  net: ena: fix RST format in ENA documentation file
  net: ena: aggregate doorbell common operations into a function
  net: ena: Use dev_alloc() in RX buffer allocation
  net: ena: re-organize code to improve readability

 .../device_drivers/ethernet/amazon/ena.rst    | 164 +++++++------
 .../net/ethernet/amazon/ena/ena_admin_defs.h  |   2 -
 drivers/net/ethernet/amazon/ena/ena_com.c     |   3 +-
 drivers/net/ethernet/amazon/ena/ena_eth_com.c |  30 ++-
 drivers/net/ethernet/amazon/ena/ena_ethtool.c |  18 +-
 drivers/net/ethernet/amazon/ena/ena_netdev.c  | 216 ++++++++++--------
 drivers/net/ethernet/amazon/ena/ena_netdev.h  |  23 +-
 7 files changed, 249 insertions(+), 207 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org June 8, 2021, 9:50 p.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (refs/heads/master):

On Tue, 8 Jun 2021 19:01:08 +0300 you wrote:
> Hi all,
> this patchset introduces several changes:
> 
> - Use build_skb() on RX side.
>   This allows to ensure that the headers are in the linear part
> 
> - Batch some code into functions and remove some of the code to make it more
>   readable and less error prone
> 
> [...]

Here is the summary with links:
  - [v1,net-next,01/10] net: ena: optimize data access in fast-path code
    https://git.kernel.org/netdev/net-next/c/e4ac382ebfb4
  - [v1,net-next,02/10] net: ena: Remove unused code
    https://git.kernel.org/netdev/net-next/c/9912c72edd8c
  - [v1,net-next,03/10] net: ena: Improve error logging in driver
    https://git.kernel.org/netdev/net-next/c/091d0e85a0d4
  - [v1,net-next,04/10] net: ena: use build_skb() in RX path
    https://git.kernel.org/netdev/net-next/c/9e5269a915a8
  - [v1,net-next,05/10] net: ena: add jiffies of last napi call to stats
    https://git.kernel.org/netdev/net-next/c/0ee251cd9a63
  - [v1,net-next,06/10] net: ena: Remove module param and change message severity
    https://git.kernel.org/netdev/net-next/c/15efff76491e
  - [v1,net-next,07/10] net: ena: fix RST format in ENA documentation file
    https://git.kernel.org/netdev/net-next/c/511c537bb564
  - [v1,net-next,08/10] net: ena: aggregate doorbell common operations into a function
    https://git.kernel.org/netdev/net-next/c/9e8afb059611
  - [v1,net-next,09/10] net: ena: Use dev_alloc() in RX buffer allocation
    https://git.kernel.org/netdev/net-next/c/947c54c395cb
  - [v1,net-next,10/10] net: ena: re-organize code to improve readability
    https://git.kernel.org/netdev/net-next/c/a01f2cd0ccf4

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html