mbox series

[v1,net-next,0/5] lynx pcs interface cleanup

Message ID 20211229032237.912649-1-colin.foster@in-advantage.com (mailing list archive)
Headers show
Series lynx pcs interface cleanup | expand

Message

Colin Foster Dec. 29, 2021, 3:22 a.m. UTC
The current Felix driver (and Seville) rely directly on the lynx_pcs
device. There are other possible PCS interfaces that can be used with
this hardware, so this should be abstracted from felix. The generic
phylink_pcs is used instead.

While going through the code, there were some opportunities to change
some misleading variable names. Those are included in this patch set.


Colin Foster (5):
  net: phy: lynx: refactor Lynx PCS module to use generic phylink_pcs
  net: dsa: felix: name change for clarity from pcs to mdio_device
  net: dsa: seville: name change for clarity from pcs to mdio_device
  net: ethernet: enetc: name change for clarity from pcs to mdio_device
  net: pcs: lynx: use a common naming scheme for all lynx_pcs variables

 drivers/net/dsa/ocelot/felix.c                |  3 +-
 drivers/net/dsa/ocelot/felix.h                |  2 +-
 drivers/net/dsa/ocelot/felix_vsc9959.c        | 28 ++++++++-------
 drivers/net/dsa/ocelot/seville_vsc9953.c      | 28 ++++++++-------
 .../net/ethernet/freescale/dpaa2/dpaa2-mac.c  | 12 ++++---
 .../net/ethernet/freescale/dpaa2/dpaa2-mac.h  |  3 +-
 .../net/ethernet/freescale/enetc/enetc_pf.c   | 27 +++++++-------
 .../net/ethernet/freescale/enetc/enetc_pf.h   |  4 +--
 drivers/net/pcs/pcs-lynx.c                    | 36 +++++++++++++------
 include/linux/pcs-lynx.h                      |  9 ++---
 10 files changed, 86 insertions(+), 66 deletions(-)