mbox series

[v2,net-next,0/5] lynx pcs interface cleanup

Message ID 20211229050310.1153868-1-colin.foster@in-advantage.com (mailing list archive)
Headers show
Series lynx pcs interface cleanup | expand

Message

Colin Foster Dec. 29, 2021, 5:03 a.m. UTC
The current Felix driver (and Seville) rely directly on the lynx_pcs
device. There are other possible PCS interfaces that can be used with
this hardware, so this should be abstracted from felix. The generic
phylink_pcs is used instead.

While going through the code, there were some opportunities to change
some misleading variable names. Those are included in this patch set.

v1->v2
    * compile-time fixes for freescale parts


Colin Foster (5):
  net: phy: lynx: refactor Lynx PCS module to use generic phylink_pcs
  net: dsa: felix: name change for clarity from pcs to mdio_device
  net: dsa: seville: name change for clarity from pcs to mdio_device
  net: ethernet: enetc: name change for clarity from pcs to mdio_device
  net: pcs: lynx: use a common naming scheme for all lynx_pcs variables

 drivers/net/dsa/ocelot/felix.c                |  3 +-
 drivers/net/dsa/ocelot/felix.h                |  2 +-
 drivers/net/dsa/ocelot/felix_vsc9959.c        | 28 ++++++++-------
 drivers/net/dsa/ocelot/seville_vsc9953.c      | 28 ++++++++-------
 .../net/ethernet/freescale/dpaa2/dpaa2-mac.c  | 13 ++++---
 .../net/ethernet/freescale/dpaa2/dpaa2-mac.h  |  3 +-
 .../net/ethernet/freescale/enetc/enetc_pf.c   | 28 ++++++++-------
 .../net/ethernet/freescale/enetc/enetc_pf.h   |  4 +--
 drivers/net/pcs/pcs-lynx.c                    | 36 +++++++++++++------
 include/linux/pcs-lynx.h                      |  9 ++---
 10 files changed, 88 insertions(+), 66 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org Jan. 2, 2022, 7 p.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (master)
by David S. Miller <davem@davemloft.net>:

On Tue, 28 Dec 2021 21:03:05 -0800 you wrote:
> The current Felix driver (and Seville) rely directly on the lynx_pcs
> device. There are other possible PCS interfaces that can be used with
> this hardware, so this should be abstracted from felix. The generic
> phylink_pcs is used instead.
> 
> While going through the code, there were some opportunities to change
> some misleading variable names. Those are included in this patch set.
> 
> [...]

Here is the summary with links:
  - [v2,net-next,1/5] net: phy: lynx: refactor Lynx PCS module to use generic phylink_pcs
    https://git.kernel.org/netdev/net-next/c/e7026f15564f
  - [v2,net-next,2/5] net: dsa: felix: name change for clarity from pcs to mdio_device
    https://git.kernel.org/netdev/net-next/c/61f0d0c304a2
  - [v2,net-next,3/5] net: dsa: seville: name change for clarity from pcs to mdio_device
    https://git.kernel.org/netdev/net-next/c/2c1415e67f93
  - [v2,net-next,4/5] net: ethernet: enetc: name change for clarity from pcs to mdio_device
    https://git.kernel.org/netdev/net-next/c/82cc453753c5
  - [v2,net-next,5/5] net: pcs: lynx: use a common naming scheme for all lynx_pcs variables
    https://git.kernel.org/netdev/net-next/c/0699b3e06f22

You are awesome, thank you!